Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

SG300-20 - Configure DHCP on VLAN interface

I have been reading the various related discussions on the SG300 and SG500 switches regarding setting up VLAN's and DHCP on those VLAN's.  For whatever reason I have been unable to even get this simple task to work.

First thing I did was to update my firmware and boot version as follows:

SW version    1.3.7.18 ( date  12-Jan-2014 time  18:02:59 )

Boot version    1.3.5.06 ( date  21-Jul-2013 time  15:12:10 )

HW version    V02

When I reloaded the SG300 after the SW/Boot updates the startup config was wiped out and I had to setup my switch from scratch.  The intent is to have two VLAN's:

VLAN 1: all devices, servers, etc.

VLAN 2: basic subnet that hands out DHCP addresses

The SG300-20 is connected to an Asus RT-AC66U router on the 192.168.1.x subnet and provides internal network access and WiFi access (router IP address is 192.168.1.1 and is default gateway).  All that works with no issues.  So my task is simply to create VLAN 2 on 192.168.2.x subnet and use DHCP to allocate addresses.  I have spent many hours on this and I still can't get it to work.  When I connect a laptop to the port (GI8) assigned to VLAN 2, I end up getting some wonky 169.254.x.x address.  I certainly thought something this "easy" wouldn't be that hard to setup, but apparently I was wrong.

The SG300 is running in L3 mode as shown in my running-config below.

Does anyone happen to see something that might be preventing my laptop client from recieving IP addresses from the VLAN 2 DHCP interface that are not in the 192.168.2.x subnet?

Any ideas / suggestions would be greatly appreciated!

Here's my running-config:

config-file-header
MYSTICSW1
v1.3.7.18 / R750_NIK_1_35_647_358
CLI v1.0
set system mode router

file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
vlan database
vlan 2
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
bonjour interface range vlan 1
hostname MYSTICSW1
logging host 192.168.1.15
logging origin-id hostname
username cisco password encrypted b4a0fcf20b2cd9d80a55b06ab8f83277f9733904 privilege 15
snmp-server location Office
clock timezone " " -5
clock summer-time web recurring usa
clock source sntp
sntp unicast client enable
sntp unicast client poll
sntp server 192.168.1.10 poll
!
interface vlan 1
ip address 192.168.1.254 255.255.255.0
no ip address dhcp
!
interface vlan 2
name MysticWAN
ip address 192.168.2.254 255.255.255.0
!
interface gigabitethernet8
switchport mode access
switchport access vlan 2
!
exit
ip default-gateway 192.168.1.1

Thanks in advance!

Clint Lambert

1 ACCEPTED SOLUTION

Accepted Solutions
Green

SG300-20 - Configure DHCP on VLAN interface

Clint, please review this post

https://supportforums.cisco.com/message/4178990#4178990

-Tom
Please mark answered for helpful posts
http://blogs.cisco.com/smallbusiness/

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
2 REPLIES
Green

SG300-20 - Configure DHCP on VLAN interface

Clint, please review this post

https://supportforums.cisco.com/message/4178990#4178990

-Tom
Please mark answered for helpful posts
http://blogs.cisco.com/smallbusiness/

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Community Member

Re: SG300-20 - Configure DHCP on VLAN interface

Tom,

Thanks ... I followed the steps you outlined and it worked!  The only difference being that I have an Asus RT-AC66U router and the there is no "enable multiple subnet" option.  So, I just followed your instructions on creating the static routes in the RT-AC66U and everything worked.  The DHCP addresses were correct and I had internet connectivity when I plugged a laptop into the gi8 port.

I did make one tweak to the Network Pools screen as follows:

2014-03-02_12-19-29.jpg

My DHCP configuration for gi8 on VLAN 2 now looks like:

ip dhcp server

ip dhcp pool network InternalWAN

address low 192.168.2.1 high 192.168.2.99 255.255.255.0

lease infinite

domain-name MYSTIC

default-router 192.168.2.254

dns-server 8.8.8.8

Previously I had followed your advice in the article "Need help configuring SG300-10 switch" and had setup everything using CLI.  However, I didn't think about needing the static routes.  So, I think it was probably setup correctly beforehand but had no chance to work because the routes were not setup.

Thanks very much for your help!

Clint

10120
Views
0
Helpful
2
Replies
CreatePlease to create content