Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SG300-28P Voice VLAN issue

Hi,

I was running firmware 1.1.2.0 and everything was working fine on 2 of these switches, connected via fiber.  I tried upgrading to the latest firmware (1.3.5.58) and had no luck.  Our phones which are Avaya 9650 VOIP handsets could not find the router, would not find DHCP, and were waiting for LLDP.  The update was only applied on the further away switch from the PBX, yet it still messed up the other switch.  I put the firmware back to the original active version and everything started working again.

Nothing else changed except when I rolled back from the firmware version It left any phones plugged in to ports, it changed their tagging to untagged.  I put this back and everything worked fine. 

Is there an incompatiblity with this firmware with my phones, or what else could be the problem?

Everyone's tags (6)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Green

SG300-28P Voice VLAN issue

Hi Chris, I think one of the problem is, the 1.1.2.0 is very different than every release after. When the 1.2.7.76 firmware was introduced it changed the XML in the switch. If you're jumping up from the 1.1.2.0 to any later release you really should erase your switch config and do not reload a config file.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
4 REPLIES
Highlighted
Green

SG300-28P Voice VLAN issue

Hi Chris, I think one of the problem is, the 1.1.2.0 is very different than every release after. When the 1.2.7.76 firmware was introduced it changed the XML in the switch. If you're jumping up from the 1.1.2.0 to any later release you really should erase your switch config and do not reload a config file.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

SG300-28P Voice VLAN issue

Interesting idea Tom.  It could be worth a try, even though it would be a decent amount of work.  Is there other evidence of this firmware "jump" causing other issues besides mine?

Green

SG300-28P Voice VLAN issue

https://supportforums.cisco.com/search.jspa?peopleEnabled=true&userID=&containerType=14&container=2141&spotlight=true&q=1.2.7.76+xml

If you want to dig through some posts.

I'm sure could find some. It looks like the 1.2.7.76 release notes were removed off the download page even.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

This solved it for me.  I

This solved it for me.  I bought a new switch, built config from scratch after upgrading to the latest version of the firmware and installed.  No issues.  This switch just doesn't like to upgrade to this version.  Thanks for your help!

603
Views
5
Helpful
4
Replies
CreatePlease login to create content