Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SG300/500 L3 changing management VLAN IP?

Why is it such a pain to change the IP?  I know now that you have the set the management vlan IP as static before doing anything else but once that's done and you then add more vlans and with their own static IPs why can't I change the management IP to something else should I desire. 

When I try and it hangs is that because the attempt forces the sw to change management vlans and then because I can't save the config cuz I'm not on that vlan, acually I'm working remotely and not physically connected, the change isn't saved and my remote power cycling of the sw just brings me back to square one. Just like when leaving the management set as DHCP and then adding a vlan with a static IP seemingly hangs the sw when in reality it just changes your management vlan.

Of course you can't change the IP if already static even if no other vlans are yet defined.  At least I couldn't, I'm sure there's some convoluted method that I couldn't grasp.

If that's the case do I need to be onsite and set up an access port for the next vlan in line that will presumably become to be the management vlan when I attempt the IP change.

6 REPLIES
Green

SG300/500 L3 changing management VLAN IP?

Hi Vini, in layer 3 mode, each VLAN interface is considered a management IP.

I'm glad you got past the static IP for VLAN 1 as that's the true caveat. If you log in to a fresh reset layer 3 switch

config t

int vlan 1

ip address 192.168.1.254 /24

this sets static from dynamic then you can create additional vlan interface

config t

vlan database

vlan 2-10

int vlan 2

ip address 192.168.2.254 /24

int vlan 3

ip address 192.168.3.254 /24

From here, if you desire to change vlan 1 it should be no issue, naturally you will loose connection until you reconnet to the new ip

config t

int vlan 1

ip address 192.168.1.200 /24

------> at this point you should lose connectivity until you reconnect at the 192.168.1.200.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

SG300/500 L3 changing management VLAN IP?

Everytime I try that exact same procedure for vlan 1 I get.

Currently vlan 1 it's set to 192.168.175.148 and all my other vlan management ips are 192.168.x.10

conf t

Int vlan 1

ip address 192.168.175.10 /24

Duplicated IP interface on same subnet

If I then do

no ip address 192.168.175.10

ip address 192.168.175.10 does not exist on interface

Any idea why?

Green

SG300/500 L3 changing management VLAN IP?

Hi Vini, can you post a show run of the switch at it's current state of when it produces the error?

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

SG300/500 L3 changing management VLAN IP?

Here the Show Run, Show Vlans and Show IP Route

SW-SG300-28-1#show run

config-file-header
SW-SG300-28-1
v1.3.0.62 / R750_NIK_1_3_647_260
CLI v1.0
set system mode router

file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
vlan database
vlan 25,75,100
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
bonjour interface range vlan 1
hostname SW-SG300-28-1
line console
exec-timeout 30
exit
line ssh
exec-timeout 30
exit
line telnet
exec-timeout 30
exit
no passwords complexity enable
username xxxxxxxxaccc privilege 15
username xxxxxxxxaccc privilege 15
ip ssh server
snmp-server server
snmp-server location "xxxxxxx"
snmp-server contact "xxxxxxx"
ip http timeout-policy 1800
clock timezone " " -4
clock summer-time web recurring usa
clock source sntp
clock source browser
ip telnet server
!
interface vlan 1
ip address 192.168.175.148 255.255.255.0
no ip address dhcp
!
interface vlan 25
name "Guest Wi-Fi"
ip address 192.168.176.10 255.255.255.0
!
interface vlan 75
name Data
ip address 192.168.178.10 255.255.255.0
!
interface vlan 100
name POS
ip address 192.168.177.10 255.255.255.0
!
interface 1
switchport forbidden default-vlan
!
interface gigabitethernet1
description "ADMIN PVID1"
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport mode access
switchport forbidden vlan add 25
macro description desktop
macro auto smartport type desktop $max_hosts 10 $native_vlan 1
!
interface gigabitethernet2
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport mode access
switchport forbidden vlan add 25
macro description desktop
macro auto smartport type desktop $max_hosts 10 $native_vlan 1
!
interface gigabitethernet3
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport mode access
switchport forbidden vlan add 25
macro description desktop
macro auto smartport type desktop $max_hosts 10 $native_vlan 1
!
interface gigabitethernet4
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport mode access
switchport forbidden vlan add 25
macro description desktop
macro auto smartport type desktop $max_hosts 10 $native_vlan 1
!
interface gigabitethernet5
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport mode access
switchport forbidden vlan add 25
macro description desktop
macro auto smartport type desktop $max_hosts 10 $native_vlan 1
!
interface gigabitethernet6
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport mode access
switchport forbidden vlan add 25
macro description desktop
macro auto smartport type desktop $max_hosts 10 $native_vlan 1
!
interface gigabitethernet7
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport mode access
switchport forbidden vlan add 25
macro description desktop
macro auto smartport type desktop $max_hosts 10 $native_vlan 1
!
interface gigabitethernet8
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport mode access
switchport forbidden vlan add 25
macro description desktop
macro auto smartport type desktop $max_hosts 10 $native_vlan 1
!
interface gigabitethernet9
switchport mode access
switchport access vlan 100
switchport forbidden vlan add 25
switchport forbidden default-vlan
!
interface gigabitethernet10
switchport mode access
switchport access vlan 100
switchport forbidden vlan add 25
switchport forbidden default-vlan
!
interface gigabitethernet11
switchport mode access
switchport access vlan 100
switchport forbidden vlan add 25
switchport forbidden default-vlan
!
interface gigabitethernet12
switchport mode access
switchport access vlan 100
switchport forbidden vlan add 25
switchport forbidden default-vlan
!
interface gigabitethernet13
switchport mode access
switchport access vlan 100
switchport forbidden vlan add 25
switchport forbidden default-vlan
!
interface gigabitethernet14
switchport mode access
switchport access vlan 100
switchport forbidden vlan add 25
switchport forbidden default-vlan
!
interface gigabitethernet15
switchport mode access
switchport access vlan 100
switchport forbidden vlan add 25
switchport forbidden default-vlan
!
interface gigabitethernet16
switchport mode access
switchport access vlan 100
switchport forbidden vlan add 25
switchport forbidden default-vlan
!
interface gigabitethernet17
switchport mode access
switchport access vlan 100
switchport forbidden vlan add 25
switchport forbidden default-vlan
!
interface gigabitethernet18
switchport mode access
switchport access vlan 100
switchport forbidden vlan add 25
switchport forbidden default-vlan
!
interface gigabitethernet19
switchport mode access
switchport access vlan 100
switchport forbidden vlan add 25
switchport forbidden default-vlan
!
interface gigabitethernet20
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport mode access
switchport access vlan 100
switchport forbidden vlan add 25
macro description desktop
switchport forbidden default-vlan
!
interface gigabitethernet21
description "PAK AP Bar"
switchport mode access
switchport access vlan 100
switchport forbidden vlan add 25
switchport forbidden default-vlan
!
interface gigabitethernet22
description "PAK AP Dining"
switchport mode access
switchport access vlan 100
switchport forbidden vlan add 25
switchport forbidden default-vlan
!
interface gigabitethernet23
spanning-tree link-type point-to-point
switchport trunk allowed vlan add 25,75
macro description ap
macro auto smartport type ap
!
interface gigabitethernet24
spanning-tree link-type point-to-point
switchport trunk allowed vlan add 25,75
macro description ap
macro auto smartport type ap
!
interface gigabitethernet25
description Router
storm-control broadcast enable
storm-control broadcast level 10
spanning-tree link-type point-to-point
switchport trunk allowed vlan add 25,75,100
macro description router
macro auto smartport type router $native_vlan 1
!
interface gigabitethernet26
spanning-tree link-type point-to-point
switchport trunk allowed vlan add 25,75,100
macro description switch
macro auto smartport type switch $native_vlan 1
!
interface gigabitethernet27
spanning-tree link-type point-to-point
switchport trunk allowed vlan add 25,75,100
macro description switch
macro auto smartport type switch $native_vlan 1
!
interface gigabitethernet28
spanning-tree link-type point-to-point
switchport trunk allowed vlan add 25,75,100
macro description switch
macro auto smartport type switch $native_vlan 1
!
exit
SW-SG300-28-1#
SW-SG300-28-1#show vlan

Vlan       Name                   Ports                Type     Authorization
---- ----------------- --------------------------- ------------ -------------
1           1             gi1-8,gi23-28,Po1-8       Default      Required   
25     Guest Wi-Fi              gi23-28              static      Required   
75        Data                  gi23-28              static      Required   
100         POS              gi9-22,gi25-28           static      Required

SW-SG300-28-1#show ip route

Maximum Parallel Paths: 1 (1 after reset)
IP Forwarding: enabled
Codes: > - best, C - connected, S - static


C   192.168.175.0/24 is directly connected, vlan 1                        
C   192.168.176.0/24 is directly connected, vlan 25                       
C   192.168.177.0/24 is directly connected, vlan 100                      
C   192.168.178.0/24 is directly connected, vlan 75       

New Member

SG300/500 L3 changing management VLAN IP?

Additional info:

I'm connecting to an RV320 on its port 1 from port 25 on the SG300 and the RV320 is providing the DHCP servers using 192.168.x.1.  Port 1 on the RV320 is 1U, 25T, 75T, 100T.  My PPTP VPN range has been shifted to 192.168.175.221-229.  My lowest DHCP range is 20 and I don't think there's anything else reserved on the router so .10 should be clear there. 

New Member

SG300/500 L3 changing management VLAN IP?

I was watching a vid on SVI and I think I may have found an issue, possibly the issue.

Video: http://m.youtube.com/watch?v=Wl_-tdnCUEE

Apparently using int vlan x doesn't create the vlan but a layer 3 logical interface for the vlan and I think my config created a layer 3 logical interface on the switch on .148 and on the RV320 on .1 for vlan 1 and .10 and .1 for the other vlans.  I think this might be bad but I'm not sure yet. 

Presently I'm routing on the RV so I'm guessing I shouldn't be assigning IPs to the vlans on my switch since I'm basically using the router on a stick setup.  If I change my setup and route on the switch and I would then need to setup my vlan logical interfaces on the switch, probably run my dhcp servers, pools and binding on the switch and then set up the RV on a completely different subnet from any of my vlans just to act as the gateway. 

I'll have to watch the video a few more times and see if I can actually grasp the concepts and then find a few more videos to help connect the missing dots.

2445
Views
0
Helpful
6
Replies