Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SG300 Firmware Upgrade - Copy: Illegal software format

Following the process documented in the SG300 manual - When I select the firmware source file - Select File sx300_fw-14088.ros (I just downloaded from the Cisco website)  -  I receive the following error - Copy: Illegal software format.  What is the file extension of the firmware upgrade file?  What am I doing wrong?

30 REPLIES
Bronze

Hi  Kindly upgrade the boot

Hi

 

 Kindly upgrade the boot loader first before attempting the firmware. Boot loader (.rfb file)can be found on the same zip folder as the firmware. 

 

regards

Moorthy

New Member

HiEven after updating the

Hi

Even after updating the boot loader, i am getting the same error message "Illegal Software format"

Regards

Gaurav

Hi All,Im having the same

Hi All,

Im having the same problem.. Anyone had news on this?

 

 

Thanks

Matt

Hi All,I've sorted this...

Hi All,

I've sorted this... You need to carry out an interim firmware upgrade to the previous version. Then upgrade to 1.4.X.X. The switch flash file system was changed in 1.3.7.18

Hope it helps?

Matt

New Member

Hi, thanks, just had the very

Hi,

 

thanks, just had the very same problem and you tip did it :)

 

Thanks, Adam

My pleasure..Please rate all

My pleasure..

Please rate all useful posts :)

Matt

New Member

Chaps does any one know were

Chaps

 

does any one know were can download the the interim flash software. 

 

unless im looking in the wrong place i dont see the version you guys mention.

 

 

 

 

You need to expand the file

You need to expand the file tree as follows..

All the best

Matt

New Member

Hello Cisco Support Community

Hello Cisco Support Community,

Wanted to add to this thread. I recently obtained a SG 300-10 in which I had to upgrade its firmware before I could proceed with my configurations. Thanks to your comments and tips I was able to upgrade our SG 300-10 from firmware v1.0.0.27 to 1.4. 5.02. Here is what I did...

Step 1: upgrade "boot code" first to "sx300_boot-13506.rfb"

Step 2: upgrade firmware to "sx300_fw_1.3.7.18.ros"

Step 3: "Reboot"

Step 4: upgrade to firmware "sx300_fw-1413.ros"

Step 5: "Reboot"

Step 6: Upgrade to firmware "sx300_fw-14502.ros"

Step 7: "Reboot"

The reason why I updated from 1.3.7.18 to 1.4.1.3 is because of my experience with jumping through major versions. I did not find any information regarding a specific firmware level stop point to update from 1.3.7.18 to 1.4.5.02, but you can sure try to update all the way to 1.4.5.02. Please document here your experience by jumping straight to the latest version.

My 7 steps did the job for our SG 300-10.

Thank you,

Gustavo

New Member

Gustavo,

Gustavo,

I was able to skip step 4 (and 5) and upgrade directly from "sx300_fw_1.3.7.18.ros" to "sx300_fw-14502.ros".

Thank you for detailing these steps.

  Paul Lemaire

New Member

HelloI bought a sg-300-52p or

Hello

I bought a sg-300-52p or-switch and it has a vero firmware SW version 1.3.0.62 and Boot version 1.1.0.6, I do not find a version 1.3.5, I'm a doubt, I can go straight to the version 1.4.7?

thank you

New Member

DearI found the version .rfb

Dear

I found the version .rfb 1.3.5 inside the .zip of version 1.4.1

Thank you

New Member

Gustavo,

Gustavo,

I wasn't able to update the boot code.(rfb), i keep having the "Illegal Software format" error. Although I was able to update the system to the 1.3.7.18 version, but i could not get any further, because after reboot, the firmware version wasn't active, later after that, if i tried with a higher firmware version, i got: "oversized file" and the upload of the firmware was cancelled at 96%.


Thank you,

New Member

Hi gmontanez01,

Hi gmontanez01,

What is the current version of your boot code? More than likely there could be a version in between that needs to be reached prior to updating to that specific boot code.

Thanks,

Gustavo

New Member

Jesus Christ. After hours of

Jesus Christ. After hours of frustration I found your post. I was about to RMA this piece of crap. Upgrading firmware should not be this frustrating in 2017.

New Member

Right there with you. 

Right there with you.  Completely ridiculous process.  Finally updated!

New Member

Wow I bought the switch with

Wow I bought the switch with old firmware (need 100mb not GB) and I've spent many hours trying to solve this upgrade problem. Never in all the switches and firewalls I have programed have I had this much trouble.CLI, TFTP, HTTP it doesn't matter except for the boot code. You must have V1.3.7.18 installed before updating to V1.4.7.06.

Once I realized that you have to expand the ' 1 ' to get to download the V1.3 FW, then things started going right.

Many thanks to support community.

New Member

Thanks a bunch!  As I had the

Thanks a bunch!  As I had the same trouble as well.

New Member

Thank you.  I was having the

Thank you.  I was having the same issue and had to step upgrade several times.  Another reason I prefer enterprise switches over SMB ones.  Unfortunately I still have some out there.

Hi Raul,I understand that

Hi Raul,

I understand that current upgrade it is a bit complicated but it is not always going to be the same challenge. Such a caution is usually communicated in release notes.

The reason for this is to accommodate bigger firmware with more additional features :-) 

Regards,

Aleksandra

New Member

Hi All,

Hi All,

Same Problem here, I have an old 1.3.x on my SG300-28.My Problem is now, that I cant find the 1.3.7.18 Firmware, it Looks like Cisco has removed it from the download.

Without the iterim release, I can't upgrade anymore...

Anyone know where I can download the 1.3.7.18 or can send it to me?

Hello. Check out my posts and

Hello. Check out my posts and screen grabs at the bottom of this page. 1.3.7.18 is tricky to find but it's there.

All the best

Matt

New Member

Thanks for the info above.  

Thanks for the info above.   I  was able to install the V1.3.7.18 ros file via http/https but cannot upload the boot loader via that option.

 

Our boot version is 1.1 and want to update it to 1.3.506 before 1.4x.  I tried TFTP and entered the ip of the server and file name of the rfb in UNC format.   I got the message download in progress, processing data banner, but copy failed TFTP server unreachable.

 

What is the easiest way to get the boot loader updated?  The files are on the file server or could be located anywhere that's easiest

 

 

Hi Jeff,I'd recommend you

Hi Jeff,

I'd recommend you always use the CLI to TFTP.. Seems to be easier on the SMB boxes. For example if your TFTP server was 10.7.8.9..

copy tftp://10.7.8.9/my_boot.rfb boot

Make sure your TFTP Server service is running on your server too, and that you don't have any Windows firewalls blocking TFTP. Solarwinds.net do a great free TFTP server if you need one.

Cheers

Matt

New Member

Hi Matt,Thanks.  I'll have a

Hi Matt,

Thanks.  I'll have a look at that as we don't have a tftp server setup yet.

Appreciated

Jeff

 

New Member

You can also just download a

You can also just download a simple free tftp software to make your desktop a tftp server.  I use TFTPServer for MAC.

New Member

Hi,

Hi,

I am following the same steps that you have mentioned and I am able to transfer some firmware file data but after exact same amount to byte transfer it stops working and gives me illegal software format error.

Could you please help me to find out the cause of this issue?

New Member

Mohit,

Mohit,

Based on your extensive documentation of the problem I will make a wild-ass guess that you are not using a TFTP server for your file transfers.

 PL

New Member

Hi,

Hi,

I have run TFTP server and I was able to upload boot file. But after then when I tried to upgrade firmware file I was not able to upload whole file. Just look at the error message that I have attached to previous comment.

Thanks,

Mohit

36081
Views
132
Helpful
30
Replies
CreatePlease login to create content