Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

SG300 Series Switch- ##Unknown Procedure or function: free ??

Hi All,

Does anyone know what "##Unknown Procedure or function: free" means on an SG300 Series switch? (as below)

Also, I want to create a config template file, modify and mass deploy it... what is the best way to do so on a 300 series switches? They don't seem to behave the same as Cisco IOS products when it comes to modifying and uploading config files.

Switch software version:

v1.3.0.62 / R750_NIK_1_3_647_260

CLI v1.0 v1.3.0.62 / R750_NIK_1_3_647_260
CLI v1.0

                  

!
interface gigabitethernet13
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med network-policy add 1

##Unknown Procedure or function: free

!

Thanks in advance for any help..

Matt

1 ACCEPTED SOLUTION

Accepted Solutions
Green

Re:SG300 Series Switch- ##Unknown Procedure or function: free ??

Hi Matt, I did not try to recreate because I think I know the problem which goes back to my original suspicion.

You have a lot of things going on, basically I think you're too clever for your own good.

  • If you have an auto policy, you don't need to manually tag the vlans, therefore your port config to manually set 100t can be breaking stuff
  • You have the lldp policy assigned to the port while assigned through the auto voice

To make this as painless as possible, I'd reset the switch (backing out config is boring and takes too much time in my opinion).

Use this document for the LLDP-MED

https://supportforums.cisco.com/docs/DOC-27005

You have to remember the auto voice feature is dependent on discovery protocols such as cdp and lldp. These auto policies yield no result or undesirable if you already manually define the setting. The switch runs a basic QoS for the CoS and DSCP for tag packets, hence it is why everything is basically being done twice - or more based on this config.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
7 REPLIES
Green

SG300 Series Switch- ##Unknown Procedure or function: free ??

Hi Matt, this looks like it is clashing to the built in macro.

Disable the auto smart port / macros and it may clear this.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

Re:SG300 Series Switch- ##Unknown Procedure or function: free ??

Hi Tom,

Thanks for your reply.. I disabled the macros but the error was still present.. it appears w hen I apply the lldp med policy to the interface. Any other ideas?

Thanks a lot
Matt


Sent from Cisco Technical Support Android App

Green

Re:SG300 Series Switch- ##Unknown Procedure or function: free ??

Matt, I am unable to reproduce the error. Can you paste your config file here?

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

Re:SG300 Series Switch- ##Unknown Procedure or function: free ??

Here you go Tom.. Thanks again for your help! Matt

config-file-header
Test-SW
v1.3.0.62 / R750_NIK_1_3_647_260
CLI v1.0
set system mode router

file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
vlan database
vlan 100
exit
voice vlan id 100
voice vlan state auto-enabled
voice vlan cos 5 remark
no lldp med network-policy voice auto
lldp med network-policy 1 voice vlan 100 vlan-type tagged up 5 dscp 46
bonjour interface range vlan 1
hostname Test-SW
no passwords complexity enable
username admin password encrypted test privilege 15
clock timezone " " 0 minutes 0
clock summer-time web recurring eu
clock source sntp
clock source browser
sntp unicast client enable
sntp server 158.43.128.33 poll
sntp server 158.43.128.66 poll
ip name-server 8.8.8.8
ip telnet server
!
interface vlan 1
ip address 192.168.14.251 255.255.255.0
no ip address dhcp
!
interface vlan 100
name "Voice VLAN"
!
interface gigabitethernet1
speed 100
no negotiation
description Shoregear-Shelf
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport mode access
switchport access vlan 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet2
speed 100
no negotiation
description Shoregear-Shelf
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport mode access
switchport access vlan 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet3
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet4
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet5
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet6
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet7
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet8
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet9
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet10
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet11
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet12
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet13
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet14
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet15
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet16
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet17
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet18
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet19
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet20
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet21
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet22
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet23
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet24
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
lldp med network-policy add 1

##Unknown Procedure or function: free
no macro auto smartport
!
interface gigabitethernet25
description Uplink-To-887-A
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet26
description Uplink-To-887-B
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet27
lldp med enable
no macro auto smartport
!
interface gigabitethernet28
lldp med enable
no macro auto smartport
!
exit
no macro auto processing cdp
no macro auto processing lldp
macro auto processing type ip_phone disabled
macro auto processing type ip_phone_desktop disabled
macro auto processing type switch disabled
macro auto processing type ap disabled
ip default-gateway 192.168.14.1

Green

Re:SG300 Series Switch- ##Unknown Procedure or function: free ??

Hi Matt, I did not try to recreate because I think I know the problem which goes back to my original suspicion.

You have a lot of things going on, basically I think you're too clever for your own good.

  • If you have an auto policy, you don't need to manually tag the vlans, therefore your port config to manually set 100t can be breaking stuff
  • You have the lldp policy assigned to the port while assigned through the auto voice

To make this as painless as possible, I'd reset the switch (backing out config is boring and takes too much time in my opinion).

Use this document for the LLDP-MED

https://supportforums.cisco.com/docs/DOC-27005

You have to remember the auto voice feature is dependent on discovery protocols such as cdp and lldp. These auto policies yield no result or undesirable if you already manually define the setting. The switch runs a basic QoS for the CoS and DSCP for tag packets, hence it is why everything is basically being done twice - or more based on this config.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

Re:SG300 Series Switch- ##Unknown Procedure or function: free ??

Hi Tom,

Thanks a lot for the additional info and advice.. It does make sense to me. But I do suspect that Cisco may have a minor bug surrounding manually adding LLDP MED policies to switch interfaces in some config combinations. I'm thinking this because while testing I've tried to add a manual Voice MED policy to the switch without using "Auto Voice VLAN". It seems to flag the error every time you add a policy of any type, not just voice.. The error occurs even with Auto Voice VLAN disabled? I wonder what would happen if you wanted to use an LLDP Voice VLAN and a concurrent LLDP Video VLAN MED network policy?..

Anyway, I have tidyed up my config a bit and removed some of the default config which I believe is not required. I did need to add "switchport trunk allowed vlan add 100" to each interface which makes sense to me, because without the VLAN 100 frames being allowed across the trunk how are the LLDP MED tagged voice frames going to traverse the interface? I have also disabled Smart Ports as im a bit of a control freak so I dont really want to use them if I dont have to.. :). I've managed to get things working without the switch complaining of "##Unknown Procedure" so thats good news..

Id appreciate it if you would take a look at my config and let me know what you think?

Cheers

Matt

v1.3.0.62 / R750_NIK_1_3_647_260
CLI v1.0
set system mode router

file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
no cdp appliance-tlv enable
vlan database
vlan 100
exit
voice vlan id 100
voice vlan state auto-enabled
voice vlan vpt 6
no bonjour enable
hostname Test-SW
no passwords complexity enable
passwords aging 0
username admin password encrypted test privilege 15
clock timezone " " 1
clock summer-time web recurring eu
clock source sntp
clock source browser
sntp unicast client enable
sntp server 158.43.128.33 poll
sntp server 158.43.128.66 poll
ip name-server  8.8.8.8
ip telnet server
!
interface vlan 1
ip address 192.168.14.251 255.255.255.0
no ip address dhcp
!
interface vlan 100
name "Voice VLAN"
!
interface gigabitethernet1
speed 100
no negotiation
description Shoregear-Shelf
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport mode access
switchport access vlan 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet2
speed 100
no negotiation
description Shoregear-Shelf
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport mode access
switchport access vlan 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet3
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet4
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet5
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet6
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet7
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet8
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet9
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet10
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet11
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet12
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet13
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet14
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet15
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet16
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet17
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet18
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet19
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet20
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet21
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet22
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet23
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet24
description IP-Phone&PC
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
lldp med enable
no macro auto smartport
!
interface gigabitethernet25
description Uplink-To-887-A
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet26
description Uplink-To-887-B
switchport trunk allowed vlan add 100
lldp med enable
no macro auto smartport
!
interface gigabitethernet27
lldp med enable
no macro auto smartport
!
interface gigabitethernet28
lldp med enable
no macro auto smartport
!
exit
macro auto disabled
no macro auto processing cdp
no macro auto processing lldp
macro auto processing type ip_phone disabled
macro auto processing type ip_phone_desktop disabled
macro auto processing type switch disabled
macro auto processing type ap disabled
ip default-gateway 192.168.14.254

Green

Re:SG300 Series Switch- ##Unknown Procedure or function: free ??

Hi Matt, if it works, it is good.

I agree there are some caveats with the macros. The only thing that bothers me about your statement is the fact that you'd have to specify the tag vlan. The LLDP policy should be doing this for you. If you manually define the vlan tags then the only thing the LLDP policy is doing is adding the additonal lines of config like port security, port fast etc.If you manually specified those, then the LLDP isn't actually doing anything for you.

I would say the switch does work it's finest with either the macros and cdp/lldp. The switch was designed that way for plug and play voice deployments.

I have even made LLDP policies on a Catalyst which told me SX300 the voice vlan and how to configure the trunk between the switches. So it is a pretty powerful tool with the smart ports and macros.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
840
Views
0
Helpful
7
Replies
CreatePlease login to create content