Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SG500 associate VLAN to DHCP server/pool

Where in the web gui do you associate the a DHCP server/pool to a VLAN?  The closet thing I can find would be IP Config > IP Management & Interfaces > IPv4 Interfaces but everytime I set and IP to VLAN I need to power cycle to access the gui again.  I have 2 named pools 192.168.222.100-249 and 192.168.244.100-249.  VLANs are 1, 222 & 244.  I know I can dig up old notes and my Indigo terminal emulator library and do this using CLI but I'm fixated on doing this through the gui but I can fine anything other than what I tried above that looks like it will associate a VLAN to subnet and that just makes the switch hang. 

FYI, I did update the FW and Boot last night to the latest.

1 ACCEPTED SOLUTION

Accepted Solutions
Green

Re: SG500 associate VLAN to DHCP server/pool

Hi Vini, that behavior is correct.

First do something like

The default IP is 192.168.1.254 so example would be

config t

int vlan 1

ip address 192.168.1.254 /24

Once this is done then you may modify your other vlans as wanted.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
7 REPLIES
Green

Re: SG500 associate VLAN to DHCP server/pool

Hi Vini, that is a good question. The switch is a bit more intuitive. You do not actually bind a dhcp pool to a vlan. When you make a routed vlan the dhcp pool that corresponds to the SVI will associate. In other words, so long as you set up the different routed vlans, you would configure the dhcp scope as the same subnet as the SVI and it will work.

By the way, if your switch is 'locking up', ensure your vlan 1 is a static IP address before making any other vlan with an ip address.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

Re: SG500 associate VLAN to DHCP server/pool

VLAN 1 is already set w/ static IP but it still locks up when I try to set IPv4 Interface. 

L3 and the acronym SVI are completely new to me so I'll need to do some reading before I can attempt to figure out what you mean. 

I did find some CLI commands

[code]

Switch#

configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#

interface Vlan2

Switch(config-if)#

ip address 10.1.2.1 255.255.255.0

Switch(config-if)#

no shutdown

[/code]

but this should be the same as the gui IPv4 Interface settings I would think and that just locks up.

I'll be back....

New Member

Re: SG500 associate VLAN to DHCP server/pool

Here's my running config.  I've done some reading and YouTube videos and everything seems to point to

conf t

int Vlan###

ip address 192.168.2xx.254 255.255.255.0

.........  but this always hangs my SG500-28. 

I had loaded the most recent FW & Boot before starting anything but have since rolled back the the last version because I couldn't get this to work.  Right now I'm just using this as a lab practice switch so I can experiment before trying to deploy these in jobs and the first thing I want to do is simply create a couple vlans each with their own dhcp server/pool so when I plug something in to a switchport, config'd access for a specific vlan, receive an IP from the pool or binding table.  I never had any problems doing this on L2 2960's but so far I can't seem to do this with the SG500 in L3 mode.  I'm starting to feel like it I can't get this to work I'm gonna be really lost when I get to the inter vlan routing attempts so there must be something simple I'm missing. 

show running-config

config-file-header
vavswitch
v1.3.0.59 / R750_NIK_1_3_647_260
CLI v1.0
set system mode router queues-mode 4

file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
vlan database
vlan 222,244
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
ip dhcp server
ip dhcp pool network Pool_DistAV
address low 192.168.222.100 high 192.168.222.249 255.255.255.0
domain-name DistAV.com
default-router 192.168.222.1
exit
ip dhcp pool network Pool_InHouse
address low 192.168.244.100 high 192.168.244.249 255.255.255.0
domain-name InHouse.com
default-router 192.168.244.1
exit
bonjour interface range vlan 1
hostname vavswitch
username xxxxxxxxxx privilege 15
username yyyyyyyyyy privilege 15
ip ssh server
snmp-server location "VAV Office"
snmp-server contact "Dan Vining"
clock timezone " " -5
ip telnet server
!
interface vlan 1
no ip address dhcp
!
interface vlan 222
name Dist_AV
!
interface vlan 244
name In_House
!
interface gigabitethernet1/1/1
description "222 only"
switchport mode access
switchport access vlan 222
switchport forbidden default-vlan
!
interface gigabitethernet1/1/2
description "244 only"
switchport mode access
switchport access vlan 244
switchport forbidden default-vlan
!
interface gigabitethernet1/1/13
description "1 and 222"
switchport trunk allowed vlan add 222
!
interface gigabitethernet1/1/14
description "1 and 244"
switchport trunk allowed vlan add 244
!
interface gigabitethernet1/1/24
description "All Vlans"
switchport trunk allowed vlan add 222,244
!
exit

vavswitch#


Any help would be appreciated, TIA!

Green

Re: SG500 associate VLAN to DHCP server/pool

Hi Vini, that behavior is correct.

First do something like

The default IP is 192.168.1.254 so example would be

config t

int vlan 1

ip address 192.168.1.254 /24

Once this is done then you may modify your other vlans as wanted.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

Re: SG500 associate VLAN to DHCP server/pool

Well that was surely simple! 

Just so I understand since I changed the default vlan from dhcp to static and didn't specify an IP (I'm sure I did in some iteration of config but..) the system was in a fault state?  which is why I wasn't able to set my vlan's IP addresses.  I guess it throws an exception when it re-compiles that segment of the config being modified/saved since the default vlan isn't properly set.  MIght need better error handling so it doesn't hang and returns an error notification instead of forcing a hard reboot. 

Here I was thinking the blinking System LED was the correct state whereas that apparently was a fault indication?  Thanks for your help and I look forward to further help next time I hit a wall, which will be soon.

Green

Re: SG500 associate VLAN to DHCP server/pool

Hi Vini, you're correct in the sense. When you assigned a static IP to another vlan that vlan became the "management vlan" and therefore requires an untagged member in that vlan to be able to manage the switch giving the experience that the switch locks up. A static IP will have precedence over a dynamic IP even if setting the IP to static, the IP should still be defined - as your observation notes.

If the system light is blinking it is expecting or has a DHCP address.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

Re: SG500 associate VLAN to DHCP server/pool

Just as a follow up I think I have everything working which I think is pretty good considering how stuck I was with the Vlan 1 no static IP problem that had me dead in my tracks.  If anyone would like to check my config to look for bad practice or mistakes I'm open to suggestions.  I know I need to work on proper ACL's but I figure get it working first and then secure it since I'm pretty much a newb at this.

FYI my router is a RV082 192.168.1.65/27 for now.  It's on the .224 netmask for stupid reasons and will be changed.  Subnetting is configured and static routes for my 2 vlans.  Not sure if I needed to config both subnetting and static routes on the RV but now that it's working maybe I'll verify.

show running-config

config-file-header

SG500-28-1

v1.3.0.62 / R750_NIK_1_3_647_260

CLI v1.0

set system mode router queues-mode 4

file SSD indicator encrypted

@

ssd-control-start

ssd config

ssd file passphrase control unrestricted

no ssd file integrity control

ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0

!

vlan database

vlan 222,244

exit

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

ip dhcp server

ip dhcp pool network Pool_DistAV

address low 192.168.222.100 high 192.168.222.249 255.255.255.0

domain-name audio.com

default-router 192.168.222.1

dns-server 192.168.1.65

exit

ip dhcp pool network Pool_InHouse

address low 192.168.244.100 high 192.168.244.249 255.255.255.0

domain-name house.com

default-router 192.168.244.1

dns-server 192.168.1.65

exit

bonjour interface range vlan 1

ip access-list extended "In All Any"

permit ip any any

exit

ip access-list extended "Out All Any"

permit ip any any

exit

hostname SG500-28-1

username nnnnn accc privilege 15

username yyyyy accc privilege 15

ip ssh server

snmp-server location VAV

snmp-server contact DRV

clock timezone " " -5

ip name-server  192.168.1.65 68.87.71.226 8.8.4.4

ip telnet server

!

interface vlan 1

ip address 192.168.201.254 255.255.255.0

no ip address dhcp

!

interface vlan 222

name Dist_AV

ip address 192.168.222.1 255.255.255.0

!

interface vlan 244

name In_House

ip address 192.168.244.1 255.255.255.0

!

interface gigabitethernet1/1/1

description "222 only"

service-acl input "In All Any" default-action permit-any

switchport mode access

switchport access vlan 222

switchport forbidden default-vlan

!

interface gigabitethernet1/1/2

description "244 only"

service-acl input "In All Any" default-action permit-any

switchport mode access

switchport access vlan 244

switchport forbidden default-vlan

!

interface gigabitethernet1/1/12

description "To Gateway"

ip address 192.168.1.89 255.255.255.224

service-acl input "In All Any" default-action permit-any

!

exit

ip default-gateway 192.168.1.65

SG500-28-1#show ip route

Maximum Parallel Paths: 1 (1 after reset)

IP Forwarding: enabled

Codes: > - best, C - connected, S - static

S   0.0.0.0/0 [1/1] via 192.168.1.65, 0:3:21, gi1/1/12                    

C   192.168.1.64/27 is directly connected, gi1/1/12                       

C   192.168.222.0/24 is directly connected, vlan 222                      

C   192.168.244.0/24 is directly connected, vlan 244                      

SG500-28-1#show access-lists

Extended IP access list In All Any

    permit  ip any any

Extended IP access list Out All Any

    permit  ip any any

SG500-28-1#show hosts

Name/address lookup is enabled

Domain Timeout: 3 seconds

Domain Retry: 2 times

Domain Polling Interval: 18 seconds

Default Domain Table

                   Domain                    Source  Interface Preference

-------------------------------------------- ------- --------- ----------

Domain name is not configured

Name Server Table

                 IP Address                  Source  Interface Preference

-------------------------------------------- ------- --------- ----------

192.168.1.65                                 static            1         

68.87.71.226                                 static            2         

8.8.4.4                                      static            3         

Cache Table

Flags: (STA/DYN, OK/NE/??)

STA - Static, DYN - Dynamic

OK - Okay, NE - Negative Cache, ?? - No Response

                                                               Remaining

          Host                   Addresses         Type State     TTL    

------------------------- ------------------------ ---- ------ ----------

No hostname is mapped to an IP address

SG500-28-1#

2983
Views
0
Helpful
7
Replies
CreatePlease login to create content