Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SG500X and C3750G VLAN

Hello! Sorry for my bad english, I'm from Russia. I need to configure SG500X and C3750G dot1q trunk, but this does not work... Please help me!

This my configs:

==3750==

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname aik-office-gw1

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

clock timezone UTC 5

clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00

switch 1 provision ws-c3750g-24ts

switch 2 provision ws-c3750g-24ts

system mtu routing 1500

ip routing

!

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

no ip ftp passive

ip ssh time-out 30

ip ssh version 2

!

!

!

interface GigabitEthernet1/0/1

ip access-group 101 in

no cdp enable

!

.........................................

!

interface GigabitEthernet1/0/28

no cdp enable

!

interface GigabitEthernet2/0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,10,39

switchport mode trunk

switchport nonegotiate

no vtp

spanning-tree portfast trunk

!

......................

!

interface GigabitEthernet2/0/28

no cdp enable

!

interface Vlan1

ip address 192.168.39.1 255.255.254.0

!

interface Vlan39

ip address 192.168.40.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.39.201

no ip http server

ip http secure-server

!

!

logging trap debugging

logging 192.168.39.201

access-list 1 permit 192.168.38.95

access-list 1 remark For_access_to_telnet_to_c3750G

access-list 1 permit 192.168.39.201

access-list 2 permit 192.168.38.95

access-list 2 remark Access_to_SNMP

access-list 2 permit 192.168.38.27

no cdp run

no cdp tlv location

no cdp tlv app

!

snmp-server community

!

!

line con 0

line vty 0 4

access-class 1 in

password

login

line vty 5 15

password

login

!

end


==SG500X==

switch8f36e2

v1.3.0.62 / R750_NIK_1_3_647_260

CLI v1.0

set system queues-mode 4

file SSD indicator encrypted

@

ssd-control-start

ssd config

ssd file passphrase control unrestricted

no ssd file integrity control

ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0

!

vlan database

vlan 10,39

exit

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

no ip routing

bonjour interface range vlan 1

hostname switch8f36e2

aaa authentication enable Telnet enable

aaa authentication login Telnet local

line telnet

login authentication Telnet

enable authentication Telnet

password da39a3ee5e6b4b0d3255bfef95601890afd80709 encrypted

exit

username admin password encrypted 6c50510819da7f3418270eabb5a59f84830440bf privilege 15

ip ssh server

ip telnet server

!

interface vlan 10

name Management

!

interface vlan 39

ip address 192.168.40.2 255.255.255.0

!

interface gigabitethernet1/1/1

switchport mode general

switchport general allowed vlan add 10,39 tagged

!

interface gigabitethernet1/1/2

switchport mode access

switchport access vlan 39

!

exit

Снимок.PNG

My Vlan 1 subnet 192.168.38.0/23

ping from 192.168.39.95 to 192.168.38.114 OK

ping from 192.168.39.95 to 192.168.40.1 OK

ping from 192.168.39.95 to 192.168.40.3 OK

ping from 192.168.40.3 to 192.168.40.2 Failed

ping from 192.168.40.1 to 192.168.40.2 Failed

ping from 192.168.40.3 to 192.168.40.1 OK

ping from 192.168.40.3 to 192.168.40.4 Failed

ping from 192.168.40.2 to 192.168.40.4 OK

ping from 192.168.40.4 to 192.168.40.2 OK

dot1q does not work!!!

3 REPLIES
Green

SG500X and C3750G VLAN

Hi Ruslan- Try something like this below. My syntax may be off a bit but you should have the idea.

SG:
interface gigabitethernet
switchport mode general

switchport mode general native vlan 1
switchport general allowed vlan add 10,39 tagged

switchport general ingress-filtering disable


Catalyst:
interface GigabitEthernet
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,39
switchport mode trunk

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

SG500X and C3750G VLAN

I entered command as you wrote earlier, but still Trunk does not work. Somebody help me!

New Member

hi ahmetov-ra, You could have

hi ahmetov-ra,

 

You could have solved the same stage, and still can not get fixed.

 

Cristobal

743
Views
0
Helpful
3
Replies
CreatePlease login to create content