Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

SG500X LACP Not Working...

Hello,

 

I'm simply trying to create an LACP link between a SG500 and SG500X. The problem is on the SG500X which is the new switch I'm setting up - there are already other switches using the SG500 with an LACP link just fine, just this SG500X is giving me problems.

I have 4 links from the SG500 configured for LACP that I will be using with the SG500X, although the ports I want use 33-36 show as 'non-candidate' on the SG500, why I don't know.

 

SG500-B1-NET#sh int po1

Load balancing: src-dst-mac.

Gathering information...
Channel  Ports
-------  -----
Po1      Active: gi1/1/47-49 Non-candidate: gi1/1/33-36,gi1/1/50
SG500-B1-NET#

interface gigabitethernet1/1/33
 channel-group 1 mode auto
!
interface gigabitethernet1/1/34
 channel-group 1 mode auto
!
interface gigabitethernet1/1/35
 channel-group 1 mode auto
!
interface gigabitethernet1/1/36
 channel-group 1 mode auto

interface Port-channel1
 switchport trunk allowed vlan add 30-33

 

 

 

When I go over to the SG500X and setup the port-channels and such, the links steadily keep saying the LACP ports are inactive. When I look at one of the ports setup for LACP, I noticed is has no VLAN information.

 

interface Port-channel1
 switchport trunk allowed vlan add 30-33,70,100,130-133,160
!

 

Core-B9-NET#sh int po1

Load balancing: src-dst-mac.

Gathering information...
Channel  Ports
-------  -----
Po1      Inactive: gi1/1/1-4
Core-B9-NET#sh lacp port-channel 1
Port-Channel Po1
       Port Type Gigabit Ethernet
       Attached Lag id:
       Actor
               System Priority:1
               MAC Address:    f4:ea:67:8e:4b:31
               Admin Key:      1000
               Oper Key:       1000
       Partner
               System Priority:0
               MAC Address:    00:00:00:00:00:00
               Oper Key:       0

 

Port : gi1/1/1
Port Mode: Trunk
Gvrp Status: disabled
Ingress Filtering: true
Acceptable Frame Type: admitAll
Ingress UnTagged VLAN ( NATIVE ): 1

Port is member in:

Vlan               Name               Egress rule Port Membership Type
---- -------------------------------- ----------- --------------------


Forbidden VLANS:
Vlan               Name
---- --------------------------------


Classification rules:

Protocol based VLANs:

 

None of the switch ports on either end are shutdown. 

 

I can't ping my GW IP on the switch or the management IP on the switch, from the actual CLI interface. The only time I can at least ping the local interface on the SG500X switch is if I have a different laptop setup on a port for 'access mode', then I can ping the actual management IP address of the switch. But of course this laptop would be connected directly to the SG500X when this works.

What am I missing here, do I need to set this up only via the Web GUI or what? This would easily work on any other Cisco switch.

Additionally, I only added one link port channel on the SG500X and still NO joy.

15 REPLIES

Hi,Shouldn't "channel-group 1

Hi,

Shouldn't "channel-group 1 mode auto" be used with PAgP?, and active or on with LACP?

In addition, please keep in mind that all the ports in the etherchannel group must have same speed, duplex, being in the same vlan and none of them can be a pan port.

Regards,

Aref

Cisco Employee

Hi Guys,On small Business

Hi Guys,

On small Business switches there is no PAgP so if you set "channel-group 1 mode auto it would indicate LACP if only "channel-group 1 mode on" it is a static LAG with no LACP.

what you see as non-candidate simple means inactive when LACP enabled. In static LAG you would see "inactive".

what does it mean practically in your case that eather the cable is not connected or it is fault or the other end is not set the same way to LACP.

Please post both ends LAG settings if you have some doubts.

Regards,

Aleksandra

Community Member

Hello Aleksandra,I do not

Hello Aleksandra,

I do not have a LAG setup and between these 2 switches I'm unable to setup a LAG.

So what is my option to get this to work with just LACP?

I simply need to make sure all of those VLANs are accessible on the SG500X I'm setting up, so I can then create some access ports with specific VLANs and connect those ports to some host connected Dell switches.

How can I get LACP by itself to work?

 

Cisco Employee

Hi,LAG with LACP and trunk

Hi,

LAG with LACP and trunk those are two different subjects. Test on one port creating trunk with all desired VLANs and verify connectivity on all VLANs. LAG with LACP even if fails on Small Business switches would still keep one port up so the trunk should be up as well. From what you have mentioned about testing I understand that there is a trunk and VLAN tagging, PVID mismatch between two sites.

Regards,

Aleksandra

Community Member

Yes, they are 2 different

Yes, they are 2 different things. As I mentioned, I can't create a LAG, I can only use LACP. 

I brought the LACP link down to 1 and I still had no luck. The only VLAN that would work is VLAN 1 (default) and that's it.

When I create a trunk port it works, but that is not even remotely the desired affect I want here. I'm trying to reduce my port count needed on the SG500X. If I need to trunk all of the ports I'm going to use with VLANs, I will use up all of my 24 ports on the SG500X.

My question is, can this SG500X work with just LACP alone or MUST I have a LAG?

 

Community Member

Just FYI,I got this working,

Just FYI,

I got this working, but for whatever reason this SG500X does NOT like port-channels.It would only work when using trunk ports from the SG500.

With this setup, I have a server connected to a port on the SG500X that is on VLAN 131 and the port is setup as an 'access' port for that VLAN. I'm able to ping that server, so I know this works. 

Strangely enough, these trunks are acting very similiar to what a port-channel would do anyways.

Very strange switch that SG500X.

Hope this may help someone.

So the setup is the following:

 

SG500

 

SG500-NET(config)#int r gi1/1/34-36

SG500-NET(config-if-range)#no shutdown

SG500-NET(config-if-range)#31-Oct-2013 01:16:21 %LINK-I-Up:  gi1/1/34

31-Oct-2013 01:16:21 %LINK-I-Up:  gi1/1/36

31-Oct-2013 01:16:22 %LINK-I-Up:  gi1/1/35

31-Oct-2013 01:16:26 %STP-W-PORTSTATUS: gi1/1/34: STP status Forwarding

31-Oct-2013 01:16:26 %STP-W-PORTSTATUS: gi1/1/36: STP status Forwarding

31-Oct-2013 01:16:26 %STP-W-PORTSTATUS: gi1/1/35: STP status Forwarding

 

SG500-NET(config-if-range)#channel-group 1 mode auto

Port gi1/1/34 belongs to a VLAN.

Port gi1/1/35 belongs to a VLAN.

Port gi1/1/36 belongs to a VLAN.

SG500-B1-NET(config-if-range)#

 

interface gigabitethernet1/1/33

switchport trunk allowed vlan add 130-133

!

interface gigabitethernet1/1/34

switchport trunk allowed vlan add 130-133

!

interface gigabitethernet1/1/35

switchport trunk allowed vlan add 130-133

!

interface gigabitethernet1/1/36

switchport trunk allowed vlan add 130-133

 

 

 

SG500X

 

NET(config)#int r gi1/1/2-4

NET(config-if-range)#no shutdown

NET(config-if-range)#20-Jul-2012 15:12:40 %LINK-I-Up:  gi1/1/2

20-Jul-2012 15:12:40 %LINK-I-Up:  gi1/1/4

20-Jul-2012 15:12:41 %LINK-I-Up:  gi1/1/3

 

NET(config-if-range)#channel-group 1 mode auto

Port gi1/1/2 belongs to a VLAN.

Port gi1/1/3 belongs to a VLAN.

Port gi1/1/4 belongs to a VLAN.

NET(config-if-range)#

 

 

 

interface gigabitethernet1/1/1

switchport trunk allowed vlan add 130-133

!

interface gigabitethernet1/1/2

switchport trunk allowed vlan add 130-133

!

interface gigabitethernet1/1/3

switchport trunk allowed vlan add 130-133

!

interface gigabitethernet1/1/4

switchport trunk allowed vlan add 130-133

Cisco Employee

Hi, Before putting ports in

Hi,

 

Before putting ports in LAG you have to bring them up to VLAN 1 access port or default which are trunks but with only 1 UP.

only after ports are in LAG/port channel you can make configuration of VLANs

That is why you have see the message 

HNASCore-B9-NET(config-if-range)#channel-group 1 mode auto

Port gi1/1/2 belongs to a VLAN.

Port gi1/1/3 belongs to a VLAN.

Port gi1/1/4 belongs to a VLAN.

Regards,

Aleksandra

Community Member

I tried that already and that

I tried that already and that didn't work. I then got a message (as expected) that the ports are in a port-channel and that I need to change that first.

We are on the same page, but this switch is not functioning as I would expect another Cisco switch.

 

 

Cisco Employee

once you have port in port

once you have port in port channel did you try to configure trunk on interface port-channel 1 rather than the ports directly?

Community Member

Same as I always do, this was

Same as I always do, this was in my very first message hat started the post. No different from any other port-channel configuration.

 

This switch just has some weird behaviour is all.

Cisco Employee

Hi,There is no difference

Hi,

There is no difference between SG500 and SG500X in behaviour, at leats it should not be. In your case I would suggest to open ticket with Cisco Small Business team so they can check everything in details:

http://www.cisco.com/c/en/us/support/web/tsd-cisco-small-business-support-center-contacts.html

Regards,

Aleksandra

Community Member

The only differnce between

The only differnce between the 2 is that the Sg500X is running newer firmware. But for now I'm good with the the trunk ports instead of the port-channel.

Maybe the next one I get will behave correctly or will prove that this is how the SG500X ned to be setup.

Community Member

I do have one last question

I do have one last question for you though. How come I can only manage this switch via the web interface remotely, I can't telnet too it.

When I'm in the web interface I only see console settings, but nothing for telnet.

Can this not be managed via telnet?

Cisco Employee

Hi,Yes :-) you have to enable

Hi,

Yes :-) you have to enable telnet in Security--> TCP/UDP services. or via CLI command: ip telnet server

Aleksandra

2099
Views
5
Helpful
15
Replies
CreatePlease to create content