Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

SGE 2000 - DHCP Relay

Hello Community,

I have definded several VLANs and the coresponding IP Adresses on the SGE2000. The static routing works fine. On one VLAN there is a Windows 2003 DHCP Server which I have defined as DHCP Relay Server (Option 82), but no packets are relayied. Has anyone a functional setup, with dhcp relay?

Thanks in advance,

Jan Jensen

8 REPLIES
Bronze

Re: SGE 2000 - DHCP Relay

Hello and Good Evening,

Assuming you have the DHCP scopes set up correctly, you will need to enable DHCP relay and enter the IP address.  By default broadcasts (DHCP requests) do not get forwarded past L3 boundaries.  The relay feature will address this.  

I have a similar set up and this works fine.  Do please let me know how you make out.  Kindest regards,

Andrew Lee Lissitz

Re: SGE 2000 - DHCP Relay

Hi Jan,

firstly , I checked today and saw that the new release of code is available at the support > downloads section of www.cisco.com.

Looks like 3.0.0.17 is available to download.  You will, I believe need a cisco login to grab that new file.

I found that when i tried to download software  via  the SGE2000 product info page, which is usually another way to get code, only the older software could be downloaded.  That i guess will take a few days to change

.

try this new software first, I must admit i did not check the release notes regarding DHCP relay, but upgrading software is the quickest thing to try.

But, you still may just have a configuration issue, if you  check the built in help text on the DHCP relay, it mentions, to enable DHCP snooping on the VLAN you are on.

You have a couple of actions to take, does the problem still exist or does DHCP relay now work to the Windows server ?

If your issue  still exists contact the Small Business Support Center via the following URL;

http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html

regards Dave

Community Member

SGE 2000 - DHCP Relay

Hi,

I have the same issue in relaying a DHCP with SGE2000, but the only difference is my DHCP Server is a Linux box.

When the DHCP Server and the Client are in the same VLAN, the communication works fine as expected.

But across VLAN's, the DHCP Discover  broadcast is not reaching the server.

Have enabled ip helper, DHCP relay and DHCP options on the SGE2000, but still doesnt seem to go through.

Updated the software version of the SGE2000 to the latest firmware but still doesn't work,

I can paste the configuration details if needed.

Should DHCP Snooping be enabled for this setup to work?

Thanks

Kasi VPS

Green

SGE 2000 - DHCP Relay

Hi Kasim

DHCP option 82 only works if the DHCP snooping is enabled. If the DHCP is not working, you may have to add a route on the DHCP server.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Community Member

SGE 2000 - DHCP Relay

Hi Thomas,

Could please let me know what route should be in place?

Since we are in the deployment stage, we just created 2 VLANs, VLAN 10 & VLAN 20.

DHCP Server in part of VLAN 1 (DHCP Server IP : 192.168.1.220)

Switch Management IP: 192.168.1.230

Client computers from VLAN 20 are not getting an IP from the DHCP Server.

VLAN 20 IP : 172.16.2.1

VLAN 20 Client IP Address range defined in DHCP Scope: 172.16.2.x

IP helper address is pointed to the DHCP server 192.168.1.220,but the DHCP broadcast traffic is not hitting the DHCP server in the log messages.

What could be the issue?

Thanks

Kasi Viswanathan

Green

SGE 2000 - DHCP Relay

The issue is the broadcast is going out of the server but not coming back to the server.

To add a route on your DHCP server, this is something you need to contact the server admin for.

Here would be an example for server 2003...

Route ADD 172.16.2.0 Mask 255.255.255.0 192.168.1.0 –p

If you have the dhcp relay / iphelper set up correctly, you may want to contact the server's support team / admin as the switch won't do any thing more.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Community Member

SGE 2000 - DHCP Relay

Thanks for the quick response.

I meant the client's DHCP DISCOVER broadcast packet is not coming to the DHCP Server.

As far as i understand, the below process happens on a DHCP. Please correct if i m wrong.

Discover: The DHCP Client sends a Broadcast to the network discovering if there a DHCP Server.

Offer: The available DHCP server responds with the Offer

Request: The DHCP Client then request's the offer'd

Acknowledge: The DHCP then sends an acknowledgement to the client and confirms the leased IP address to it.

In our setup the Discover broad cast from the DHCP client from one VLAN(20) is not coming to the DHCP Server located in VLAN 1.

I also will try adding the route on the DHCP server provided by you and post the results.

Thanks

Kasi Viswanathan

Community Member

SGE 2000 - DHCP Relay

Hi,

I tried configuring the route on the DHCP Server like below

route add -net 172.16.4.0 netmask 255.255.255.0 gw 192.168.1.220

172.16.4.0 is my client network at VLAN 20

192.168.1.220 is my DHCP Server(Linux VM)

It still doesnt work. Please help where is something wrong.

The DHCP Server is able to lease IP to the clients on the same VLAN but not across VLAN's

Please find my running-config on the CISCO SGE2000

vlan database

vlan 10,20

exit

interface ethernet 1/g15

switchport access vlan 10

exit

interface ethernet 1/g3

switchport access vlan 20

exit

interface vlan 10

name 172-16-3

exit

interface vlan 20

name 172-16-4

exit

interface vlan 1

ip address 192.168.1.253 255.255.255.0

exit

interface vlan 10

ip address 172.16.3.1 255.255.255.0

exit

interface vlan 20

ip address 172.16.4.1 255.255.255.0

exit

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip dhcp relay address 192.168.1.220

ip dhcp relay enable

ip helper-address 192.168.1.220 172.16.3.0 37 42 49 53 137 138

ip helper-address 192.168.1.220 172.16.4.0 37 42 49 53 137 138

ip helper-address all 192.168.1.220 37 42 49 53 137 138

Thanks

Kasi Viswanathan

3627
Views
0
Helpful
8
Replies
CreatePlease to create content