Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SGE2000 inter vlan routing problem

Hi,

I have the following problem with routing between vlan on SGE2000 switch configured in L3 mode:

I have 2 locations connected througn vpn with the following ip's:

HQ class configured on cisco router (i do not have access on that because is the router of my internet provider): 192.168.50.0/24, gw on 254

Remote site (same as HQ with access): 192.168.51.0/24, gw on 254

My internal class on HQ is 10.0.0.0/24 with gw on 10.0.0.1

Both of classes are conected in SGE2000 switch. The config on the sw:

vlan database

vlan 10,20

exit

interface ethernet g1

switchport access vlan 10

exit

interface range ethernet g(2-24)

switchport access vlan 20

exit

interface vlan 10

name VPN

exit

interface vlan 20

name PCs

exit

interface vlan 10

ip address 192.168.50.1 255.255.255.0

exit

interface vlan 20

ip address 10.0.0.254 255.255.255.0

exit

ip route 192.168.51.0 255.255.255.0 192.168.50.254

The 10.0.0.1 IP is connected in port 19 which is on vlan 20.

Main problem is that i cannot ping from internal class (10.0.0.0/24) in provider access class (192.168.50.0/24) and the vpn class (192.168.51.0/24)

From the sw i can ping in all the above classes.

Thanks!

Everyone's tags (3)
957
Views
0
Helpful
0
Replies
CreatePlease to create content