Cisco Support Community
Community Member

SGE2000 weird behaviour after stack split

Hi All

     I've had a stack of two SGE2000 switches, then I decided to split the stack and use switches separately as standalone. I removed one of switches (master if it does matter) to reconfigure it. I was able to connect to it via stack IP and did "Restore Configuration Factory Defaults" assuming that it will change it's IP to default - - and enable DHCP server. But a problem arose.

     It surely been reset somehow: I was able to see it as ports which were shut down (permanent green light) became up (light disappeared), but neither default IP was set nor DHCP server up. I tried to reach the switch via old stack IP and via (configured my PC address to manually) but with no luck.

     As former slave stack member was working flawlessly, I reconnected problem switch to it and stack recognised it as it was. Newly connected switch (was master again in web interface but MST LED stayed on working switch according to rules described in manual (longer uptime)) got an old config (ports state, LAGs and VLAN membership). Then I changed things to kind of factory defaults (removed all ports on master switch from LAGs and VLANs, made all ports up, type general and untagged in vlan 100) manually and saved configuration (Admin - File Management - Copy Files - Copy configuration: copied running config to backup config and then backup to startup (if copy running straight to startup, the device shows 0 bytes copied and the only way to save changes is via backup conf - is terribly buggy)). I assumed that after saving the config I could remove master switch again and it will have stack IP, but no luck again: I wasn't able to reach it with stack IP and according to sniffing log it looks like switch doesn't have and IP at all. Situation getting worse as I don't have serial cable for this device.

     So questions are:

1) How to gain access to problem switch back (second one which works well is in production so possible manipulations with it are limited)?

1a) Is there any hardware way to reset the switch to factory defaults?

1b) Is there any way to assign separate IP to stack mamber which it will use when away from the stack?

2) How does serial cable pinout look like?

All suggestions will be greatly appreciated.

Community Member

Re: SGE2000 weird behaviour after stack split

Connected problem switch back to the stack, configured all it's ports to access mode, changed stack management vlan to 100, saved config and disconnected the switch. After that switch became reachable via stack IP.

Community Member

Re: SGE2000 weird behaviour after stack split


I agree that, at times, the SGE switches can be somewhat difficult when getting them in and out of stack mode. I would recommend getting them back to the config that they had before you tried to remove them from a stack, then configure them via the serial cable back to factory defaults. The pinout for the cable can be found here.

There is also a little, round, red hole at the bottom left of the switches face plate that allows you to factory reset the device. You should use a paper clip and hold it for a full 30 seconds.

These switches are designed to either be stacked or not, meaning they are not supposed to be put in and taken out of stacked mode at random. By default, the switches try to stack together, and do not work well when the stack gets broken up or changed. I sincerely suggest you pick either stacked or standalone and leave them as such.

As a side note, there is a newer firmware available for this switch. It is version It can be found here.

Please report any new problems.


CreatePlease to create content