Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

SGE2010P

hello to all, Im newbie network guy currently im having problem with ip phone configuration using SGE2010P switch and IP phone 7911G. When I try to connect the phone on the switch it doest get ip address and configuration files Im using vlan one as my native and vlan 20 for my IP phones but still no luck. here is my router configuration.

 

!
hostname ROUTER
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
no aaa new-model
!
resource policy
!
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.100
ip dhcp excluded-address 192.168.1.1 192.168.1.149
ip dhcp excluded-address 192.168.1.200 192.168.1.254
ip dhcp excluded-address 10.10.10.42 10.10.10.254
!
ip dhcp pool DATA
   import all
   network 192.168.1.0 255.255.255.0
   dns-server 213.42.20.20 192.229.241.222
   default-router 192.168.1.1
!
ip dhcp pool VOICE
   import all
   network 10.10.10.0 255.255.255.0
   dns-server 213.42.20.20 195.229.241.222
   default-router 10.10.10.100
   option 150 ip 10.10.10.100
!

!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10 native
ip address 192.168.1.1 255.255.255.0
ip access-group NAT-ACL in
ip nat inside
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.10.10.100 255.255.255.0
ip access-group VOICE-ACL in
!
interface Service-Engine0/0
ip address 192.168.100.1 255.255.255.252
service-module ip address 192.168.100.2 255.255.255.252
service-module ip default-gateway 192.168.100.1
!
interface FastEthernet0/1
ip address 192.168.99.17 255.255.255.252
ip nat outside
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.99.18
!
!
ip http server
ip http access-class 1
ip http authentication local
ip http secure-server
ip nat inside source list NAT-ACL interface FastEthernet0/1 overload
!
ip access-list extended NAT-ACL
permit udp any eq domain any
permit udp any any eq bootpc
permit udp any any eq bootps
permit ip 192.168.1.0 0.0.0.255 any
permit icmp 192.168.1.0 0.0.0.255 any
permit ip any any
ip access-list extended VOICE-ACL
permit ip 10.10.10.0 0.0.0.255 any
permit udp any any eq bootps
permit udp any any eq bootpc
permit ip any any
permit tcp any any eq domain
!
!
!
tftp-server flash:apps11.8-2-2ES1.sbn
tftp-server flash:cnu11.8-2-2ES1.sbn
tftp-server flash:cvm11sccp.8-2-2ES1.sbn
tftp-server flash:dsp11.8-2-2ES1.sbn
tftp-server flash:jar11sccp.8-2-2ES1.sbn
tftp-server flash:SCCP11.8-2-2SR1S.loads
tftp-server flash:term06.default.loads
tftp-server flash:term11.default.loads
tftp-server flash:apps70.8-2-2ES1.sbn
tftp-server flash:cnu70.8-2-2ES1.sbn
tftp-server flash:cvm70sccp.8-2-2ES1.sbn
tftp-server flash:dsp70.8-2-2ES1.sbn
tftp-server flash:jar70sccp.8-2-2ES1.sbn
tftp-server flash:SCCP70.8-2-2SR1S.loads
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
!
control-plane
!

telephony-service
no auto-reg-phone
load 7970 SCCP70.8-2-2SR1S
load 7911 SCCP.8-2-2SR1S
max-ephones 24
max-dn 30
ip source-address 10.10.10.100 port 2000
auto assign 1 to 24
timeouts interdigit 5
time-zone 35
max-conferences 8 gain -6
moh music-on-hold.au
web admin system name alucard777 secret 5 $1$FL95$2jgtmf0gWLSDRfFVfoQD2/
dn-webedit
time-webedit
transfer-system full-consult
create cnf-files version-stamp 7960 Sep 06 2009 10:11:35

 

 

I would appreciate any help.

1 REPLY
New Member

Re: SGE2010P

I need a running configuration from your SGE to verify that all vlans are properly configured and being trunked/tagged going to your router.

You should have your trunk port configured as a trunk with the native vlan as 1 and have vlan 20 tagged across it. You should also have each port set as a trunk port with the same configuration if you want your phone and pc to be daisy chained off a single port.

Then you should make sure port security is set for 3 mac addresses. The router's config looks good but you did not post a config for the SGE. It would also be good to get a diagram of what is attached to each port on the switch.

Bill

718
Views
0
Helpful
1
Replies