Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SRW2048 Web GUI

My work just bought this switch last week. The switch was brand new when I opended the box.

The web GUI on the switch never fully opens so that it's functional. On each browser that I try the page only loads halfway... It seems the iframe content never loads but the graphics always do.

I've tried IE 6.0, Firefox 3.6.12, and Chrome 5.0. I've set the security to low, and also set the address to trusted in IE. no change.

I also flashed the switch with the latest from cisco.com...'SRW2048_FW_v122d_gesm-12220' Issue still remains....

I found other threads with people with the same issue lat year... the answer at the time was to flash to the latest firmware.. Well that's the 3rd thing I did....

Screenshots should give you a better idea of what I'm seeing.

Any suggestions?

7 REPLIES
Silver

Re: SRW2048 Web GUI

There are two options you can do to resolve this.  The issue is the active x is not installed completely on the IE browser and needs to be installed completely.  Go to tools/internet options/security/custom level. Once there scroll down to all the active x controls and plug-ins all the way to active x controls marked safe for scripting.  Make sure all of these are enabled or prompted.  Run this and restart the browser.  After you do this it should allow you to the gui.  The other option is to get the ie tab 2 for firefox and go to the switch in ie tab in firefox.  I have not found any issues with the firefox ie tab.  Once you install it, there will be a firefox symbol in the bottom right corner of the page, click that and it will turn to an ie tab.  Once you have done that your in ie tab mode and this should allow you access to the gui.

New Member

Re: SRW2048 Web GUI

I'm having the exact same problem.  I tried the solution that you supplied, davicarr, and this didn't help me either.

Silver

Re: SRW2048 Web GUI

What os are you using to access the switch todd?  If the prompt in the active x controllers keeps prompting, then change them to on instead of prompt.

New Member

Re: SRW2048 Web GUI

davicarr,

I'm using Windows Server 2003 R2.  Changing them to "ON" doesn't help either.

I was able to do what I needed by going into the super secret lite-ish version of IOS, which I found out about after searching around on here and google for a while.  So I have given up trying to get into the web GUI.  I called tech support and some guy told me that I probably needed to reset the switch to the factory default and reload the backup I (luckily) made just before I upgraded the firmware and started having this problem.  Although it's possible that'll work, I didn't think it was likely, or worth the trouble, especially once I figured out how to get a better CLI.

To anyone that wants to know: to get into that lite IOS CLI, telnet into the switch and log on.  Then hit CTRL-Z.  At the new prompt, type lcli and hit enter.  Log in again.  Voila, it's kinda like IOS.  The difference is that there's no running-memory, so you have to do a "sh start" to view the config.  Also, instead of configure terminal, (conf t), you have to just type configure (or conf).  There are a bunch of other things that you can't do because it's not a high end cisco switch, but you can figure it out along the way.

We're not going to be buying any more Linksys switches here.  We need much better support, and we also need to actually be able to get into the config without having to rely on some guy hacking into the thing and posting about it on the web.  For the times when we don't want to spend the cash on a high end Cisco switch, we're going with HP from now on.

New Member

Re: SRW2048 Web GUI

What a JOKE of a solution.... You really are asking customers to do this? WOW!

I find this to be rather ridiculous to ask customers to do this. I should be able to pull up a fully functional GUI with IE or FF without installing additional plugins. I can do this with OTHER switches, routers and other devices no prob. I've never had an issue like this with a cisco/linksys product till now. Why is support and development lacking with this product?

The 'solution' is rather a bandaid to the issue. So everyones browser is fubar, while the switch is operating like normal? I don't think so...

I've set activeX to prompt or ask admin when it wants to run... I close the browser, reopen.. and guess what? THE SAME THING HAPPENS...

IE tabs in FF? Are you really serious asking customers to install IE tabs on FF. This uses the IE engine instead of FF... So why even try FF if you're not going to use it? What if its a dev machine and I DO NOT want extra software on it... Or FF is not even installed?  What if I have no internet on the machine?

There must be another workaround, or a solution as the one suggested is NOT working.

So CISCO, Are you going to leave your customers out in the rain, or are you going to support the product and fix the issue instead of having customers apply bandaid to an issue on you're product?

Please don't force me to return this switch and buy something else.

Thanks.

P.S, I right click and get a menu to insert an image, or align or insert a table.. Uhh, remove that 'feature'... You have these options above, why remove the ability to check spelling on the fly with a right click? Ugh.

New Member

Re: SRW2048 Web GUI

After doing further investigation, and speaking with a a buddy of mine. This issue is only on Server OS such as Windows 2003 with IE enchanced security browser. (which was not enabled)

I plugged into the switch with my lappy with Windows 7, 64bit with IE8 and the GUI came up.. slow.. but its now functional.

So, why is this not disclosed?  Seems like MS Server OS's, Win2k3, Win 2008 with IE will NOT work, while desktop IE and browsers will work.

I'm still working on a reasonable solution since cisco can't seem to come up with one.

Thanks!

New Member

Re: SRW2048 Web GUI

Why are you even using ActiveX?

  • ActiveX is only available on Windows operating systems, and as a result webpages that require it will not work on Linux or Mac.
  • ActiveX integration with the Windows operating system has made it a target for malicious software.

Use a standard like HTML4/5, JavaScript, CSS... where just about all browsers now support.

1630
Views
0
Helpful
7
Replies