Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SRW208: IGMP Snooping not working!

Hi all,

at the moment we have trouble with the following SRW208 setup:

- Port mirroring is enabled (Port 8 mirrors Port 1) for sniffing via Wireshark in promiscuous mode.

- 'IGMP Snooping' is enabled for all ports.

Our test scenario:

- an IPTV settop-box is connected to port 1 and gets/sends traffic from/to a VDSL router connected to port 2.

- a wireshark PC sniffs at mirror port 8 (all traffic) in promiscuous mode

- another wireshark PC sniffs at port 3 (all traffic) in promiscuous mode

With  IGMP snooping enabled only the wireshark PC at (mirroring) port 8  should be able to sniff the mcast traffic between the settop-box and the  VDSL router.

The  problem is that wireshark can sniff the mcast traffic at all ports.  In addition the LED of all active ports are blinking  synchronously/continuously.

It seems that the IGMP snooping does not to work properly because all ports are still flooded with mcast traffic.

With an old Zyxel switch the same setup works without a problem.

Is this a known problem of the srw208?

Cheers,

Fred

7 REPLIES
New Member

Re: SRW208: IGMP Snooping not working!

Fred,

          I have the same issue with our SRW2008. I have it hooked up to a Spirent TestCenter in the following diagram:

     When I run the RFC3918 multicast test, Spirent ports 4, 5 and 6 send group registration requests and

are seen by Spirent port 3 (means they have made it through the switch). The multicast traffic then generated

from Spirent port 3 is seen on all Spirent ports 4-8, when it should only be seen on ports 4-6. I have

snooping configured and have tried it and without VLANs, changing the Ports from Access to Trunk but I

always seem to see the multicast packets spewing from ports 7&8 when they should not.

     Have you hand any luck with technical support?

Thanks,

         John C.

New Member

Re: SRW208: IGMP Snooping not working!

So much for the image upload, how about this diagram:

                            ___________

Spirent 3 --------------|  SRW2008  |------------------ Spirent 4

                            |                   |------------------ Spirent 5

                            |                   |------------------ Spirent 6

                            |                   |------------------ Spirent 7

                            |                   |------------------ Spirent 8

                            ---------------------

New Member

Re: SRW208: IGMP Snooping not working!

In order for snooping to work, the Enable Bridge Multicast Filtering must be set (under Bridge Multicast

tab.) But the port selections on this menu only allow to select None, Forbidden and Static (Dynamic is

not selectable.) Forbidden and None are for excluding multicast packets, so that only leaves Static which

is not what is needed. I'm currently waiting for Tech support to to duplicate the issue and tell me why I can't

select Dynamic.

Thanks,

      John C.

New Member

Re: SRW208: IGMP Snooping not working!

Hi John,

did you get an answer from Cisco in the meantime?

Regards,

Fred

New Member

Re: SRW208: IGMP Snooping not working!

Hi John,

didn't get an answer or technical support so far which is a little bit disappointing.

Hope you will have more luck with your request...

Cheers,

Fred

Silver

Re: SRW208: IGMP Snooping not working!

What setting do you have the bridge multicast and the bridge multicast forward all?


If those settings are setup on the port then it will flood the unregistered multicast on that port.

New Member

Re: SRW208: IGMP Snooping not working!

See my post on November 5th. The Bridge Multicast tab needs to have the port "Dynamic"  be settable. It is not and technical support said they would see why this is not being allowed, but they never got back to me.

John C.

962
Views
0
Helpful
7
Replies
CreatePlease to create content