Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Three SG300 keep on restarting (SYSLOG-F-OSFATAL: FATAL ERROR)

Dear All,

 

We have Total 7 SG300 switches for Desktop access dual-homed to Pair of 3560-x switches for Data access in branch environment.

All 7 switches have identical configuration, hardware version and were commissioned at the same time.

However only three of them keep on crashing or restarting intermittently without any time correlation with each other.

But the issue occurs only during working hours

 

Error on all of the switches before crashing :-

SYSLOG-F-OSFATAL: FATAL ERROR: tExcTask: ABORT DATA exception ***** FATAL ERROR ***** SW Version : 1.2.7.76 Version Date: 19-Jul-2012 Version Time: 17:54:43 Instruction 0x18 Exception vector 0x10 Program state register 0x80000092

 

Information level message on all of the switches after crashing :-

INIT-I-Startup: Cold Startup

14 REPLIES
Bronze

 Hi, Try to upgrade the

 

Hi,

 

Try to upgrade the firmware of the switch over console.Still issue exists .Kindly raise the TAC ticket to get replacement of the switch.

 

Firmware link:

http://software.cisco.com/download/release.html?mdfid=283019669&flowid=18907&softwareid=282463181&release=1.4.0.88&relind=AVAILABLE&rellifecycle=&reltype=latest

Cisco TAC contact details:

http://www.cisco.com/c/en/us/support/web/tsd-cisco-small-business-support-center-contacts.html

 

 

New Member

Dear V K Moorthy,Could you

Dear V K Moorthy,

Could you explain how to upgrade SG300 firmware over console, because i could only find below three methods.

  • HTTP/HTTPS that uses the facilities provided by the browser
  • TFTP that requires a TFTP server
  • Secure Copy Protocol (SCP) that requires an SCP server

 

 

Bronze

Hi, Refer the attached

Hi,

 

Refer the attached document.

 

 

regards

Moorthy

New Member

Is it possible to upgrade

Is it possible to upgrade both the boot code and the firmware through this method?

Bronze

 No only we can upgrade the

 

No only we can upgrade the firmware.

New Member

Hey, Post upgrading one of

Hey,

 

Post upgrading one of the affected switch, new issue is being observed.

If both the two links are connected to upstream pair of 3560 switches, a layer 2 loop is found to be occurring with multiple mac flap notifications and traffic utilization shooting to 400 Mbps from normal 1 Mbps.the loop is rectified after one of the link to 3560 switches is disconnected.

The loop is observed even if no other host is connected to the switch except these two uplinks

 

The configuration which was working fine before upgrade, is now  causing this issue post upgrade.

 

 

 

Bronze

Which is the root-bridge in

Which is the root-bridge in your network:3560 or SG 300 .Kindly share the network topology of your network. 

New Member

     Root Bridge             

 

 

   Root Bridge               port channel

[3560 1]---------------------------[3560 2]

         |                                           |

         |                                           |

         |                                           |

         |------------[SG300]-----------|

                     

 

 

 

 

 

As you can see for all of our Sg300 Root bridge id is same as bridge id.

and port on secondary 3560 usually goes to block mode, but in case of upgraded Sg300 the port on 3560-2 switch remains in forwarding mode only.

Bronze

Kindly share the STP priority

Kindly share the STP priority values for switch 3560-1 and 3560-2

New Member

Below is configuration for

Below is configuration for port 32 connected to working SG300.

Affected SG300 is connected to port 33 and has identical configuration

 

 

3560-1

Port 32 (GigabitEthernet0/33) of VLAN0031 is designated forwarding
   Port path cost 4, Port priority 128, Port Identifier 128.32.
   Designated root has priority 4127,
   Designated bridge has priority 4127,
   Designated port id is 128.32, designated path cost 0

 

3560-2

 Port 32 (GigabitEthernet0/33) of VLAN0031 is alternate blocking
   Port path cost 4, Port priority 128, Port Identifier 128.31.
   Designated root has priority 4127,
   Designated bridge has priority 4127,
   Designated port id is 128.31, designated path cost 0

Bronze

Hi, Kindly take the

Hi,

 

Kindly take the configuration backup from SG300 switch.Reset the switch to factory default and upload the configuration back.After that you have same issue.Kindly raise the TAC ticket to cisco support team.

Support center contact details:

--------------------------------------http://www.cisco.com/c/en/us/support/web/tsd-cisco-small-business-support-center-contacts.html

New Member

Nothing seems to work , same

Nothing seems to work , same issue exists even after factory reset,

It seems the switch is filtering BPDUs as port facing SG300 of 3560-2 shows 0 BPDUs received.

 

 

Hi,Can you try to change on

Hi,

Can you try to change on catalyst PVST+ to classic STP and on SG300 RSTP to classic STP?

Those two are running different STP versions and simply do not understand each other BPDU messages.

Aleksandra

I would not do the xmodem

I would not do the xmodem console load unless you tried a normal update first.  It seems you can still access the switches and they only reboot intermittently, right? 

I would suggest just normal firmware and boot rom upgrade to current version first.

Also, there is no TAC assistance for SG300 you have to go through SBSC support: http://www.cisco.com/c/en/us/support/web/tsd-cisco-small-business-support-center-contacts.html

 

-- please remember to rate and mark answered helpful posts --
452
Views
10
Helpful
14
Replies