Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

New Member

Voice VLAN not communicating between SG300's

I have two SG300's, one is setup as Layer 3 and the other is setup as Layer 2.

On the Layer 3, I have voice vlan 100 setup with IP 10.10.10.1. I have turned off Spanning Tree and Smart port. Vlan 1 is setup for all other devices on the network. All phones and PC's work fine on this switch. The phones communicate with a server that is plugged into a port with access to 100.

On the Layer 2, I have auto voice vlan 100 and do not have an interface for the voice vlan. I also have STP and Smart Port disabled. Vlan1 is configured as well.

All ports on both switches are configured as:

interface gigabitethernet24

switchport mode trunk

switchport trunk native vlan 1

switchport trunk allowed vlan add 100

So 100 is tagged and 1 is untagged. Like I said, works fine on the L3 switch. On the L2 switch, all PC's are working fine and able to communicate with all PC's but the phones are not working in the voice vlan. They are not communicating with the phone server which provides their DHCP.

Any suggestions? The trunk port between the two switches is configured the same, trunk mode with 1 untagged and 100 tagged.

6 REPLIES
Green

Voice VLAN not communicating between SG300's

Hi Christie.

So from switch #1 layer 3 point of view your config looks something like this-

Vlan 1 and Vlan 100

config t

vlan database

vlan 100

interface vlan 1

ip address x.x.x.x /24

interface vlan 100

ip address 10.10.10.1 /24

Port 1 = VOIP DHCP server as vlan 100 untagged

config t

int gi0/1

switchport mode access

switchport access vlan 100

You have another port, lets say port 24 as a trunk between the switches.

config t

int gi0/24

switchport mode trunk

switchport trunk allowed vlan add 100

On switch #2, the layer 2 switch, one problem is you have auto voice vlan enabled but disabled the macro so for deminstration purpose your config should look something like this-

config t

vlan database

vlan 100

Your trunk to the layer 3 switch let's say on gi0/24 also

config t

int gi0/24

switchport mode trunk

switchport trunk allowed vlan add 100

Then a connection for your phone, let's say on port 1-

config t

int gi0/1

switchport mode access

switch port access vlan 100

With this fundamental set up as describe your phone connection to the layer 2 switch should work.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

Voice VLAN not communicating between SG300's

That is accurate except for all switch ports (besides the server port) are defined as:

int gi0/1

switchport mode trunk

switchport trunk native vlan 1

switchport trunk allowed vlan add 100

It's like this on both switches, works on the L3 switch but not he L2. Smartport is disabled on both.

Green

Voice VLAN not communicating between SG300's

Hi Chrstie, so the problem is your phone is remaining on VLAN 1 hence not communicating to VLAN 100 where your server is.

If you set your phone on an access port vlan 100 I am sure it works?

If so, the problem is with the phone not tagging in to VLAN 100.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

Voice VLAN not communicating between SG300's

The phone is not even remaining in vlan 1, vlan 1 has a DHCP server as well and it's not getting an IP from there. It goes no IP from either DHCP server. If I assign it an IP in the VLAN 100 scope, it is not pingable from the phone server in that VLAN. It's almost like it has a connectivity issue.

Green

Re: Voice VLAN not communicating between SG300's

Test the basic connectivity.

On the layer 2 switch, connect a computer to access port 1. Does it receive DHCP?

Connect a computer to access port 100. Does it receive DHCP?

Is the default gateway of the DHCP server set correctly as the IP address of the switch VLAN address or somewhere else?

If you connect a computer on VLAN 100 from the layer 2 switch and configure it with the gateway address of the VLAN 100 IP (10.10.10.1) does it communicate to the SVI?

So to make the hypothetical situation.

VLAN 100 = 10.10.10.1

VLAN 1 = 10.10.1.1

DHCP server is vlan 100 untagged at IP 10.10.10.2 with gateway 10.10.10.1

Computer A located on the layer 2 switch to test both VLAN... to start VLAN 1 with an address 10.10.1.2 and gateway 10.10.1.1 on an access port  and to test VLAN 100, 10.10.10.10 with gateway 10.10.10.1 from an access port.

Both of these scenarios should prove true. At the very minimum you should be able to ping the switch SVI for both VLAN assuming you have an active connection on the layer 3 switch (IE, your trunk link).

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
New Member

Re: Voice VLAN not communicating between SG300's

Hi,

On Your l2 switch,

Below config should work,

Config#voice vlan state auto-enabled

Config#inter range giga 1-28

no lldp transmit

switchport mode trunk

switchport trunk tagged native vlan 1

switchport trunk allowed vlan add 100

spanning tree portfast

exit

579
Views
0
Helpful
6
Replies
CreatePlease to create content