Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Flash Firmware WRV200

After flashing the latest version of the firmware for the WRV200 (1.0.39) all of the pages on the web based admin tool are not working, and some are missing alltogether.

I need to be able to re-flash the firmware to an earlier version (or attempt to re-flash this version) without using the web-based admin tool, as the page for doing the flash is one of the one's that is missing. Re-setting it doesn't help.

Can anyone point me to simple instructions for this? I have tried searching here and through Google without any luck so far. The WRV200 works fine, but obviously is not locked down from a security standpoint, which is a large problem.

Thanks in advance!

Everyone's tags (3)

Re: Flash Firmware WRV200

Hi Todd,

That Wireless Router with VPN 200 router has been superseded with the WRV210,  ok not new news.

Is the WRV200  just having a problem with a modern browsers ?  Remember some of the modern browsers weren't around when this product was first developed

As a first step, what happens if you use and older version of Internet explorer to access the router. (maybe IE version 6)

As a second step, you might try something like  http://192.168.X.1//AdminUpgrade.htm   (substituting x for the real network address)

I haven't tried this as my WRV200, but i believe this is the URL to bring up a firmware upgrade prompt.  Still don't know if this will work,  and it's still under three year warranty try calling the local Small Business Support Center  via the URL below.

I'll also keenly wait to see other responses you get to your issue.



Community Member

Re: Flash Firmware WRV200

David ... thanks, but I don't think it's a browser issue as I've tried it from several machines with various versions of IE, Firefox and Chrome. The page that you mentioned for flashing the firmware is actually blank (as are several others).

My guess is that somehow the flash I attempted did not complete properly and the web based admin functionality is the part that got corrupted.

Unfortunately, it's out of warranty. Was hoping there was some way to flash it directly so I didn't have to trash the thing and buy a new one.

Re: Flash Firmware WRV200

Hi Todd,

You never know.

i will monitor this posting,  as the good folks at the SBSC and the Business units monitor these postings.

Might still get a response.. so hang in there.   Just out of interest, can't recall if you factory reset the unit.

the only problem with that is that the unit is sorta working now.  After a factory reset everything will be at default setting.

regards Dave

Community Member

Re: Flash Firmware WRV200

Yep, tried the factory re-set many times. Unfortunately it only reverts to whatever the last firmware that was flashed. In my case it appears that firmware was either corrupted, or didn't complete, so nothing changes.

Re: Flash Firmware WRV200

Hi Todd,

Just had a word to the good folk at Small Business Support Center. 

The comment is that if remote access via WAN support was enabled, you had a pretty good chance of accessing the router and the GUI coming up.  Since the machine was factory reset any chance of that happening is now gone.

CreatePlease to create content