Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

My WAP371 disconnects in 5GHz band

Hi,

Recently I've bought the WAP371 access point (European version) and updated it with the firmware 1.0.0.10.
Unfortunately this device does not work properly in the frequency band of 5 GHz, in the frequency band of 2.4 GHz it seems to work fine.
The issue in the frequency band of 5 GHz is that it causes disconnections in both modes; N and AC. I can reproduce this issue relatively easily if I transfer huge files (5-6 GB) over the device, but the disconnections occur sporadically also at low load.
Originally I blamed the Intel's Wireless-AC 7260 wifi card or it's device drivers/firmware, but having observed the same issue using different hardware/software/firmware combinations - I tested with a few laptops with different wifi cards (three Intel's Wireless-AC 7260 cards and one Centrino Ultimate N- 6300 AGN) running under different operating systems (MS Windows 8.1 and 7 Pro, Linux Arch64  with Kernel 3.15 and 3.16) - I'm sure that my WAP371 is to blame for the disconnections.
My questions are:
1. Are there other owners of the WAP371 having the same problems?
2. Is this a known issue of Cisco's WAP371, generally,  or is it rather an issue of my device only?
3. Is there anything I could try out before I give my WAP371 back?

Thanks in advance for any idea! 

Everyone's tags (1)
17 REPLIES

Hello,My name is Eric Moyers.

Hello,

My name is Eric Moyers. Thank you for using the Support Forums.

If I amy ask, what are you using to power your device? A power adapter or a PoE switch. If a Switch what is the make and model, please?

Thanks

Eric Moyers
.:|:.:|:. CISCO | Subject Matter Expert | Cisco Technical Support |
Together We Are The Human Network

 

New Member

Hello,Thank you for your

Hello,

Thank you for your response!

I've tried both, a 12V DC power adapter and a budget PoE injector supporting IEEE802.3af.
In both cases the results were the same - disconnections after data-transfer of approximately 1.4 GB (or sometimes after 4 GB  if WAP371 had been reset immediately before I started the test.
Also In both cases I experienced sporadically disconnections at low network load (e.g. during internet brawsing).

Thanks!

I have seen simialr scenarios

I have seen simialr scenarios when the WAP was under powered. The Power injector that is suggested is a PWR-SB-INJ2

http://www.cisco.com/c/en/us/products/collateral/interfaces-modules/small-business-network-accessories/datasheet-c78-731787.pdf

and when using a power adapter 12volt 2amp.

If you are running both radios and Single Point Setup or Captive Portal, I would suggest using a PoE+ switch.

Eric Moyers
.:|:.:|:. CISCO | Subject Matter Expert | Cisco Technical Support | 
Together We Are The Human Network

New Member

Thanks for this idea, but the

Thanks for this idea, but the problem seems not  to be concerned with the power supply.
Actually, just to be sure of this, today I powered my WAP371 by a professional regulated power supply with a nominal voltage of 12 V and max. current of 3A.
I was measuring the input voltage on the AP continuelly during testing and it had never fallen under 12.3 V. Nevertheless, my WAP371 caused disconnections on the IP layer - originally I forgot to mention that the disconnections seem not to be on the radio/wifi layer, but rather on the IP layer. I suppose this since the symptoms are as followed:

1. If I am testing with Linux (Kernel 3.15 or 3.16),  there are no according warning/error messages from the system/kernel. Even after connection failures, the network interfaces seems to be OK - the command "ifconfig" returns still a valid IP address. So, also the Linux Network Manager does not detect any connection errors. First high level communication layer do that - applications detect and report timeouts.
This status remains usually as long as I do not reconnect  the wifi interface.

2. Also under MS Windows I do not get typical disconnection indications - in the first 20-60 seconds there are no changes in the network icon (on the right in the status bar on the bottom of the Windows desktop).
I usually test by copying data form a network drive  to my local hard drive using Windows Explorer. The first symptom of a disconnection is a connection-error concerning the path to the network drive. First after a while Windows detects (only) that there is no internet-access anymore - there appears just the warning sign in the network icon. Usually (but not always) Windows tries then automatically to solve the problem (reconection?) and the warning sign disappears. Then I am usually able to restart the file transfer again.

3. Generally, after the problem has once occurred, I am not able to access any IP-devices via WLAN from my test laptop, neither other PCs nor the WAP371. However, the WAP371 is still accessible over LAN (Ethernet) and from other computers even over wifi. The disonnections are not reported in WAP371's log.

Thanks in advance for further ideas!        

New Member

Finally, I was testing the

Finally, I was testing the WAP371 under low power requirements, i.e. in the configuration after factory-reset ("Single Point Setup" disabled, no "Captive Portal" no SMTP, etc,) and with only 5 GHz band enabled. As mentioned earlier, I powered the device  using a high quality power supply (regulated 12V/3A ). Unfortunately, the problem occurred just the same ;-(
On the other hand, I tested on the same location access point products of other vendors - they worked perfectly in 5 GHz band! 

As I found, in "Small Business Support Community -> Small Business Wireless" other customers working with a similar wireless product of Crisco (WAP561) reported disconnection issues too, and Cisco seem to have never solved them (!)-  see in the thread "Devices keep disconnecting since WAP561" (https://supportforums.cisco.com/discussion/12199931/devices-keep-disconnecting-wap561).

I am really deeply disappointed of Cisco's WAP371 and Cisco's (pseudo-) support - my case was closed a day after I had reported the problem, just so, without any effective solution!
In this situation I have no choice, I will return the buggy WAP371 to the retailer and will finish my adventure with Cisco.

Thank you Cisco and good-by!

New Member

I agree with you here, Cisco

I agree with you here, Cisco should pick up these problems and fix them for once and for all on all WAP products. Things like:

- Dropping internet connectivity,
- Dropping wireless clients (mostly apple products)
- Bonjour still buggy

Seem to continue to happen with WAP3x and WAP5x series and after all these months i still hope Cisco will actually pick things up and release a new firmware fixing these issues instead of forwarding everyone to open a support ticket.

New Member

Hi, I'm experiencing the same

Hi,

 

I'm experiencing the same issue...

I have a WAP371 with latest firmware (1.0.1.5) connected to a PoE+ switch (Netgear GS728TP), and when I'm on the wifi AC 5 GHz band with either my Windows 8.1 Pro laptop (Intel 7260 AC card) or my Android smartphones (LG G3 and Samsung Galaxy S4), when transferring big files or when streaming movies it works for the first seconds/minutes but then at one point I have no TCP/IP traffic anymore... My file transfers never completes, and my movies stop streaming.

Even opening a google page doesn't work anymore. The Wifi is still connected, but I have to turn off the radio on my devices and turn on again in order to re-enable the TCP/IP traffic...

Very annoyed by this... 

The AP replaced by this one (a Netgear WNDAP660) worked flawlessly on the 5 GHz band (though only N, not AC wifi), connected to the same port of the same PoE+ switch...

Any solution?

New Member

I have the same problems with

I have the same problems with WAP 371, the Cisco support is just a shit. They have tried many times and finally find it is difficult to solve it, then they just find an excuse to end my case. And I have to solve this by myself. From the log this problem is caused by group session key handshake time out, and mostly happen when transferring high data load. It is a firmware bug, actually the WAP 371 cannot have enough computing capability to support 803.11ac data throughput. Therefore when high data rate happen, the thread which handle group session key handshake cannot have CPU time to run. The feasible solution is simplifying all the configuration to reduce CPU load. Such configuration includes set 802.11ac channel as fix channel, set multicast rate as fixed 54Mbps rate, and prolong the group session key refresh time duration from 300 seconds to 3000 seconds. In my environment the WAP 371 can stably transfer over 300 GB data without any interruption after I configured as above. You may try it and we can continue discuss it in this post.

 

New Member

Hi, Great that I finally find

Hi,

 

Great that I finally find someone who can give me some tips :)

I will try your recommendations and report... When you talk about the group session key refresh time, I assume you're talking about the setting named "Broadcast key refresh rate" in the Networks menu?

 

Also, for the fixed radio channel, should I preferably use a lower or higher channel? There are no other 802.11ac networks in my area so I can set whatever channel is the best... Choice goes from 36 to 112.

New Member

It shouldnt matter but I

It shouldnt matter but I would recommend channel 36 or 40 for 5Ghz.

I have no idea why the change of broadcast key refresh rate would fix anything.

What you could do, that fixed a lot of problems for me is:

- Disable bonjour (Administration)
- Disable Banwidth utilization (Wireless)
- Set a static channel for both 2.4 and 5ghz
- Use WPA2 only
- Use 20Mhz for 2.4ghz and 80Mhz for 5ghz mode
- Frame burst enabled for 5ghz only

That's it.

New Member

Wow guys, thanks! I had to

Wow guys, thanks!

 

I had to disable frame burst totally (2.4GHz and 5GHz) in addition to all your recommendations but I can now finally transfer 20+ GB files at around 40MB/s without issues!!!

Also I don't have streaming issues anymore with mobile devices, the connection doesn't freeze after a while.

I appreciate your help, thanks for sharing :)

New Member

I have exactly the same

I have exactly the same problem. I cannot make any time machine backup.

I'll give a try with your solution.

I hope cisco will fix this issue...

New Member

- Disable bonjour

- Disable bonjour (Administration)
- Disable Banwidth utilization (Wireless)
- Set a static channel for both 2.4 and 5ghz
- Use WPA2 only
- Use 20Mhz for 2.4ghz and 80Mhz for 5ghz mode
- Frame burst enabled for 5ghz only

Do all that plus set for both bands set DTIM period to 1 (2 by default).

Set Legacy rates sets to, basic: 1, 2, 5.5, 11 and Supported rates enable all.

Enjoy ;)

New Member

Thanks for your advices. It

Thanks for your advices. It seems you're the only support for this problem (where are the cisco guys?)

I changed the DTIM value to 1 and set the channel from 40 to 44

In addition to your settings I have :

- Fixed Multicast Rate : 54 Mbps

- Disable Frame burst in 5Ghz

- Broadcast Key Refresh Rate : 0

With all these I still have disconnection problem. Last time it was after 44GB of transfert.

Any thought ?

 

New Member

After changing the channel

After changing the channel from 44 to 36 in 5GHz and channel 6 for 2.4GHz. I finally succeeded a 70GB file transfert (download) for the first time. After that I try a time machine backup of 22GB, but it fails ... It's a shame. Even disabling 2.4GHz doesn't help.

The support should really get concerned with those problems. It has been 4 days of configuration by trial-and-error to get this "almost" working.

New Member

I enabled client Qos and Qos

I enabled client Qos and Qos association and it seems to be working for now.

New Member

I just purchased four WAP371

I just purchased four WAP371 APs along with the recommended external power supplies (Cisco Small Business SB-PWR-12V2A-NA 12V 2A Power ).

The APs seem to work okay but I may have to change the 5Ghz network settings, per the information below.

My observation is that even with using the recommended external power supplies, the power indicator displays RED vice GREEN.  Any ideas?  I hate to think that using the recommended external power supplies are under powered.  If true, I will rethink using Cisco in the future.

7527
Views
5
Helpful
17
Replies