Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

wap321 captive portal not loading

I am struggling with wap321 captive portal. tried a lot of configurations and still cannot get it to work. The portal authentication page just does not load. It always ask for the WPA2 password regardless it is enabled or not in the global configuration. CP instance assigned to vlan1/vap0 and configured. One local user created just for this. if I manually type in the "192.168.1.10/cp.cgi?action=captive" in the browser, the CP authentication page loads, but without pictures. Also tried 1.0.4.4 and 1.0.3.4 firmware and got the same result. I run out of ideas now apart from return it.

The configuration is as follows:

wap321: one SSID on vlan1/vap0, vlan1 is the only VLAN. PID is V01. No ACL configured.

SG200-08P: all port are 1UP and trunking. An old netgear modem/router connected to the switch as dhcp server. DHCP works for wireless and cabled connection. Cabled client can ping the dhcp server and wap321, the wireless client cannot even though it can get ip address from DHCP server.

 

I did read all the cisco documents and Googled a lot to no avail.

 

Thanks for your help.

2 REPLIES

My name Eric Moyers. I am an

My name Eric Moyers. I am an Engineer in the Small Business Support Center.

I am sorry to hear that you are experiencing this issue.

Captive Portal has several pages to troubleshoot. In order to get this resolve for you quickly I would suggest that you please call our support center and open a case so that one of our engineers can work directly with you. Once you have done that you can also post your case number here and I can check in on this case to assist as needed.

Eric Moyers
.:|:.:|:. CISCO | Eric Moyers | Cisco Technical Support |
Wireless and Surveillance Subject Matter Expert

Please rate helpful Posts and Let others know when your Question has been answered.

Community Member

Thanks for the quick reply.

Thanks for the quick reply. It is not convenient for me to call because there is no phone at the location where the AP is setting up.

As to the pages of diagnosis, there isn't really that many. The setup procedure seems pretty straight forward. I am not (yet) trying to do anything fancy. Although started with multi-Vlans, gradually reduced to basic settings just to get the CP authentication page loaded.

Is there any thing stops the CP authentication loading? it seems whatever I do, it always uses the 'normal' wireless authentication method (and it works).

 

 

172
Views
0
Helpful
2
Replies
CreatePlease to create content