Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

WAP321 crashes all the time

We recently purchased a WAP321 to provide public wifi to patrons at our library.  Up until now, we have been using a Linksys E1200 configured as an access point without any issues at all.  We purchased the WAP321 for the Captive Portal feature because we want users to agree to our Internet policy and be directed to a specific page when they connect.

We have tried two WAP321 units so far (we returned the first one), and both of them repeatedly crashed after anywhere between a half hour and two hours of use.  When the crash happens, the SSIDs appear and disappear repeatedly, but no connections can be established.  I also cannot connect to the admin interface.  The only solution is to reboot the device.  Every time the unit has crashed, we have had 5-10 users connected to the guest network through Captive Portal.  Up until the crash, everything has worked fine.

As I mentioned, we have tried two WAP321 access points and experienced the exact same problem.  I opened a support case and the Cisco engineer concluded that the second unit would have to be replaced.  We tried capturing the log at the time of crash through a TFTP server, but nothing showed. Since it is within the return period of the place we purchased it, we are exhanging it through them, which means we will be receiving a third unit.  I don't have high hopes for this unit, and if this one does not function properly, we will likely give up on this model.

I have tried the WAP with PoE and also a power adapter, but it made no difference.  I have tried firmware versions 1.0.4.2 and 1.0.4.4.  I have factory reset and reconfigured countless times.  I have tried both DHCP and static IPs as well.  The access point is connected to a Cisco 2801 router (also the DHCP server) through a Netgear PoE switch.  Once again, the Linksys E1200 works perfectly fine.

Any thoughts on this?  I thought I would post this message to see if there are any ideas before the third unit arrives.  I still have the second unit that I could test in the meantime.

Thanks.

2 REPLIES
Gold

WAP321 crashes all the time

Ronn,

What seems to be different than what you had before is the captive portal feature. As part of your troubleshooting did you test without that feature enabled? Generally a good way to troubleshoot uncommon issues like this is to start with a very basic configuration and then add to it. I would plug the AP directly to the 2801 for starters and use the power supply. That will eliminate the switch as a possible cause of the issue. Start with a simple SSID, then eventually add captive portal if it works. If it fails at some point, contact support and report it. If there is a bug, we need to know about it so that we can work on a fix.

Are there a large number of SSIDs being broadcast in the same area?

- Marty

New Member

Re: WAP321 crashes all the time

The problem is captive portal.  I tried the new unit with captive portal enabled and had the same result: total crash after an hour or two.  Without captive portal enabled, the WAP works flawlessly.  I've had it up for two weeks straight without any problems.  However, as soon as I enable captive portal, it crashes within a short period of time.  Our main goal with captive portal is to direct users to a landing page so we can count hits to the page to determine the number of monthly users. In lieu of this, I have set up the WAP to save its log to a remote TFTP server. With the help of a PHP script, I can parse the syslog file and determine the number of client associations over a period of time. Obviously, this solution is cumbersome and does not allow for a landing page. It would be nice if the WAP could direct newly authenticated clients to a landing page without captive portal (I have seen this feature on a Netgear WAP.). We don't necessarily need people to accept a policy before authenticating; we just need them to be directed to a specific web page.

468
Views
0
Helpful
2
Replies