Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Wireless Clients losing connection to WAP321

I have a SonicWALL running DHCP and two WAP321 Access Points. Mac and iOS clients will connect for around 5 seconds and then lose their IP address and use a self-assigned one. The wireless channels are set statically to the least used in our area. The Cisco logs are as follows:

Feb 18 2000 06:45:19infohostapd[2134]wlan0vap1: IEEE 802.11 STA 20:c9:d0:45:8e:2f deauthed from BSSID 64:9e:f3:87:cc:11 reason 3: STA is leaving IBSS or ESS 
Feb 18 2000 06:45:06infohostapd[2134]wlan0vap1: IEEE 802.11 STA e0:c9:7a:05:29:85 disassociated from BSSID 64:9e:f3:87:cc:11 reason 8: Sending STA is leaving BSS 

 

Any thoughts why this would be happening? This problem was occurring before and after we upgraded to the most recent firmware (1.0.4.4). This happens at random times after hardware reboots, but once it starts it's consistent.

2 REPLIES
New Member

Hi,It would be helpful if you

Hi,

It would be helpful if you could provide some more information about your setup such as:

  1. Firewall settings on your SonicWALL, such as DHCP settings
  2. Verify that your cluster settings are correct, since you are using two Access Points
  3. To clarify, when you try to set your static IP, does it actually set, or would it revert to a different IP address?
  4. Verify if the problem also occur on devices running Windows

The error logs suggest that the clients are roaming out of reach of the WAP, or that there are some interference issues that are jamming the effectiveness of your Access Points. 2.4 ghz phones are often notorious for interfering with other 2.4 ghz access points.

If you think there is no interference from the AP to the device, a few people with the same problem found that resetting and restarting all their devices solved their problem.  

Other solutions can be to give your iOS/mac devices a static LAN IP address before connecting; if those devices are able to connect & sustain a connection, it is a possibility that it might be a DHCP issue between the WAP and your DHCP server. Also, extending the DHCP lease time may help.

Can you isolate the issue by turning off one of the AP’s, and then check whether or not the problem persists? Other problems could result from an overlap between the two APs; the clients could see two strong signals in one area and switches between the two, or there could be a multipath issue where the client is near one WAP, but some kind of multipath or interference is forcing said device to look for another AP that has a better signal strength, but bad signal quality. 

Please reply if you have any questions or concerns. 

New Member

Try changing the following

Try changing the following settings under Wireless > Radio:

Channel Width: 20/40Mhz
Set a static channel that doesnt interfere with other access points. (1,6,11)

Beacon Interval: 50
DTIM Period: 1

Leave the rest as is, and try it again for a few hours, this seemed to have solved a lot of issues for us with IOS/OSX devices.

 

Update: Actually nvm, ill take that back it's still dropping.
 

752
Views
5
Helpful
2
Replies