Cisco Support Community
Community Member

WRVS4400N no internet connection

I wonder if anyone can help me. I have been going around in circles and not really getting anywhere with this.

I have a D-Link DSL-320B ADSL2+ Ethernet modem that connects to the internet fine if I am using just 1 computer. However I have bought a Cisco WRVS4400N to enable me to get all of the other computers at home on the network (wired and wireless).

The WRVS4400N picks up a WAN address from the D-Link BUT I just cannot get an internet connection, just "Local" only. I have tried setting it up as a gateway, as a router, upgraded the firmware but it just is not having it. Its driving me insane as my previous experience with routers has been just to plug em in and let them get on with it. The WRVS4400N is proving very troublesome. I am in the U.K. and use Demon Internet. I have tried to get help from Demon but they have been next to useless.Any suggestions would be greatly appreciated.

Kind regards


Cisco Employee

Re: WRVS4400N no internet connection

Hi Jeremy and thanks for your post.

I brought your issue to the attention of the WRVS4400N product engineer and, after reviewing, he recoomends you call the UK Small Business Support Center. You'll find the phone number here:


Stephanie Reaves

Small Business Technology Group

Community Member

Re: WRVS4400N no internet connection

Hi Jeremy, i have the same exact problem you have (hopefully 'had'). Same d-link modem and cisco router combo, the only difference is that I'm not in the UK. I'm really curious to know if you called cisco and if you got any help? did you menage to make it work afterall?

I can't think of anything right now, i tryed everything i could think off to make it work but nothing yet...

Any help would be very very appreciated!



Community Member

Re: WRVS4400N no internet connection

Same problem for me.  I tried everything I could think of.  It came with the latest firmware.  Will try and reload

it anyway, as I'm a loss for more ideas.

Will call tech support tonight it that fails.


Community Member

Re: WRVS4400N no internet connection

Hi Sam, before you go trough a lot of troubles for nothing (which is what i did) I'll share with you my experience.

Before I say anything i want to say I'm not a network expert, i bought this product not for a business but for my home.

The only way i got the router to properly communicate with the modem was by setting the modem in bridge mode with pppoE and giving the router the task to communicate username and password to my ISP, couldn't get anything to work until i did that.

Later on i still had troubles with that configuration since my isp renews the public IPs that gives out and the router/modem configuration wasn't able to catch up with that dropping the dsl connection.

But i did something a lil drastic, but that i do not regret a bit, i changed my modem. Bought a netgear dsl DM111 adsl2+ modem, and left it in default configuration and left the router's "Internet connection type" on the default "Automatic Configuration setting - DHCP".

Now everything works and i'm happy with the router and the modem.

Someone more expert than me probably would have solved this without changing the modem, but i'm no expert and the trouble was not worth the extra 30 $ for the second modem.

Hope this helped, maybe the bridging approach will work for you.

Community Member

Re: WRVS4400N no internet connection

For starters, thanks a bunch for the great reply. The bridge technique worked (mostly).  I never would have tried that and I'm sure you saved me hours. Now my issue is that my Wireless N client (toshiba laptop) connects fine and I can see the Internet, but my wireless G client (HP laptop) connects, but can't see the Internet.  I only get an IP address.  I haven't checked if I can see stuff on the LAN.  I was too tired!

What a pain! 

I appreciate all the insights.  I'm trying to concience ATT to give me an updated DSL modem, but so far, they want $40.  I didn't buy the first one (I don't think I tehcnically own it either).

Wish me luck and thanks again,


Community Member

Re: WRVS4400N no internet connection

I had big problems as well and in the end swapped my D-Link adsl2+ modem

for a Draytek Vigor 120 ADSL2+ modem. This came with true PPoa/PPoE

bridging. I have had it running now for almost a week and it has not

disconnected yet. With my previous modem I got a disconnect whenever

there was an incoming call but it would also disconnect for no reason

at all.

The Draytek Vigor 120 was a more expensive bit of kit BUT has saved my

sanity & no doubt that extra bit of time I have now due to not having to

troubleshoot/reboot my modem and router will be spent on making money

for the business. My mistake was getting a cheap ADSL modem in the




On 16/11/2010 20:41:52, sam88jeep

Community Member

Re: WRVS4400N no internet connection

So it seems that my DSL modem isn't the real culrpit (at least after I starting using the PPoE

bridging).  The router does its job great if I turn the WPA2 off, and run "wide open".  If I try any flavor of WPA, WPA2, AEA, TKIP... no love.  My wireless N laptop works great, but my wireless G one either won't connect, or will only "psuedo connect" enough to get an IP address, but nothing else.

(Can't even ping the gateway IP)

I tried different channels... no help.  I also tried "G-Only" mode.  No luck there either.  This HP (802.11G) laptop connects fine to my old dlink router.

Any advice?   Since i have an isolated problem, I think I'm more apt to have success with customer support, so that's where I'm headed next.

Thanks all for all the advice so far,


Community Member

Re: WRVS4400N no internet connection

I'm sorry but i don't have any advice on the wireless problem, i use only wireless.G devices from laptops cellphones and game consoles and they all work fine.

It is weird that you can connect with a wireless N device but not with a wireless.G if you have both of them enabled.

If you messed around with a lot of options and settings one thing you could try is to hard reset the router.

I say it because some times when i get frustrated fixing stuff i try to cahange everything and it might happend that i leave that little setting in the wrong configuration and spending more time on it is not worth it.

But that is my case, i'm not assuming you did something wrong, is just a suggestion.

CreatePlease to create content