Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

5428-2 , brocade switches and ql2200 with fcip

I keep on getting these messages when I connect a Qlogic ql2200 adapter to 5428 that's using FCIP between two SAN's that are using Brocade 3800 switches:

Mar 13 08:21:06: %FC-5-PortOperChange: PortOperChange;2959;0;0;1

I assume that I don't have the 5428 setup correctly for the ql2200 and I understand that there's a CISCO white paper describing how to set up the 5428 for interoperability with the Brocade switches and Adapaters. Could I please get a copy. Thanks

9 REPLIES
Cisco Employee

Re: 5428-2 , brocade switches and ql2200 with fcip

This message doesn't mean much by itself other than the port changed status from down to up.

Other than this message in the log, is everything else OK? I mean you do not indicate whether things are working or not past the OperChange message.

Do you see the Qlogic in the nameserver? What storage is zoned for this HBA and can the OS see storage?

New Member

Re: 5428-2 , brocade switches and ql2200 with fcip

I know that the message probably didn't mean much, but what I was really after was getting a copy of the Interoperability White Paper that's been mentioned in this forum serval times. I like figuring out how things work from the documentation provided so I can refer my customers to authoritative information. I was hoping to solve the problems I am having by refering to this White Paper.

OK, so here's my PROBLEM: No I don't see the qlogic adapter in the Brocade Nameserver. I was finally able to get the two 5428's to be seen in the fabric once I changed their domain to 112 and 114, something that wasn't in any of the Cisco documentaton, I know it's all Brocades fault.... I also changed the Buffer to Buffer Credit to 16 by borrowing buffers from one of the other FC ports. If I did not change the B2B credits then the fabric kept on reconfiguring itself, something else that I haven't seen documented? So now when plug in the qlogic adapter into either 5428's I get the message I've refered to and the fabric keeps on reconfiguring the topology. So have I answered enough of your questions to be able to get a copy of the white paper ?

Cisco Employee

Re: 5428-2 , brocade switches and ql2200 with fcip

Larry, There is not a interoperability white paper for 5428 to brocade that I know of.

I don't think it a matter of fault but just how to config for interoperability. Do you have the brocade set for interoperability mode or for native in the switchshow command?

New Member

Re: 5428-2 , brocade switches and ql2200 with fcip

Hello tblancha, Yes I have the Brocades set for interop mode. How would I be able to see the 5428's if it wasn't ? I'll disconnect the 5428's from the Brocades and connect the ql200 directly to the 5428 and see what happens. Is there any information about correctly setting up the ql200 ?

New Member

Re: 5428-2 , brocade switches and ql2200 with fcip

Oppsss...i meant the qlogic ql2200 adapters.

Regarding interoperabiliy, here's a referance to the White Paper in this discussion group:

Oct 17, 2002

Subject: SN5428 and Silkworm 2800

By: aseppala

Discussion:

.....Source: "SN5428 Interoperability Whitepaper, for internal use only...)

I've tried disconnecting the 5428 from our fibre and only connecting the ql2200 adapter to a fc port in a 5428. I still get the same message.

Cisco Employee

Re: 5428-2 , brocade switches and ql2200 with fcip

Larry,

One more thing before we open up a TAC case on this.

Ensure the principal switch is allowing the PWWN's that you want to pass data. Then verify the storage can be seen in the brocade and the qlogic hba is in the nameserver in the 5428. Then in the 5428, use the show fcswitch global-nameserver all to see if the storage can be seen. This command shows all of the devices in the entire fabric whereas show fcswitch nameserver only shows locally attached devices. Likewise, on the brocade, nsAllShow, shows all of the devices in the fabric and nsShow only shows locally attached devices

New Member

Re: 5428-2 , brocade switches and ql2200 with fcip

I'm trying the vary basics. I disconnected the GE ports from each 5428. I cleared the configuration on one of the 5428's with the "clear conf" command. I then setup the basic information and did a "setup". I plug the fibre cable from the ql2200 into fibre channel port 1. Here's what I get when I run the nameserver command:

[sm542802]# show fcswitch nameserver all

0 entries found

[sm542802]#

So my problem is that the qlogic adapter is just not seen by the 5428 when I use the default settings.

If I set the 5428 fc1 port to 1Gb/sec, then I get the following messages...

Mar 15 17:14:22: %FC-5-PortOperChange: PortOperChange;670;0;0;1

Mar 15 17:14:24: %FC-5-PortOperChange: PortOperChange;671;0;0;1

Mar 15 17:14:26: %FC-5-PortOperChange: PortOperChange;672;0;0;1

Mar 15 17:14:28: %FC-5-PortOperChange: PortOperChange;673;0;0;1

Mar 15 17:14:30: %FC-5-PortOperChange: PortOperChange;674;0;0;1

Mar 15 17:14:32: %FC-5-PortOperChange: PortOperChange;675;0;0;1

Mar 15 17:14:34: %FC-5-PortOperChange: PortOperChange;676;0;0;1

Mar 15 17:14:36: %FC-5-PortOperChange: PortOperChange;677;0;0;1

Mar 15 17:14:45: %FC-5-PortOperChange: PortOperChange;678;0;0;1

Cisco Employee

Re: 5428-2 , brocade switches and ql2200 with fcip

Ok, I had taken one of your previous posts to indicate that you were seeing the HBA in the local nameserver of the 5428.

So, what is the OS. Is there messages in the log of the OS as it appears that the HBA is attempting to login to the fabric but is trying to do loop while the port is configured to be F port.

Is it possible for you to open a TAC case on this and we'll dig into it more? Would you perhaps have a finisar to look at the login process?

New Member

Re: 5428-2 , brocade switches and ql2200 with fcip

I'm using Windows 2000 Server. I was able to make some progress. I connected another Brocade FC switch, call it switch 1, to the 5428 and then connected the ql2200 to the FC switch and I'm now able to see the ql2200 adapter. I then created a fcip link between the 5428's and connected the second 5428 to the fabric. I can see the 5428's and the first fc switch from the topology. The name server now shows the ql2200 adapter on switch 1. Is the storage router supposed to support a direct connection from an adapter or storage without a FC switch ? I don't have a finisar. How would I open a TAC case ?

334
Views
0
Helpful
9
Replies
CreatePlease to create content