Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

FM 4.2 installation issue.

While trying to install the FM 4.2, on Windows, with the express option, at the database options screen it gives me a message as, 'There is already an instance of PostgreSQL installed on your system. Please go back and proceed with the existing database', if I say 'ok', to this and go back to do a custom install and say use existing database with Postgresql selected, it says, 'Unable to connect to the database. Please go back and check your settings. Cannot connect to jdbc:postgresql://localhost:5432/dcmdb with admin.'. Thus I am unable to install it, looks like I had a incomplete install earlier. Now I tried removing postgresql by deleting the folders from the c:/program files as I was not getting any option to uninstall it, but the error still comes looks like the Postgre isn't getting uninstalled. How do I get rid of this postgresql and then do a complete install of FM?

5 REPLIES
Silver

Re: FM 4.2 installation issue.

do you see any PostgreSQL services still listed in "Services" mmc ?

@dynamoxxx
Community Member

Re: FM 4.2 installation issue.

Hi Dynamoxxx,

Yes, the PostgreSQL Database Server 8.2 was listed under services. I tried starting it but it says that the path could not be found (as I deleted the folders earlier). So I deleted this service through the registry and rebooted, now that the service is not listed, I tried installing FM. This time it did past the last point and tried installing the files for a while, however it again gave an error :

'This application failed to start because libpq.dll was not found. Re-installing the application may fix the issue.'

I say ok to the message and then one more pop up comes:

Cisco Fabric Manager Installer 4.2(5) has encountered a problem and must quit.

For further assistance, please contact customer support.

Cause: Failed to start PostgreSQL. A security software agent may be blocking PostgreSQL from installing.

saying OK to this quits the installation, tried another time as the first message asked, but still the same set of messages come and keep coming in the next tries.

Thanks.

Community Member

Re: FM 4.2 installation issue.

I had this problem, it's to do with the path to the Database. When you do the install for PostgreSQL I had to change the path as it didn't exist.

Silver

Re: FM 4.2 installation issue.

probably more clean up is needed on the windows drive itself. See if there is a directory for PostgreSQL and delete it as well as any remains of FM server.

@dynamoxxx
Community Member

FM 4.2 installation issue.

Validate this folder is empty:

c:\program files\postgresql\8.2\data

You can try this install method:

You can run the install and then let it fail.

verify this folder is deleted:

c:\program files\postgresql\8.2\data

verify that these files are not in your path, if so, rename them .old

libeay32.dll

ssleay32.dll

Modify the install.bat batch file in:

c:\documents and settings\\.cisco_mds9000\postgres-win

change the servicepassword to meet your password complexity requirements, ie, Password1234!

add double quotes around the installdir variable

run the install.bat from the command prompt

when prompted for the dcmdb password type: andiamo_4_5_6

run upgrade.bat from the command prompt (same folder)

Re-run the Cisco Fabric Manager for Windows install

select use existing postgres

admin: andiamo

password: andiamo_4_5_6

2215
Views
5
Helpful
5
Replies
CreatePlease to create content