Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

in desperate need of config assistance for 6513 trunking to Netapp controller

We are building a new SAN using a Netapp Fas3160 with 2 controllers in failover mode. We have 1 6513 switch they will connect to for the etherchannels. Each Netapp controller will need an LACP port channel with 4 gig interfaces in each running to the 6513.  I have tried to set up the port channels on the 6513 by adding the interfaces into them with the following port config.  The channel comes up fine, but routing to the netapp fails immediately after bringing up the trunk, and the port channel will eventually show down/down but the individual interfaces stay up/up.  I have tried creating the trunks using the mode "on" command also and it will not stay up either.I am at a loss as to why the channels quit routing and eventually go down.

partial cisco config

interface Port-channel10
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
spanning-tree guard loop

interface GigabitEthernet1/29
description NetApp
switchport
switchport access vlan 34
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
spanning-tree guard loop
channel-protocol lacp
channel-group 10 mode active

Anyone with any experience of this type, please help.  This should not be that hard, but the Netapp doco has conflicting info for modes, etc.  I can provide more detail if someone needs it.

2 REPLIES
New Member

Re: in desperate need of config assistance for 6513 trunking to

Why the access vlan 34?  If it's a native trunk or such, please describe, otherwise, remove.  Also, the netapp probably negotiates, the material I could find, showed it as such.  I don't believe you should need the channel-protocol lacp, as channel-group active means essentially lacp. Put it back in if this doesn't work. I would try this:

interface Port-channel10
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast trunk

interface GigabitEthernet1/29
description NetApp
switchport
switchport mode trunk
spanning-tree portfast trunk
channel-group 10 mode active

If it really accesses multiple vlans, then great.  I would add a "switchport trunk allowed vlan 1,34" (as appropriate) to limit extraneous traffic.

You will also likely need to add or verify this:
port-channel load-balance src-dst-mac

New Member

Re: in desperate need of config assistance for 6513 trunking to

Hi, here is my config for my trunk from a Cisco 4507R switch trunking to a NetApp FAS2050:

interface GigabitEthernet5/14
description NetApp Controller
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 22 mode active
end

UK-LON-SW01#sh run int gi6/14
Building configuration...

Current configuration : 183 bytes
!
interface GigabitEthernet6/14
description NetApp Controller
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 22 mode active
end

UK-LON-SW01#sh run int po22
Building configuration...

Current configuration : 149 bytes
!
interface Port-channel22
description NetApp
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate

My initial troubles in getting the port-channel to come up were related to the config SAN admin did on the netapp controller, the cisco config is pretty basic/straightforward.

hope that helps.

Ashar.

1489
Views
0
Helpful
2
Replies