Cisco Support Community
Community Member

MDS 9124 Not Switching


I have just got a MDS 9124 swith to replace an old Capellix Gadzoox 3000 unit.

Basically, I have just removed the Gadzoox and added the Cisco switch in its place.

There are only 8 ports used. 3 x HBAs, 4 x Tape Drives and 1 x JBOD.

The problem that I have is that when everything is connected together through the switch nothing seems to talk to each other. I can FCPING each of the divices individually from the switch.

Now all the 8 ports are in VSAN 1 and I have set the default-zone to permit too but still no success.

Put the Gadzoox back in circuit, it all works but nothing with the Cisco.

Any ideas?

Fibre channel is definitely a different beast to Ethernet!

Community Member

Re: MDS 9124 Not Switching

As I don't know what you have done and what experience you have with SAN switches.....

I suggest that you don't use VSAN0001 as a production VSAN for any number of reasons. I don't recall ever seeing a zoneset in VSAN001 by default.

I am assuming that you are using the stock standard zoning of using WWN. So have you created a zone that includes the WWN's for these devices and then created an active zoneset for the zone?

Thats about the only simple reason I can think of that it would not be working. I know it is SAN switch 101 but as I don't have a clue what a Gadzoox is, I have to ask...


Community Member

Re: MDS 9124 Not Switching

My Fibre Channel/SAN experience was nil until a few weeks ago. However, I have planty of experience on Cisco Ethernet routers and switches etc.

I'm sure I read somwehere that these switches are "so easy to set-up and training is not required"....yeah, right!

Well, we did create a new VSAN (10) and moved the 8 ports into the new VSAN. Created a zone and added all the 8 ports using their FCid's. Then created a zoneset and added the zone into the zonest and activated the zoneset.

It is my understanding that this should have worked BUT this was done by a 3rd party at the end of last week and they said that it didn't.

The other thing they tried was to leave the 8 ports in VSAN 1 and did a "default-zone permit" which should have opened up the 8 ports to each other. Tis did not work either.

I hope that explains things a little further.

Community Member

Re: MDS 9124 Not Switching

If you have IOS experience you will find SAN-OS relatively easy. Have a look at the following URL. Its not exactly the right version but it will help.

Do something like:

show int brief - to get the interfaces that are working.

show zoneset active - to look at the active zoneset.

show zone vsan 10 - to see what is in the vsan 10.

show flogi database vsan 10 - to see what has logged into the fabric for vsan 10.

Basically, if you can see the interfaces and they are up and the interfaces are in a zone in an active zoneset, thats all you really need --- unless all the stuff you has does not understand fabrics which is probably unlikely.

Also, check out some of the debug options.

There is nothing simple about SAN-OS but it can be easy to setup quickly.


CreatePlease to create content