Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

MDS 9124 Setting up a zone

Hi,

This is my first setup of an MDS zone and I can't figure out what I'm doing wrong here. Here is my config that matters:

device-alias database

  device-alias name TESTST01-B pwwn 20:15:00:a0:b8:11:39:de

  device-alias name TESTSVR01-A pwwn 21:00:00:1b:32:9b:35:8f

device-alias commit

fcdomain fcid database

  vsan 1 wwn 20:15:00:a0:b8:11:39:de fcid 0x5b0000 dynamic

!            [TESTST01-B]

  vsan 1 wwn 21:00:00:1b:32:9b:35:8f fcid 0x5b0100 dynamic

!            [TESTSVR01-A]

zone name TESTSVR01-001 vsan 1

    member pwwn 20:15:00:a0:b8:11:39:de

!               [TESTST01-B]

    member pwwn 21:00:00:1b:32:9b:35:8f

!               [TESTSVR01-A]

zoneset name FABRIC-B vsan 1

    member TESTSVR01-001

zoneset activate name FABRIC-B vsan 1

The PWWN's listed in the device-alias database are the ones that connect to each other when I connect the server HBA directly to the storage device. Here are also some show commands:

-----

sh flogi database

--------------------------------------------------------------------------------

INTERFACE        VSAN    FCID           PORT NAME               NODE NAME     

--------------------------------------------------------------------------------

fc1/2            1     0x5b0000  20:15:00:a0:b8:11:39:de 20:04:00:a0:b8:11:39:de

                           [TESTST01-B]

fc1/3            1     0x5b0100  21:00:00:1b:32:9b:35:8f 20:00:00:1b:32:9b:35:8f

                           [TESTSVR01-A]

-----

sh vsan

vsan 1 information

         name:VSAN0001  state:active

         interoperability mode:default

         loadbalancing:src-id/dst-id/oxid

         operational state:up

vsan 4079:evfp_isolated_vsan

vsan 4094:isolated_vsan

-----

sh zoneset active

zoneset name FABRIC-B vsan 1

  zone name TESTSVR01-001 vsan 1

  * fcid 0x5b0000 [pwwn 20:15:00:a0:b8:11:39:de] [TESTST01-B]

  * fcid 0x5b0100 [pwwn 21:00:00:1b:32:9b:35:8f] [TESTSVR01-A]

-----

show zone status

VSAN: 1 default-zone: deny distribute: full Interop: default

    mode: basic merge-control: allow

    session: none

    hard-zoning: enabled broadcast: unsupported

Default zone:

    qos: none broadcast: unsupported ronly: disabled

Full Zoning Database :

    DB size: 128 bytes

    Zonesets:1  Zones:1 Aliases: 0

Active Zoning Database :

    DB size: 68 bytes

    Name: FABRIC-B  Zonesets:1  Zones:1

Status: Activation completed at 18:04:21 PDT Sep  8 2010

-----

sh zoneset active

zoneset name FABRIC-B vsan 1

  zone name TESTSVR01-001 vsan 1

  * fcid 0x5b0000 [pwwn 20:15:00:a0:b8:11:39:de] [TESTST01-B]

  * fcid 0x5b0100 [pwwn 21:00:00:1b:32:9b:35:8f] [TESTSVR01-A]

Hope anyone can tell me what I'm doing wrong here...
9 REPLIES
New Member

Re: MDS 9124 Setting up a zone

Peter,

Can you tell us what symptoms you see or what makes you think there is anything wrong in the first place?

You have successfully created a zone and activated a zoneset.  The MDS indicates that both members of the zone are online and can see eachother.  I don't see any issues why these two devices would be having a problem.

New Member

Re: MDS 9124 Setting up a zone

Thanks for clearing out that the config should work. When I connect server and storage directly I see the PWWN of the storage pop up in the qlogic bios and I can connect to the assigned lun. When I use the MDS with the config listed above I don't see the storage PWWN or the lun. Something tells me that I should see the same behaviour when I have the switch in the middle as when I connect the server and storage directly.

Silver

Re: MDS 9124 Setting up a zone

Peter,

on some vendor arrays you have to set correct topology on the ports that connect into your fabric. For example on HP MSA i can set "point to point" which is only design for direct "server to storage" connection with no fiber switch involved. You also have arbitrated loop (used only when connected to a hub), another topology is "switched", this is where both initiator (server) and target (array) connect to a fiber switch and you zone them together. Not sure if that's your sure but something to verify.

@dynamoxxx
New Member

Re: MDS 9124 Setting up a zone

I've checked the settings on the HBA (it's a qlogic) and there is no such thing as a "Server to storage" setting.

I figured something else out:

FCSW# fcping pwwn 20:15:00:a0:b8:11:39:de vs 1

28 bytes from 20:15:00:a0:b8:11:39:de time = 2709 usec

28 bytes from 20:15:00:a0:b8:11:39:de time = 759 usec

28 bytes from 20:15:00:a0:b8:11:39:de time = 757 usec

28 bytes from 20:15:00:a0:b8:11:39:de time = 755 usec

28 bytes from 20:15:00:a0:b8:11:39:de time = 757 usec

5 frames sent, 5 frames received, 0 timeouts

Round-trip min/avg/max = 755/1147/2709 usec

FCSW# fcping pwwn 21:00:00:1b:32:9b:35:8f vs 1

28 bytes from 21:00:00:1b:32:9b:35:8f time = 771 usec

28 bytes from 21:00:00:1b:32:9b:35:8f time = 764 usec

28 bytes from 21:00:00:1b:32:9b:35:8f time = 763 usec

28 bytes from 21:00:00:1b:32:9b:35:8f time = 762 usec

28 bytes from 21:00:00:1b:32:9b:35:8f time = 765 usec

This indicates that I can reach both ends. So if you see it like A-B-C then I can get from B to A and from B to C but I can't connect from A to C.
Frustrating but it is improving my FC skills :-)
Any more thoughts?

New Member

Re: MDS 9124 Setting up a zone

You should be able to set an option in the HBA for Point to Point or Loop Preferred.  Check the Wizards tab, general configuration wizard in san surfer

New Member

Re: MDS 9124 Setting up a zone

I found the option "Loop only/Point to point/Loop only preferred". Tried all of them but still no connection. Next up I will try to get access to the storage device to see how that's configured. Any other ideas? I'm guessing it's something simple that I'm not seeing...

New Member

Re: MDS 9124 Setting up a zone

So your saying in SANsurfer you don't see the storage pwwn?  In the window on the left you can click on each hba port and expand what it sees.

New Member

Re: MDS 9124 Setting up a zone

I can't use SANsurfer since I'm booting from SAN. I have no OS to install it on. All I have is the BIOS which is telling me that there is no storage device attached.

New Member

Re: MDS 9124 Setting up a zone

In the SAN boot section in the HBA Bios (not 100% sure where it is atm and i can't check) can you see any target ports at all?

1475
Views
0
Helpful
9
Replies