Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Nexus 4000 fcoe & ethernet connectivity

Hi!

I have a question about the Nexus 4000. We currently have a Nexus 4000 connected to a Nexus 5000 connect to a 6500 Switch.

We have VLAN 115 for Ethernet & Vlan 1115 for Fcoe.

The FCOE part of the configuration is working, it is doing a fabric login to the 5K by FIP Snooping.

We are having trouble with the Ethernet component, we can't seem to get a response. The vlans are allowed end to end but all mac addresses on the port are visible in VLAN 1115.

How do we get the Ethernet part of the CNA working? The Nexus 4000 does not seem to learn the Ethernet MAC from the CNA.

Thanks

Brad

7 REPLIES
New Member

Re: Nexus 4000 fcoe & ethernet connectivity

How is the port on the 4k defined?

Which CNA card are you using?

Which OS is the server running?

New Member

Re: Nexus 4000 fcoe & ethernet connectivity

Hi,

Port on the 4k -

interface Ethernet1/5
  switchport mode trunk
  switchport trunk allowed vlan 1,115,1115
  spanning-tree port type edge
  speed auto

CNA used -Qlogic....the 4 k is part of the IBM Blade Chassis

OS on 4K - n4000-bk9.4.1.2.E1.1b.bin

We also modifed the native vlan to VLAN 115 which the MAC appeared in VLAN 115 but still no connectivity. From the looks of things, the ethernet part takes the native vlan, now is this probably because the server is sending an untagged packet, as it may not be setup to do dot1q trunking.

New Member

Re: Nexus 4000 fcoe & ethernet connectivity

Do you have other blades that are working on this chassis?  It could be a driver issue or a misconfigure on the blade itself that is causing the issue.  How is connectivity being tested?

New Member

Re: Nexus 4000 fcoe & ethernet connectivity

We have tried two blades with no sucess.

We have assigned an IP Address to the ethernet ports and cannot ping them.

We have IP connectivity to the 5K, anything beyond that on the 4K is unreachable.

New Member

Re: Nexus 4000 fcoe & ethernet connectivity

On the blades themself, can you ping the IP that you have assigned them?

If so, what about the default gateway?

Are you statically assigning an IP?

Verify on the blade OS that the interface is up and the IP is assigned.

New Member

Re: Nexus 4000 fcoe & ethernet connectivity

We have got Cisco TAC involved now. Seems the Nexus 4000 with a static IP and a Nexus 5000 with a static IP can't ping each other ov

er a trunk link....very wierd issue....mac addresses seen in correct VLAN but no ping.

New Member

Re: Nexus 4000 fcoe & ethernet connectivity

Hi,

i understand that you succeeded with FCoE between N4K & N5K.

can you please send me the configuration ?, the ETH vlan is up but i cannot see the MAC for the FCoE vlan under show fip-snooping vlan discovery.

many thanks,

Avi.

1084
Views
0
Helpful
7
Replies