Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Nexus 548UP and 1Gb FC

Hi Ihave a Nexus 5548UP running 7.0(1) and I am having an issue getting a 1Gb FC link to come up. I have a Quantum Library and it currently connect to a Q Logic FC Switch without issues. I want to move this SAN to a nexus and testing the 1Gb FC link on a port in the Nexus that is configured as FC and using the transiever model DS-SFP-FC4G-SW. The port does not come up even though the transiever is recognised. Your help would be appreciated.

The show int capabilities and show int transciever are below;

nmc-st-nxs2# sh int fc1/28 capabilities

fc1/28

fc1/28

Min Speed is 1 Gbps

Max Speed is 8 Gbps

FC-PH Version (high, low)                         (2,1)

Receive data field size (max/min)                 (2112/2112) bytes

Transmit data field size (max/min)                (2112/256) bytes

Classes of Service supported are                  Class 3, Class F

Class 3 sequential delivery                       supported

Hold time (max/min)                               (10000/1) micro sec

BB state change notification                      not supported

Rate Mode change                                  not supported

 

Rate Mode Capabilities                            Dedicated

  Receive BB Credit modification supported         yes

  FX mode Receive BB Credit (min/max/default)      (1/240/16)

  ISL mode Receive BB Credit (min/max/default)     (1/240/16)

  Performance buffer modification supported         no

  FX mode Performance buffers (min/max/default)    --

  ISL mode Performance buffers (min/max/default)   --

 

Out of Service capable                             yes

Beacon mode configurable                            no

nmc-st-nxs2#

 

 

nmc-st-nxs2# sh int fc1/28 transceiver

fc1/28 sfp is present

    Name is CISCO-FINISAR

    Manufacturer's part number is FTLF8524P2BNL-C2

    Revision is D

    Serial number is FNS14351AM6

    Cisco part number is

    FC Transmitter type is short wave laser w/o OFC (SN)

    FC Transmitter supports intermediate distance link length

    Transmission medium is multimode laser with 62.5 um aperture (M6)

    Supported speeds are - Min speed: 1000 Mb/s, Max speed: 4000 Mb/s

    Nominal bit rate is 4300 Mb/s

    Link length supported for 50/125mm fiber is 150 m

    Link length supported for 62.5/125mm fiber is 70 m

    Cisco extended id is unknown (0x0)

 

    No tx fault, rx loss, no sync exists, diagnostic monitoring type is 0x68

Invalid calibration

nmc-st-nxs2#

Regards,

Dom.

3 REPLIES
VIP Green

Show interface counters ?Any

Show interface counters ?

Any entries in the error / syslog ?

Is the port F-Port ? or is the peer expecting a loop port ?

Maybe set the port speed fix to 1G

 

 

New Member

I have tried all port modes

I have tried all port modes and speeds.

 

I have not tried to set the speed to 1G beforehand, only during and this made no difference.

 

Counters:

fc1/28

    1 minute input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec

    1 minute output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec

    171 frames input, 12084 bytes

    171 frames input, 12084 bytes

      0 class-2 frames, 0 bytes

      171 class-3 frames, 12084 bytes

      0 class-f frames, 0 bytes

      0 discards, 0 errors, 0 CRC

      0 unknown class, 0 too long, 0 too short

    171 frames output, 10192 bytes

      0 class-2 frames, 0 bytes

      171 class-3 frames, 10192 bytes

      0 class-f frames, 0 bytes

      0 discards, 0 errors

    0 input OLS, 0 LRR, 0 NOS, 0 loop inits

    178 output OLS, 10 LRR, 97 NOS, 0 loop inits

    10 link failures, 22 sync losses, 0 signal losses

     0 transmit B2B credit transitions from zero

     0 receive B2B credit transitions from zero

      16 receive B2B credit remaining

      0 transmit B2B credit remaining

      0 low priority transmit B2B credit remaining

VIP Green

Can you please check what the

Can you please check what the port type is on the Qlogic FC switch, where everything is running ok.

As has been discussed in another thread, some tape library require a loop port, NL-Port; and the Nexus 55xx doesn't this type of FC port.

The fix is to set the tape library port to N (not NL).

88
Views
0
Helpful
3
Replies
CreatePlease to create content