Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SNMP or MDS 9222i stopped working


Got two MDS 9222i switches and by some act of crazyness both have stopped responding to SNMP request. As such our monitoring tools cannot get to them. Worse still the fabric manager cannot manage them and I cannot connect to them via ssh1 or ssh2 or telnet.

I've removed ssh and snmp setting and readded. Switch will work for around 30 seconds then drops connection and when you try reconnect it times out.

commands removed and added

no telnet server enable

ssh key rsa1 1024 force

ssh server enable

snmp-server contact ******

snmp-server location ******

snmp-server community ******group network-operator

snmp-server community ****** group network-admin

snmp-server community ****** group network-admin

snmp-server user admin network-admin auth md5 0xa36756487c540124176681454b62af3f priv 0xa36756487c540124176681454b62af3f localizedkey

I've removed the names and replaced with ******, also have run no commands to remove then readded.

Like I said once the settings are there will work for 30seconds or so then crap out.

Running version 3.3(1a)

Any insight would be greatly appreciated, will be upgrading kickstart and version to 4.1.1c this weekend but wanted to find the issue at hand first.


Cisco Employee

Re: SNMP or MDS 9222i stopped working

Have you tried attaching directly to the MDS with an ethernet crossover cable and see if you get the same results?

Something in the network between your SNMP work station and the MDS mgmt interface may be blocking or dropping packets on you.

If it fails the same way with a crossover, we need to dig deeper into the MDS.

Hope this helps,


New Member

Re: SNMP or MDS 9222i stopped working

Crossover cable works fine and ACS authenticates OK

If I remove snmp and ssh and re-add it will work for 30 seconds then bomb out. Same goes for telnet will work for 30 seconds then crap out.

Management interfaces are on our management vlan which all 6500's and 3750's are on. All other switches are working fine for connectivity and snmp.

Also can still ping management interface of the MDS's fine.

Cisco Employee

Re: SNMP or MDS 9222i stopped working

So you have the same symptom of SSH and FM not working with a crossover cable? Not sure how ACS would work if you had a cross over cable in place to your PC because the ACS server would not be reachable from the MDS. It should drop to local auth and use the local user database.

Can you try to ping the MDS mgmt IP address with the cable not connected? Just to verify there is no duplicate IP address on the network? Set up a continuous ping and let it run for over a minute if all looks good. At the 1 minute mark, unplug the mgmt 0 cable and verify that the pings now timeout.

I can not think of anything internally that would affect both SSH and SNMP from working. They are totally different process. You mentioned it is a 9222i, so there is no chance that they sups are crashing and you are hitting a sup roll over to cause the disconnect.

You may want to attach a local console (PC with hypertem or Teraterm) to the console port on the MDS and monitor the event logs. Perhaps there is some event occurring that might explain the odd behavior.

If you do attach the local console, you may want to collect a 'show tech support' in case this needs to be worked by TAC.