Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

Solaris "hanging" issue

We have Sun boxes running on Solaris 8 - 10 and they all experience an issue when running "cfgadm -al" listing all system controllers, and what's attached to them.

We have tried connecting a native fibre drive directly to the severs HBA and we get an instant response. Once we connect it through the SAN it has been known to take 10 - 30 mins.

We currently have a SUN Vsan and a Library Vsan and IVR the devices together. For a test we tired just zoning within the same Vsan but still the same issue.

Has anyone noticed this issue.

SAN OS level = 3.1.3

Many thanks.

2 REPLIES
New Member

Re: Solaris "hanging" issue

I have spent years managing lots of Solaris boxes on SANs and only once saw that behaviour and it was not SAN related. I had problems with ODM and once that was patched, cfgadm -al worked perfectly. I trussed the cfgadm command and saw it hanging on /dev/odm.

Perhaps you could truss cfgadm -al and see where it is hanging?

Do you have your storage and backup devices on the same controllers? If not and you know the controller numbers, say C4 and C5 for storage and C6 for tape, can you do a cfgadm -al C4 (etc) and do any of them return without hanging?

If it hangs on some controllers, that gives something to work with.

I just don't think the SAN and especially IVR is the issue.

Stephen

New Member

Re: Solaris "hanging" issue

Cheers Stephen, I will dig a bit deeper.

233
Views
4
Helpful
2
Replies
CreatePlease to create content