Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

unify Fc interface on 5548UP down

hello,

I try to configure FC on a cisco 5548. I change last interface on the switch in native FC with SFP FC 8G SW an LW. We manage a new vlan associate with a vsan 806

Interface are down with error npmExtLinkDown and I can't find any information about this status.

---------------

`show interface brief`

-------------------------------------------------------------------------------

Interface  Vsan   Admin  Admin   Status          SFP    Oper  Oper   Port

                  Mode   Trunk                          Mode  Speed  Channel

                         Mode                                 (Gbps)

-------------------------------------------------------------------------------

fc1/23     1      F      off     sfpAbsent        --     --           --

fc1/24     1      F      off     sfpAbsent        --     --           --

fc1/25     1      F      off     sfpAbsent        --     --           --

fc1/26     1      F      off     sfpAbsent        --     --           --

fc1/27     806    F      off     npmExtLinkDown   swl    --           --

fc1/28     806    F      off     npmExtLinkDown   swl    --           --

fc1/29     806    F      off     sfpAbsent        --     --           --

fc1/30     806    NP     off     notConnected     lwcr   --           --

fc1/31     806    F      off     sfpAbsent        --     --           --

fc1/32     806    F      off     sfpAbsent        --     --           --

--------------------------------------------------------------------------------

Ethernet      VLAN    Type Mode   Status  Reason                   Speed     Port

Interface                                                                    Ch #

--------------------------------------------------------------------------------

Eth1/1        1       eth  trunk  up      none                        10G(D) 100

Eth1/2        1       eth  trunk  down    SFP not inserted            10G(D) 100

Eth1/3        1       eth  trunk  up      none                        10G(D) --

Eth1/4        1       eth  trunk  down    SFP not inserted            10G(D) --

Eth1/5        1       eth  access down    SFP not inserted            10G(D) --

Eth1/6        1       eth  access down    SFP not inserted            10G(D) --

Eth1/7        1       eth  access down    SFP not inserted            10G(D) --

Eth1/8        1       eth  access down    SFP not inserted            10G(D) --

Eth1/9        1       eth  access down    SFP not inserted            10G(D) --

Eth1/10       1       eth  access down    SFP not inserted            10G(D) --

Eth1/11       1       eth  access down    SFP not inserted            10G(D) --

Eth1/12       1       eth  access down    SFP not inserted            10G(D) --

Eth1/13       1       eth  access down    Link not connected          10G(D) --

Eth1/14       1       eth  access down    Link not connected          10G(D) --

Eth1/15       1       eth  access down    SFP not inserted            10G(D) --

Eth1/16       1       eth  access up      none                        10G(D) --

Eth1/17       1       eth  access down    SFP not inserted            10G(D) --

Eth1/18       1       eth  access down    SFP not inserted            10G(D) --

Eth1/19       1       eth  trunk  up      none                        10G(D) --

Eth1/20       1       eth  access down    SFP not inserted            10G(D) --

Eth1/21       1       eth  access down    SFP not inserted            10G(D) --

Eth1/22       1       eth  access down    SFP not inserted            10G(D) --

-------------

also my vsan is down

`show vsan`

vsan 1 information

name:VSAN0001  state:active

interoperability mode:default

loadbalancing:src-id/dst-id/oxid 

operational state:down

vsan 806 information

name:VSAN0806  state:active

interoperability mode:default

loadbalancing:src-id/dst-id/oxid 

operational state:down

vsan 4079:evfp_isolated_vsan

vsan 4094:isolated_vsan

`show vsan membership`

vsan 1 interfaces:

    fc1/23            fc1/24            fc1/25            fc1/26          

vsan 806 interfaces:

    fc1/27            fc1/28            fc1/29            fc1/30          

    fc1/31            fc1/32          

vsan 4079(evfp_isolated_vsan) interfaces:

vsan 4094(isolated_vsan) interfaces:

-------------

here is my config file

`show running-config`

!Command: show running-config

!Time: Sun Mar  8 22:41:32 2009

version 6.0(2)N2(1)

feature fcoe

hostname SW5548UP-CL1-R-1

feature telnet

cfs ipv4 distribute

cfs eth distribute

feature interface-vlan

feature lacp

feature vpc

feature lldp

username admin password 5 /*******************/ role network-admin

no password strength-check

ip domain-lookup

system qos

  service-policy type queuing input fcoe-default-in-policy

  service-policy type queuing output fcoe-default-out-policy

  service-policy type qos input fcoe-default-in-policy

  service-policy type network-qos fcoe-default-nq-policy

control-plane

  service-policy input copp-system-policy-customized

slot 1

  port 23-32 type fc

vrf context management

vlan 1

vlan 806

  fcoe vsan 806

  name FCoE-Bas

vpc domain 1

  peer-keepalive destination 10.*.*.*

port-profile default max-ports 512

vsan database

  vsan 806

interface Vlan1

interface Vlan888

  description interface management inband

  no shutdown

  ip address 10.222.50.242/24

interface port-channel100

  switchport mode trunk

  switchport trunk allowed vlan 1-804,807-4094

  spanning-tree port type network

  speed 10000

  vpc peer-link

vsan database

  vsan 806 interface fc1/27

  vsan 806 interface fc1/28

  vsan 806 interface fc1/29

  vsan 806 interface fc1/30

  vsan 806 interface fc1/31

  vsan 806 interface fc1/32

feature npv

interface fc1/23

interface fc1/24

interface fc1/25

interface fc1/26

interface fc1/27

  no shutdown

interface fc1/28

  no shutdown

interface fc1/29

interface fc1/30

  switchport description vers SW5548UP-CA3-R-1 Fc1/30 lien fc01

  no shutdown

interface fc1/31

  switchport description vers metro nseries FC

interface fc1/32

  switchport description vers ESX-DMZB

interface Ethernet1/1

  description vers vers SW5548UP-CL1-R-2 Et1/1

  switchport mode trunk

  switchport trunk allowed vlan 1-804,807-4094

  channel-group 100 mode active

interface Ethernet1/2

  description vers vers SW5548UP-CL1-R-2 Et1/2

  switchport mode trunk

  switchport trunk allowed vlan 1-804,807-4094

  channel-group 100 mode active

interface Ethernet1/3

  description vers SW3750X-CL1-R-1 Te1/0/2

  switchport mode trunk

  switchport trunk allowed vlan 888

interface Ethernet1/4

  description vers RTR3800X-CL1-R-1 Ten0/1

  switchport mode trunk

  switchport trunk allowed vlan 6-8,10,12-17,100,150,160-166,200-203,230,450,700-704,710,888

interface Ethernet1/5

interface Ethernet1/6

interface Ethernet1/7

interface Ethernet1/8

interface Ethernet1/9

interface Ethernet1/10

interface Ethernet1/11

interface Ethernet1/12

interface Ethernet1/13

  description vers SW4001I-CL1-DC-1 chemin bas

interface Ethernet1/14

  description vers SW4001I-CL1-DC-1 chemin bas

interface Ethernet1/15

interface Ethernet1/16

  description vers metro nseries

interface Ethernet1/17

interface Ethernet1/18

interface Ethernet1/19

  description vers SW5548UP-CA3-R-1 Et1/19

  switchport mode trunk

  switchport trunk allowed vlan 6-8,10,12-17,100,150,160-166,200-203,206,230

interface Ethernet1/20

interface Ethernet1/21

interface Ethernet1/22

interface mgmt0

  vrf member management

  ip address 10.200.1.242/24

line console

line vty

boot kickstart bootflash:/n5000-uk9-kickstart.6.0.2.N2.1.bin

boot system bootflash:/n5000-uk9.6.0.2.N2.1.bin

ip route 0.0.0.0/0 10.222.50.254

interface fc1/27

  switchport speed 4000

interface fc1/23

  switchport mode F

interface fc1/24

  switchport mode F

interface fc1/25

  switchport mode F

interface fc1/26

  switchport mode F

interface fc1/27

  switchport mode F

interface fc1/28

  switchport mode F

interface fc1/29

  switchport mode F

interface fc1/30

  switchport mode NP

interface fc1/31

  switchport mode F

interface fc1/32

  switchport mode F

---------------------

how can i start vsan and my FC interface

I would like to do native FC with zonings zoneset, fcal, ... I can't use show flogi database, what feature do i missing ?

thank's a lot for your help.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

unify Fc interface on 5548UP down


Hi,

-------------------------------------------------------------------------------
Interface  Vsan   Admin  Admin   Status          SFP    Oper  Oper   Port
                  Mode   Trunk                          Mode  Speed  Channel
                         Mode                                 (Gbps)
-------------------------------------------------------------------------------
fc1/28     806    F      off     npmExtLinkDown   swl    --           --
fc1/29     806    F      off     sfpAbsent        --     --           --
fc1/30     806    NP     off     notConnected     lwcr   --    


Running config has
feature npv

In NPV mode, this switch cannot relay a flogi to the upstream NPIV switch unless the NP interface is up.
Do you intend to connect fc1/30 to an NPIV switch?

Options:
connect this switch to an NPIV enabled switch.
or
Take this switch out of NPV mode
   no feature npv
   copy run start
   reload

The flogi database will be on the NPIV switch,
you can use, "show npv flogi" on the NPV switch.


Regards,
David

5 REPLIES
Cisco Employee

unify Fc interface on 5548UP down


Hi,

-------------------------------------------------------------------------------
Interface  Vsan   Admin  Admin   Status          SFP    Oper  Oper   Port
                  Mode   Trunk                          Mode  Speed  Channel
                         Mode                                 (Gbps)
-------------------------------------------------------------------------------
fc1/28     806    F      off     npmExtLinkDown   swl    --           --
fc1/29     806    F      off     sfpAbsent        --     --           --
fc1/30     806    NP     off     notConnected     lwcr   --    


Running config has
feature npv

In NPV mode, this switch cannot relay a flogi to the upstream NPIV switch unless the NP interface is up.
Do you intend to connect fc1/30 to an NPIV switch?

Options:
connect this switch to an NPIV enabled switch.
or
Take this switch out of NPV mode
   no feature npv
   copy run start
   reload

The flogi database will be on the NPIV switch,
you can use, "show npv flogi" on the NPV switch.


Regards,
David

New Member

unify Fc interface on 5548UP down

Ok I have transform this configuration without NPV feature.

Interface came's up and I find my wwn on the flogi database to make zoning.

this nexus is interconnect to an another N5K where I also use Npiv. I think that I will transforme also it in "Full fabric" without npiv but for my education I have the following error :

the interface NP "uplink" is in init mode in other side interface is in up and F mode with a WWN

full fabric side

------------------------

`show interface brief`

-------------------------------------------------------------------------------

Interface  Vsan   Admin  Admin   Status          SFP    Oper  Oper   Port

                  Mode   Trunk                          Mode  Speed  Channel

                         Mode                                 (Gbps)

-------------------------------------------------------------------------------

fc1/23     1      F      on      sfpAbsent        --     --           --

fc1/24     1      F      on      sfpAbsent        --     --           --

fc1/25     1      F      on      sfpAbsent        --     --           --

fc1/26     1      F      on      sfpAbsent        --     --           --

fc1/27     806    F      on      up               swl    F       4    --

fc1/28     806    F      on      up               swl    F       4    --

fc1/29     806    F      on      sfpAbsent        --     --           --

fc1/30     806    F      on      up               lwcr   F       8    --

fc1/31     806    F      on      down             swl    --           --

fc1/32     806    F      on      down             swl    --           --

NPIV side

-----------------------

`show interface brief`

-------------------------------------------------------------------------------

Interface  Vsan   Admin  Admin   Status          SFP    Oper  Oper   Port

                  Mode   Trunk                          Mode  Speed  Channel

                         Mode                                 (Gbps)

-------------------------------------------------------------------------------

fc1/30     806    NP     off     init             lwcr   --           --

fc1/31     806    F      off     npmExtLinkDown   swl    --           --

fc1/32     806    F      off     npmExtLinkDown   swl    --           --

config from NPIV side

-----------------------------------

version 5.2(1)N1(3)

feature fcoe

logging level feature-mgr 0

hostname SW5548UP-CA3-R-1

feature telnet

cfs ipv4 distribute

feature interface-vlan

feature lldp

slot 1

  port 27-32 type fc

vlan 806

  fcoe vsan 806

  name FCoE-Bas

vsan database

  vsan 806

interface vfc8

  bind mac-address 00:c0:dd:21:82:43

  switchport description Emplacement 8 Blade 1 CAPS - THEMIS

  switchport trunk mode on

  no shutdown

interface vfc10

  bind interface Ethernet1/29

  switchport description temp dmz

  switchport trunk mode on

  no shutdown

interface vfc30

  switchport trunk mode on

interface vfc31

  switchport trunk mode on

interface vfc32

  switchport trunk mode on

interface vfc110

  bind mac-address 00:c0:dd:26:0c:8f

  switchport trunk mode on

  no shutdown

interface vfc112

  bind mac-address 00:c0:dd:21:82:b3

  switchport trunk mode on

  no shutdown

interface vfc113

  bind mac-address 00:c0:dd:21:81:6b

  switchport trunk mode on

  no shutdown

vsan database

  vsan 806 interface vfc8

  vsan 806 interface vfc10

  vsan 806 interface vfc110

  vsan 806 interface vfc112

  vsan 806 interface vfc113

  vsan 806 interface fc1/30

  vsan 806 interface fc1/31

  vsan 806 interface fc1/32

feature npv

feature npiv

npv traffic-map server-interface fc1/32 external-interface fc1/30

npv traffic-map server-interface vfc8 external-interface fc1/30

npv traffic-map server-interface vfc10 external-interface fc1/30

npv traffic-map server-interface vfc110 external-interface fc1/30

npv traffic-map server-interface vfc112 external-interface fc1/30

npv traffic-map server-interface vfc113 external-interface fc1/30

interface fc1/30

  switchport description vers int 15 brocade bas

  no shutdown

interface fc1/31

  switchport description vers Metrocluster FC

  no shutdown

interface fc1/32

  switchport description SERVEUR DMZ

  no shutdown

*---------------------------------------------------------------*

Thank's a lot for your help

Cisco Employee

unify Fc interface on 5548UP down


IS this the topology?
NPV                         NPIV
N5K fc1/30 init - up fc1/30 N5K


Maybe the interfaces are flapping?
If you shut the interfaces on one end of the link, does the interface at the other of the link go down?
The fc1/30 descripiton says brocade.
Is there more information in both switches with the command,
  show interface fc1/30
   show logging log

Does the pwwn in the flogi database match the wwn in show interface on the NPV switch?


New Member

unify Fc interface on 5548UP down

We change our topology without Npiv or npv. "full fabric"

so this is our topology objective :

we have emplemented server on site x with blade and cisco 4005i with fip snooping. we created vfc on nexus 5K zoning. we have normal wwn on the flogi database and show zone active show fcid.

we make zoning to communicate with the DS4700 target on site y and with the n metro from site x. metro on site x and the ds4700 can't see any wwn initiator from the CNA interface and we can't see san target from the CNA bios gui.

a server with normal FC interface on fc1/32 work and can communicate with ds4700 and nserie without any issue has usual.

here is config from n4K

-------------

version 4.1(2)E1(1j)

feature telnet

feature tacacs+

feature fip-snooping

vlan 806

  fip-snooping enable

  fip-snooping fc-map 0x0efc00

  name FCoE-BAS

interface port-channel15

  description vers n5K

  switchport mode trunk

  fip-snooping port-mode fcf

  speed 10000

interface Ethernet1/1

  switchport mode trunk

  spanning-tree port type edge trunk

  speed auto

interface Ethernet1/2

  switchport mode trunk

  spanning-tree port type edge trunk

  speed auto

interface Ethernet1/3

  switchport mode trunk

  spanning-tree port type edge trunk

  speed auto

interface Ethernet1/4

  switchport mode trunk

  spanning-tree port type edge trunk

  speed auto

interface Ethernet1/15

  description vers SW5548UP-CA3-R-1 eth 1/13 dans Po15

  switchport mode trunk

  speed 10000

  channel-group 15

interface Ethernet1/16

  description vers SW5548UP-CA3-R-1 eth 1/14 dans Po15

  switchport mode trunk

  speed 10000

  channel-group 15

-----------------------

nexus site X

version 6.0(2)N2(1)

feature fcoe

feature telnet

cfs ipv4 distribute

feature interface-vlan

feature lldp

vlan 806

  fcoe vsan 806

  name FCoE-Bas

vsan database

  vsan 806

fcdomain fcid database

  vsan 806 wwn 50:0a:09:84:9d:e2:5c:61 fcid 0x560000 dynamic

  vsan 806 wwn 21:00:00:1b:32:8a:ac:59 fcid 0x560100 area dynamic

  vsan 806 wwn 21:00:00:c0:dd:26:0c:8f fcid 0x560040 dynamic

  vsan 806 wwn 21:00:00:c0:dd:21:82:b3 fcid 0x560060 dynamic

  vsan 806 wwn 21:00:00:c0:dd:21:81:6b fcid 0x560080 dynamic

interface vfc101

  bind mac-address 00:c0:dd:21:81:6b

  switchport description ESXi-E

  no shutdown

interface vfc102

  bind mac-address 00:c0:dd:21:82:b3

  switchport description ESXi-D

  no shutdown

interface vfc103

  bind mac-address 00:c0:dd:26:0c:8f

  switchport description ESXi-A

  no shutdown

vsan database

  vsan 806 interface vfc30

  vsan 806 interface vfc101

  vsan 806 interface vfc102

  vsan 806 interface vfc103

  vsan 806 interface fc1/27

  vsan 806 interface fc1/28

  vsan 806 interface fc1/29

  vsan 806 interface fc1/30

  vsan 806 interface fc1/31

  vsan 806 interface fc1/32

interface fc1/30

  switchport description vers SW5548UP site y

  no shutdown

interface fc1/31

  switchport description vers Metrocluster FC

  no shutdown

interface fc1/32

  switchport description SERVEUR DMZ

  no shutdown

and nexus 5k site Y with the zoneset

-------------------------------------------------------------

version 6.0(2)N2(1)

feature fcoe

feature telnet

cfs ipv4 distribute

cfs eth distribute

feature interface-vlan

feature lacp

feature vpc

feature lldp

vlan 806

  fcoe vsan 806

  name FCoE-Bas

vsan database

  vsan 806

fcdomain fcid database

  vsan 806 wwn 20:44:00:a0:b8:32:0c:dc fcid 0x400000 area dynamic

  vsan 806 wwn 20:35:00:a0:b8:32:0c:dc fcid 0x400100 area dynamic

  vsan 806 wwn 20:1e:54:7f:ee:ae:9d:80 fcid 0x400200 dynamic

vsan database

  vsan 806 interface fc1/27

  vsan 806 interface fc1/28

  vsan 806 interface fc1/29

  vsan 806 interface fc1/30

  vsan 806 interface fc1/31

  vsan 806 interface fc1/32

!Full Zone Database Section for vsan 806

fcalias name DS4700CA vsan 806

    member pwwn 20:44:00:a0:b8:32:0c:dc

fcalias name DS4700CB vsan 806

    member pwwn 20:35:00:a0:b8:32:0c:dc

fcalias name esxdmza vsan 806

    member pwwn 21:00:00:1b:32:8a:ac:59

fcalias name nCaps vsan 806

    member pwwn 50:0a:09:84:9d:e2:5c:61

fcalias name ESXi-E vsan 806

    member pwwn 21:00:00:c0:dd:21:81:6b

fcalias name ESXi-A vsan 806

    member pwwn 21:00:00:c0:dd:21:82:b3

fcalias name ESXi-D vsan 806

    member pwwn 21:00:00:c0:dd:26:0c:8f

zone name esxdmza_DS4700CA vsan 806

    member fcalias DS4700CA

    member fcalias esxdmza

zone name esxdmza_DS4700CB vsan 806

    member fcalias DS4700CB

    member fcalias esxdmza

zone name ESXi-E_DS4700CA vsan 806

    member fcalias DS4700CA

    member fcalias ESXi-E

zone name ESXi-E_DS4700CB vsan 806

    member fcalias DS4700CB

    member fcalias ESXi-E

zone name ESXi-E_nCaps vsan 806

    member fcalias nCaps

    member fcalias ESXi-E

zone name esxdmza_nCaps vsan 806

    member fcalias esxdmza

    member fcalias nCaps

zone name ESXi-A_DS4700CA vsan 806

    member fcalias DS4700CA

    member fcalias ESXi-A

zone name ESXi-A_DS4700CB vsan 806

    member fcalias DS4700CB

    member fcalias ESXi-A

zone name ESXi-D_DS4700CB vsan 806

    member fcalias DS4700CB

    member fcalias ESXi-D

zone name ESXi-D_DS4700CA vsan 806

    member fcalias DS4700CA

    member fcalias ESXi-D

zoneset name FCoE-Bas vsan 806

    member esxdmza_DS4700CA

    member esxdmza_DS4700CB

    member ESXi-E_DS4700CA

    member ESXi-E_DS4700CB

    member ESXi-E_nCaps

    member esxdmza_nCaps

    member ESXi-A_DS4700CA

    member ESXi-A_DS4700CB

    member ESXi-D_DS4700CB

    member ESXi-D_DS4700CA

zoneset activate name FCoE-Bas vsan 806

------------------------------------------------------------------------------------------------

zoneset look like nice

`show zoneset active vsan 1-4093`

zoneset name FCoE-Bas vsan 806

  zone name esxdmza_DS4700CA vsan 806

  * fcid 0x400000 [pwwn 20:44:00:a0:b8:32:0c:dc]

  * fcid 0x560100 [pwwn 21:00:00:1b:32:8a:ac:59]

  zone name esxdmza_DS4700CB vsan 806

  * fcid 0x400100 [pwwn 20:35:00:a0:b8:32:0c:dc]

  * fcid 0x560100 [pwwn 21:00:00:1b:32:8a:ac:59]

  zone name ESXi-E_DS4700CA vsan 806

  * fcid 0x400000 [pwwn 20:44:00:a0:b8:32:0c:dc]

  * fcid 0x560080 [pwwn 21:00:00:c0:dd:21:81:6b]

  zone name ESXi-E_DS4700CB vsan 806

  * fcid 0x400100 [pwwn 20:35:00:a0:b8:32:0c:dc]

  * fcid 0x560080 [pwwn 21:00:00:c0:dd:21:81:6b]

  zone name ESXi-E_nCaps vsan 806

  * fcid 0x560000 [pwwn 50:0a:09:84:9d:e2:5c:61]

  * fcid 0x560080 [pwwn 21:00:00:c0:dd:21:81:6b]

  zone name esxdmza_nCaps vsan 806

  * fcid 0x560100 [pwwn 21:00:00:1b:32:8a:ac:59]

  * fcid 0x560000 [pwwn 50:0a:09:84:9d:e2:5c:61]

  zone name ESXi-A_DS4700CA vsan 806

  * fcid 0x400000 [pwwn 20:44:00:a0:b8:32:0c:dc]

  * fcid 0x560060 [pwwn 21:00:00:c0:dd:21:82:b3]

  zone name ESXi-A_DS4700CB vsan 806

  * fcid 0x400100 [pwwn 20:35:00:a0:b8:32:0c:dc]

  * fcid 0x560060 [pwwn 21:00:00:c0:dd:21:82:b3]

  zone name ESXi-D_DS4700CB vsan 806

  * fcid 0x400100 [pwwn 20:35:00:a0:b8:32:0c:dc]

  * fcid 0x560040 [pwwn 21:00:00:c0:dd:26:0c:8f]

  zone name ESXi-D_DS4700CA vsan 806

  * fcid 0x400000 [pwwn 20:44:00:a0:b8:32:0c:dc]

  * fcid 0x560040 [pwwn 21:00:00:c0:dd:26:0c:8f]

New Member

unify Fc interface on 5548UP down

for your Information,

Mistake came from a global Qos configuration who break the auto process who create a mandatory QOS for FCoE. so we built a qos who can transport FCoE and is now working.

1151
Views
10
Helpful
5
Replies