Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Upgrade of 9124e from 3.3.1a to 4.2.1b hangs during Supervisor reset

Has anyone else using 9124e switches in HP c7000 blade chassis run into this?  I tried to upgrade the firmware from 3.3.1a to 4.2.1b.  According to the upgrade guides this should be a non-disruptive upgrade, and we successfully did this upgrade on our regular 9124's and 9134's.  Everything looked good on the compatablity check and everything looked good as the upgrade proceeded.  When it got to the point in the upgrade where the supervisor should reset, the switch stopped responding.  I was connected from the chasis onboard administrator to the serial port on the switch when it stopped responding, and I could not telnet or ssh to the switch and it did not respond to pings.  After about 15 mins the ISL showed down and all the HBA's had disconnected.  I removed and reinserted the switch back into the chassis, and it came up normally and was running the 4.2.1b code, all of the configs looked good and everything reconnected

Thinking that maybe 3.3.1.a to 4.2.1b was too big of a jump, I tried to do a 3.3.1a to 4.1.3a upgrade.   This produced the same results.  After this I did a 4.1.3a to 4.2.1b upgrade and this went fine with no disruption.  I looks like the upgrade is having problems going from 3.3.1a to 4.x.x.  I talked to HP on this and am waiting to hear back from them, but I was curious if this has happened to anyone else.



CreatePlease to create content