Cisco Support Community
Community Member

C20 TC5.X upgrade

Hi All,

I'm having trouble upgrading two of seven c20s that we have from 4.x to 5.x.  I started the upgrade process in TMS and five of the seven systems upgraded with no problem.  Two of them were postponed several times because TMS said that it could not communicate with the systems.  So I tried to perform the update via the system's web interface.  I applied the release key and the system rebooted. I then selected the TC5.X package and pressed upgrade after some time I refreshed the web page and the system still displayed the firmware as 4.X.  Anyone have any ideas?


C20 TC5.X upgrade

Just wonder what the official way is but I always upgrade, then in general the system auto reboots,

then I add the key and boot again, which workes fine for me.

Dont forget to refresh the page :-)

Remember that the file is quite big, so if its a remote location it can take some time.

As you seem to have direct ip connectivity to the endpoint, login with the admin account via ssh/telnet/local console.

This will first show you the version info as well and during the upgrad a progress bar.

Also checking the logfiles on the endpoint might give you some hints.

You can also upoad the file via scp, then you can split upload and upgrade in two steps

which might give you additional control.

The C20 Admin guide will give you more input, ...

Please remember to rate helpful responses and identify

Community Member

C20 TC5.X upgrade

Martin, thanks for the reply. I tried some of the suggestions you mentioned but to no avail.  I used the web interface to try and upload the software package, while logged in via telnet to observe the status. Essentially it seemed as if nothing actually took place and the system never rebooted (i.e. telntet session didnt end). The system is on TC4.1 so I thought to try TC4.2 but that didnt work either.

Re: C20 TC5.X upgrade

I would try to first simple restart the codec myself to see if this changes the behavior,

if an upgrade attempt after that would behave similar I would try to do a factory default

reset and if this did not help I would open a TAC case.

Please rate the answeres! (the stars underneeth the postings)

Please remember to rate helpful responses and identify

Community Member

C20 TC5.X upgrade

Hi William,

It does happens that codec has the latest version after upgrade however it keeps booting up with older version.

Please login as root and browse to cd /mnt/base directory.  Do "ls"  and you will see two images such as image1 and image2. 

Then check the software version of  two images.  In case one of the image has latest vesion TC5.X , please select the image using command  "selectsw image1/2"  and then reboot the codec.

The codec will reboot and come up as TC5.X software. 

In case the both the images are not TC5.X you need to upgrade the codec again.   You can also use WinScp to upgrade the codec.

Please check the documents on supports forum.

If this does not resolve the issue, open a TAC case.

Hope this helps,



Community Member

C20 TC5.X upgrade

I had the same issue.. I got around it as such..

1) Tried a simple restart and thist did not fix thing.

2) Did a backup of the config

3) Then I did a Factory default using the following command..

     xcommand systemunit FactoryReset Confirm:Yes

4) Noted that the Firmware was still TC4.2.2

5) The I went to up upgrade via the C20 Gui successfully to TC5.1.3

Just thought I should share it..


Community Member

C20 TC5.X upgrade

I have a related question but for a different symptom: One of our engineers upgraded a relatively new c20 to the TC5.1.3.292001 release thinking that this was a compatible upgrade. We're now getting a message on the screen saying:

Missing Release Key

  • Please make sure the system has a valid Release Key corresponding to software version TC5.1.3.292001

The codec shows up in sh CDP neighbors but will not get an IP address. When I navigate to Administrator Settings I get a spinning circle that just keeps going and going. I can never get past this screen to set an IP address.

This c20 does not have a 9 pin serial interface so I'm unable to get to the command line. Attempts at resetting to factory defaults have failed as well: whe I hold down the power button in the off position the device never shows the red light that's explained in the documentation.

So, Any ideas how I might get this box back to it's original 4.X relase while we work out the licensing?

Thank you in advance.


CreatePlease to create content