Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Can not set phonebooks on systems

Hello. I have been having some problems seeting my phonebooks on systems that are registered to our TMS. When I go through the procedure, nothing shows on the endpoint (EX90). This was working fine prior to our migrating to a new server. All other provisioning (Jabber for TP) is working fine. Suggestions?                 

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Can not set phonebooks on systems

Scott

You said you moved to a new server. I suspect maybe an IIS issue with the classic "Unauthorized".

First verify that the phonebook URL on the endpoint is OK and reachable. You can do this from your computer in your webbrowser:

Close all your TMS sessions on your computer first.

Then try this URL, change the values to support your TMS.

http(S)://or/tms/public/external/phonebook/phonebookservice.asmx

if you now get prompted for a password, then this is most likely your issue. You should not get prompted for a password here.

If you can see the phonebook service page, try the same URL on your endpoint. SSH on to the endpoint as root type:

cisco~$ curl http(S)://or/tms/public/external/phonebook/phonebookservice.asmx

What do you see here?

Or you can just go into the TMS server, open IIS manager, expand the TMS structure and locate the tms/public folder. Click the public folder and select authentication. Anonymous Access should be the only method enabled.

/Magnus

11 REPLIES

Can not set phonebooks on systems

Is the old server still alive or is it or at least all services properly shut down?

Did you use a hostname or did the ip address change?

Are the systems using the system navigator or the provisioning?

Are the systems behind firewall or directly reachable?

Do you use http or https?

Is the firewall ok?

If you use the syste navigator, did you try to do a force refresh, followed by an enforce management settings?

Also check under tms-webinterface > configuration > network settings that the advanced network settings

are still ok

Please remember to rate helpful responses and identify helpful or correct answers.

Please remember to rate helpful responses and identify

New Member

Can not set phonebooks on systems

Martin,

Thank you for your response. Here's my answers to your questions -

The services on the old server have been disabled.

Hostname and IP are the same as the old server (old server now has different HN and IP)

The systems are all using provisioning

All systems are directly reachable

We usee http

Firewall is OK

N/A - we use provisioning

Advanced settings seem to be fine

New Member

Can not set phonebooks on systems

The place that I often overlook for setting phone books in under the Access Control tab.

New Member

Can not set phonebooks on systems

I have allowed access for all systems in the "Access Control" tab.

Cisco Employee

Re: Can not set phonebooks on systems

Sorry but I'm a bit confused by this post. Initially you say the EXs are directly managed by TMS but then you say they are provisioned...meaning are they TMSPE provisioned (VCS provisioned and registered)? If its the later, then they wouldn't be in TMS. Therefore, we need to ascertain whether your provisioning with TMSPE or they are directly managed by TMS. Meaning the PB mechanisms works differently between the two.

Sent from Cisco Technical Support iPad App

New Member

Re: Can not set phonebooks on systems

When I referred to provisioning, I meant we provision our Jabber for TelePresence users. ll of our endpoint are registered with TMS. Sorry for the confusion.

Cisco Employee

Re: Can not set phonebooks on systems

So is it working or not working? If not, then I would follow Martin's suggestions.

Sent from Cisco Technical Support iPad App

New Member

Re: Can not set phonebooks on systems

The phonebooks are not being loaded to the endpoints even though they show up on the "Phone Book" tab for systems in TMS.

Cisco Employee

Re: Can not set phonebooks on systems

Scott

You said you moved to a new server. I suspect maybe an IIS issue with the classic "Unauthorized".

First verify that the phonebook URL on the endpoint is OK and reachable. You can do this from your computer in your webbrowser:

Close all your TMS sessions on your computer first.

Then try this URL, change the values to support your TMS.

http(S)://or/tms/public/external/phonebook/phonebookservice.asmx

if you now get prompted for a password, then this is most likely your issue. You should not get prompted for a password here.

If you can see the phonebook service page, try the same URL on your endpoint. SSH on to the endpoint as root type:

cisco~$ curl http(S)://or/tms/public/external/phonebook/phonebookservice.asmx

What do you see here?

Or you can just go into the TMS server, open IIS manager, expand the TMS structure and locate the tms/public folder. Click the public folder and select authentication. Anonymous Access should be the only method enabled.

/Magnus

Cisco Employee

Re: Can not set phonebooks on systems

And in additon to what Magnus says, and since you did move to a new server. In the TMS UI, go to Admin Tools > Configuration > Network Setting > Advanced Network Settings for Systems on Internal LAN

and ensure your IP Address and FQDN reflect the new server information. I suspect your FQDN is the same but your IP address may have changed...and it could be your EPs are using IP vs. FQDN

New Member

Re: Can not set phonebooks on systems

Magnus,

You were correct. When I enabled the proper authentication, the phone books set on the units as desired.

Thank all of you very much for all of you assistance.

438
Views
0
Helpful
11
Replies
CreatePlease to create content