Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Codec can't find file in CUCM tftp


My CTS 1300 1.5 codec is due for an upgrade to 1.6.I've downloaded SIPTS.1-6-0-3945R-K9.sbn from CCO and uploaded to CUCM tftp.

The codec complains about not being able to find the file. I have checked the CUCM tftp, and it is there OK. I've filled in device load in CUCM.

The codec attached IP phone works OK and can find its tftp image. It cannot find its wallpaper or other ringtones, so I'm starting to wonder here.

Check the Codec log...

2009-11-26 10:45:53,920 - System restart request by CUCM2009-11-26 10:45:55,963 - System restarting2009-11-26 10:46:18,186 - Download file not found (CTLFile.tlv from 10:46:18,260 - No CTL found2009-11-26 10:46:18,391 - Download file not found (SEP001DA238E79F.lic from 10:46:18,560 - SEP001DA238E79F.cnf.xml downloaded (12411 bytes)

2009-11-26 10:46:19,963 - Upgrade Master CTS Image from SIPTS.1-5-11-3659R-K9.sbn to SIPTS.1-6-0-3945R-K9.sbn2009-11-26 10:46:22,842 - Upgrade failed: file not found2009-11-26 10:47:15,092 - INFO: Start in CCM mode

2009-11-26 10:47:15,406 - Auto Upgrade is enabledMedia port range is [16384,32766]2009-11-26 10:47:30,845 - Registering DN:92612009-11-26 10:47:30,870 - Camera Power Status: Center [on] Left [unknown] Right [unknown]Camera Video Cable Status: Center [plugged-in] Left [plugged-in] Right [plugged-in]Camera Ethernet Status: Center [good] Left [good] Right [good]Camera cables are verified plugged in properly

Anyone ever seen this before?



Everyone's tags (3)

Re: Codec can't find file in CUCM tftp

From log seems to be that tftp requests contacts the TFTP server but file is not there or not in cache ready to answer the request.

Did u restart TFTP in CUCM after putting the file there?

Make sure file is in all TFTP servers in cucm cluster and restart tftp service in all.

If u use a windows XP or any manchine and try to download the file using a tftp client pointing to cucm IP address it works?

Are you using CUCM security for this cluster?

Any firewall in the middle?


Community Member

Re: Codec can't find file in CUCM tftp

Hi again!

Our Codec was delivered with the factory image CTS 1.5.11(3659).

I tried to upgrade directly up to CTS 1.6.0(3954) but this gave me the "Can't find file" message in the Codec logs.

Logically thinking that either the tftp server or even the network had issues, I went ahead and tried linking to my own Linux tftp server. When this also failed and the logs gave no clear answer I checked from other subnets to avoid firewall issues but to no avail. I double checked that http://tftp_IP:6970/ SIPTS.1-6-0-3954R-K9.sbn could be downloaded from the CUCM as well as my beloved Linux box, and they both checked out.

So, in a vain flashback from the glory days of CallManager on wintel platforms I had some memory lane from having to upgrade step by step in increments. I then managed to upgrade the Codec to CTS 1.5.12(3701) and ulitmately to CTS 1.6.0(3954).

I don't see this procedure anywhere documented on CCO, but it's entriely possible that it is on ciscoet. Maybe there sholud be a Release Note alongside the 1.6 image..?

At any rate the case is solved.

'Tanks for contributing.





Re: Codec can't find file in CUCM tftp

There should not be any restrictions, also in the log file:

2009-11-26 10:46:19,963 - Upgrade Master CTS Image from  SIPTS.1-5-11-3659R-K9.sbn to SIPTS.1-6-0-3945R-K9.sbn

which is a typo of the correct version 3954

Thats why its failing

We have tried this upgrade in ou rlab couple of times and with other customers without problems

Community Member

Re: Codec can't find file in CUCM tftp


I think you would need to explain this in more detail.

The image of CCO is SIPTS.1-6-0-3954R-K9.sbn. The image off the CUCM tftp is SIPTS.1-6-0-3954R-K9.sbn. The logs show SIPTS.1-6-0-3945R-K9.sbn...

A direct upgrade from 1.5.11 failed under all circumstances, but from 1.5.12 it worked out fine.

You refer to a typo. There is no typo in the CUCM or anywhere else I have put my fingers on.

I have seen people in other forums refer to a typo as well, but no documentation as to how and where this came up?



Re: Codec can't find file in CUCM tftp

Upgrade Master CTS Image from SIPTS.1-5-11-3659R-K9.sbn to SIPTS.1-6-0-3945R-K9.sbn

that means, codec was looking for file SIPTS.1-6-0-3945R-K9.sbn

which means u either hardcode phone load name in device under cucm or device defaults, thats it, period.

as i explained we tried the upgrade in the lab succesfully, if you are able to replicate the same behavior

we be more than happy to check the logs for you, if you can open a TAC case or here, making sure loads name are correct.


CreatePlease to create content