Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

CTMS on a VMware server in a lab environment

Hi,

Did anybody try to run a CTMS on VMware? I'm aware that it is not supported but it is just for a lab environment. As a matter of fact, I tried, it seemed to work since I was able to connect on the webGUI. Then I successfully created a static meeting but I wasn't able to connect to it using a CTS500.

So I assume the answer is no but I ask anyway.

Thanks,

Yohann LETENDRE

5 REPLIES
Green

Re: CTMS on a VMware server in a lab environment

it should work, I mean you are right is not supported but i dont see any technical reason it shouldnt work you may check region settings in CUCM and Calling search spaces

IF you have cucm detailed traces i can help u, check also CTMS sip log and system log

Let us know

Community Member

Re: CTMS on a VMware server in a lab environment

Hi, Thanks for your answer.

Since you asked, I'm gonna be more specific. First of all, I've tried to install two different versions: 1.5.3.0(12) and 1.6.1.0 with the same result. Each time, installation doesn't seem to end well since I cannot access the CLI through the console. However, webGUI and CLI via SSH are available, so I was able to finish its configuration. For testing purpose, I created a regular static meeeting. That's the one I tried to reach from a CTS500. Then, Each time I try to dial into this static meeting, I get an error message on the CTMS that says: "Execution Manager received signal=15, shutdowns all CTMS processes now" and the CTS get disconnected. An interesting point is that I can succesfully create an adHoc meeting, that works fine. I checked every parameter on both CTMS and CUCM but I found nothing. I even tried to set the transport type to UDP on the SIP Trunk but I get the same result. Actually, when it is set to UDP, I get no error message on the CTMS but it's not working neither.

Finally, I need to tell that I successfully configured several CTMS so I'm pretty sure every parameters are good. In fact, in this case, since it is for testing purpose, I'm using no CSS nor partition. On the CUCM, all I did was to create a SIP Trunk and an associated route pattern.

Thanks again for your help

Community Member

Re: CTMS on a VMware server in a lab environment

Just an update on this issue. My mistake, it appears that the "Require Forced authorization Code" was set on the route pattern on the CUCM. Once I deactivated that parameter, I was able to set a static meeting. So now I can tell that you can run a CTMS on a VMware server.

Community Member

There was a VM based CTMS

There was a VM based CTMS solution once available, based on the MCS server. It had some limitations how many CTS were supported, but it contained CTMS, Recording and CTSMan under one roof.

For the time it was introduced, it was pretty straightforward. Might you can find those vm's somewhere? It came preinstalled, but I am sure there must be a recovery medium around.

Cheers

Danny

Community Member

Re: CTMS on a VMware server in a lab environment

CTMS install fails on VMware, I believe, due to the CTMS attempting to detect the hardware platform to install an SNMP package.  Once it seems to hang during install, restart it and it will boot up until after the "starting servm" line.

If you root the box, you can shell in and edit out the line in the startup scripts (rc.local) that is attempting to start the SNMP service.  Then your CTMS will startup cleanly.

853
Views
0
Helpful
5
Replies
CreatePlease to create content