Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CTS not calling C series running Software TC5

I am having a problem where calls from CTS is not calling to Tangberd C series running software version TC5.1.

Following is the set up;

CTS registered to CUCM and C series registered to the VCS

there is a trunk between CUCM and VCS.

Version,

CTS-1.8.1, C sereis-TC5.1, CUCM 8.6.2, VCS 7.1

CTS is not making a call to the TC5 endpoint but if i downgrade it to TC4. the call goes thru.

Anybody's run into this kind of issue? if you do, can you share me your solution please?

Everyone's tags (7)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

CTS not calling C series running Software TC5

Hi Zaw,

I have seen an issue similar to this in the past on CUCM 8.6.2 where the TC5 endpoint sents a URI in the SIP contact header and the CUCM attempts a DNS lookup on the server portion of the URI which fails and the call tears down.

I would need to see CUCM traces to confirm this is the issue, but if I recall correctly the CTS endpoint would receive a 503 Service unavailable message.

If you control the DNS server the CUCM is pointed to then you could try to add a bogus A record that matches your SIP domain on the VCS to see if it helps.

It might be best to open a TAC case to explore all your options.

Thanks,

Paul

4 REPLIES
Cisco Employee

CTS not calling C series running Software TC5

Hi,

Can you notice any diference in term of C codec configuration after the upgrade? can I take a look at the xconf/xstatus from the codec on TC4.x and on TC5.x ( working / non working case) ?

Regards

New Member

CTS not calling C series running Software TC5

It would also be good to know what the behavior is during the failure. Is there any initial setup, or does it fail immediately? Is there any specific error on the screen when it fails?

Cisco Employee

CTS not calling C series running Software TC5

Hi Zaw,

I have seen an issue similar to this in the past on CUCM 8.6.2 where the TC5 endpoint sents a URI in the SIP contact header and the CUCM attempts a DNS lookup on the server portion of the URI which fails and the call tears down.

I would need to see CUCM traces to confirm this is the issue, but if I recall correctly the CTS endpoint would receive a 503 Service unavailable message.

If you control the DNS server the CUCM is pointed to then you could try to add a bogus A record that matches your SIP domain on the VCS to see if it helps.

It might be best to open a TAC case to explore all your options.

Thanks,

Paul

New Member

CTS not calling C series running Software TC5

Thanks everyone for your reponsens. The issue has been solved. the problem was CUCM was doing a DNS lookup aganist the domain name that is sent back by the VCS.

this is a cucm bug. as far as i know the fix is applied in cucm 9.0 (1).

the workaround is to create a srv record in the DNS server that translates that domain to the VCS ip address.

683
Views
0
Helpful
4
Replies