Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Domain Part in Remote URI is stripped

Dear all

I just discovered a strange behavior of Systems running TC6.1 (not sure if that has also happend with the previous versions): The domain part of the calling party is stripped in the history, so you can't dial back...

In the log it looks I see the following:

SipCall I: sip_call_handler::log_call_ind(na/0/-1): Incoming callrate=0 to sip:8572@xxx.com from sip:peter.nehrmann.movi@yyy.com

MainEvents I: IncomingCallInvite(p=48) remoteURI='peter.nehrmann.movi' displayName='Peter Nehrmann' localURI='sip:8572@xxx.com'

Do you guys have the same problem?

Regards,

Peter

Everyone's tags (3)
7 REPLIES
Bronze

Domain Part in Remote URI is stripped

Hi Peter,

- can you check the VCS on Status > Calls > history and see whether the alias is in FQDN format and not stripped?

- do have any call policy on VCS?

- do you have a conductor deployed and integrated with VCS? is it managing the call policy?

regards, Ahmad

New Member

Domain Part in Remote URI is stripped

Hi Ahmad,

In the History of the VCS the alias is fine, we have CPL just for outbound calls, but even if I disable them the domain is stripped.

The endpoints are registered to a CUCM, I checked the SIP messages there and found the following:

This is the invite from VCS > CUCM (I skipped a few lines)

INVITE sip:aaa.bbb@xxx.com SIP/2.0

Call-ID: 7d124ee57ea4226e@192.168.0.154

CSeq: 101 INVITE

Contact: <>peter.nehrmann.movi@yyy.com;gr=urn:uuid:194120e9-08b5-51c1-b49f-e18958431e65>

From: "Peter Nehrmann" <>peter.nehrmann.movi@yyy.com>;tag=548d99204a13e9db

To: <>aaa.bbb@xxx.com>

Max-Forwards: 13

Allow: INVITE,ACK,CANCEL,BYE,INFO,OPTIONS,REFER,NOTIFY

User-Agent: TANDBERG/774 (MCX 4.5.7.16762) - Windows

Supported: replaces,timer,gruu

Session-Expires: 1800

X-TAATag: cb762888-eed0-11e2-8901-0010f3249336

Content-Type: application/sdp

Content-Length: 1955

To me this is looking OK, but this is the invite CUCM > EX90

INVITE sip:8572@x.y.1.21:58500;transport=tcp SIP/2.0

Via: SIP/2.0/TCP x.y.168.11:5060;branch=z9hG4bKac5cb05327d5de

From: "Peter Nehrmann" <>peter.nehrmann.movi@yyy.com>;tag=140844383~0c7fb6d9-1e53-4c05-bb59-4d0f2ac8e4a2-34910379

To: <>8572@xxx.com>

Date: Wed, 17 Jul 2013 11:05:31 GMT

Call-ID: ca529500-1e617a7b-4c7da6-ba8180a@x.y.168.11

Supported: timer,resource-priority,replaces

Min-SE:  1200

User-Agent: Cisco-CUCM9.1

Allow: INVITE, OPTIONS, INFO, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY

CSeq: 101 INVITE

Expires: 180

Allow-Events: presence

Call-Info: ; security= NotAuthenticated; orientation= from; gci= 2-1212669; call-instance= 1

Send-Info: conference, x-cisco-conference

Alert-Info: <>

Remote-Party-ID: "Peter Nehrmann" <>peter.nehrmann.movi@yyy.com;x-cisco-callback-number=peter.nehrmann.movi>;party=calling;screen=yes;privacy=off

Contact: ;transport=tcp>;video;audio

Max-Forwards: 12

Content-Length: 0

The Domain in the Contact field is changed to the IP of the CUCM and in the "x-cisco-callback-number" the domain is missing.

Any Ideas?

Thanks in advance

Peter

Bronze

Domain Part in Remote URI is stripped

Hi peter,

This seems to be the misconfiguration on CUCM not endpoint nor VCS.

can you navigate and check the checkbox for "use domain name ...." on sip profile (see below)

if not, please set that and reset your sip trunk (or you may need to restart your cucm).

regards, Ahmad

New Member

Domain Part in Remote URI is stripped

Hi Ahmad

I downgraded one Endpoint to 5.1.8, and there it is correct:

The full URI is shown in the history for the missed call.

Back to 6.1.2 I have the same error again - even for the call that was correct in the history before, the domain is stripped...

With 6.0 I had the same error, so I guess it has to be related to 6.x - Can you reproduce that?

Thanks in advance

Peter

New Member

Domain Part in Remote URI is stripped

Hi Ahmad

Well, I don't have that option in CUCM9.1

Can I set it somewhere else?

Regards,

Peter

New Member

Domain Part in Remote URI is stripped

Wish I would had found this discussion yesterday.  Please see the discussion I started below.  I found the same with CUCM 9.1 with EX90 running 6.2.  I made no configuration changes and just downgraded the EX90 to 5.1.8 and all is working.  As indicated in my discussion below I'll be opening a TAC case.

https://supportforums.cisco.com/message/4020412#4020412

New Member

Have opened a cisco case but

Have opened a cisco case but not help, i have compared line by line for a working SIP CLID (CUCM-CUCM working) and one (VCS-CUCM not working), and found out that the codec for some reason take the display "user" before the <sip:user@domain> under the PAI if there is one and send it out with the remote-party-id with "user" <sip:user@domain>

I have to use a SIP normalization script to remove that value under PAI and got the codec display correctly with the callerID.

My sip normalization rule:

M = {}
function M.inbound_INVITE(msg)
-- Remove the display name from the PAI header
local pai = msg:getHeader("P-Asserted-Identity")
local uri = string.match(pai, "(<.+>)")
msg:modifyHeader("P-Asserted-Identity", uri)
end
return M

967
Views
0
Helpful
7
Replies
CreatePlease login to create content