Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Cisco Employee

EX90 and Self-Provisioning IVR

I am building a demo and I want users to be able to connect a EX90/60 to it, let auto-register with CUCM, and then use the self-provisioning IVR to setup the device.  I have the Self-Provisioning setup and working with all the phones like 9971/DX650/etc.  When I dial the route point number for the self-provisioning IVR on the EX90 it answers and when I try to put in my self-service user ID to provision the EX, the IVR doesn’t recognize any dtmf tones.    I’ve looked and I’ve looked and can’t find out why the keys aren’t being recognized on the EX90.  I’ve self provisioned this same EX90 device in another demo and it works just fine.  Can anyone clue me in on what this could be?  Thanks in advance!

4 REPLIES
Cisco Employee

HiLooks like you might be

Hi

Looks like you might be hitting this bug: CSCul50370

This bug should be fixed in TC7.2.0 which is planned to be released this week.

A workaround might be to use the command:

 

xCommand DTMFSend CallId: <callid> DTMFString: <number>

 

If this is still an issue on TC7.2.0 we should take a closer look at this.

 

/Magnus

Cisco Employee

Thanks I'll keep an eye out

Thanks I'll keep an eye out for the new release. I looked up the bug but I saw it was for a C series and not an EX.  Don't know if that makes a difference.  I also tried to do the xcommand and I was able to hear the digits being sent but it had the same results as if i pressed the keys myself on the codec.  I tried other services like calling voicemail and it was able to detect the DTMF being sent to it right away. Just not to the Self-provisioning IVR. 

 

Thanks

Jason

Cisco Employee

I just completed the upgrade

I just completed the upgrade to 7.2.0 and it is still having the same issue.  Also tried sending the dtmf with the xcommand and it didnt work either.  Any other suggestions?

 

Thanks

Cisco Employee

So I wanted to update this

So I wanted to update this thread just in case someone else runs into this issue.  The issue was IVR (CTI app) does not support RFC 2833 DTMF method, and the TC endpoints don't support KPML, so you must insert an MTP to do DTMF extraction from RFC 2833 to CTI.  I ended up assigning a MGRL that included the MTP_2 device on CUCM to the Default device pool which is assigned to devices when they auto-register, at least thats what I have configured.  Anyway MTP was the culprit.

84
Views
0
Helpful
4
Replies
CreatePlease to create content