Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Expressway problem with Jabber client

We’ve installed an Expressway Edge and Core (version 8.1)  because we would like to try the Jabber client from the Internet without VPN connection.

We ’ve configured both Expressway components and we see that all are working fine (we couldn’t find any error message on the logs) but when we want to login with the Jabber we get a message : ”Unable To Connect To The Server” (I’m attaching a part of the Jabber log).

If we want to use the client as a softpone, the login is working properly,  but if we try to communicate with the presence server, it’s not working

(I tried with wrong username and password and I get back the wrong username and password message so the authentication is working fine). We verified the configuration on both Expressways, we checked the certificates……., but we could find any problem. What could we check that we are able to identify the cause of error?

12 REPLIES

Re: Expressway problem with Jabber client

If you could let us know more about your deployment / setup / incl. used version numbers?

Actually I am not sure is the Jabber / Collaboration edge feature officially released?

If not you should talk to your Cisco (eft) contact.

Please remember to rate helpful responses and identify helpful or correct answers.

Please remember to rate helpful responses and identify

Cisco Employee

Re: Expressway problem with Jabber client

It's on CCO and there is only one release on CCO: VCS 8.1 and Jabber for Windows 9.6.0

Expressway problem with Jabber client

First of all he did not mention which CUCM version he uses and how he exactly deployed it.

How do I have to interpret your statement, that it is officially supported or not?

If I understood it right the official support would come with JfW9.7

Please remember to rate helpful responses and identify helpful or correct answers.

Please remember to rate helpful responses and identify

Community Member

Expressway problem with Jabber client

UCM version is 9.1.2.

Presence server version is 9.1.1 (HA solution with two servers)

Jabber version 9.6.0 17088 (we turned on the remote access option in the jabber-config.xml)

Expressway C and E version X8.1 ( The Expressway C was able to discover UCMs and Presence and status of the servers are active)  

Community Member

Re: Expressway problem with Jabber client

I'm also currently playing with jabber 9.6 and I would like to try edge functionality.

Could you please tell me how can I enable remote access option through jabber-config XML file?

Thanks

Tom

Community Member

Re: Expressway problem with Jabber client

Yes of course.

Please add  the following line to the config

in the Policies section:

ON

Regards,

Istvan

Community Member

Re: Expressway problem with Jabber client

Thanks

I have a couple of questions about this remote access feature:

1) How jabber client discover that he is out of the enterprise? I found on the logs that the client was switched to the edge mode due to not be able to resolve _cisco-uds or _cuplogin SRV records. This will be probably the reason so I need only to confirm this.

2) And how the client can locate remote access server. It should try to look for some another SRV record or something like that?? Because I didn't see any DNS SRV search on the jabber log and I immediately receive "Cannot find the edge server" message. :-(

Tom

Community Member

Expressway problem with Jabber client

Hi

Try this SRV record on your public DNS:

_collab-edge._tls.example.com. SRV 10 10 8443 expressway.example.com.

on the internal DNS server you can use:

_cisco.uds._tcp.example.com. SRV 10 10 8443 ucm.example.com.

/Ola

Community Member

Expressway problem with Jabber client

I am running 9.6 and have added the On to the jabber-config.xml file under my profile but it doesn't seem to have an impact.  The csf-unified.log still says EGDE is disabled all over the log when I am trying to find services.

Is there a thread that covers the SRV records required for Collab Edge?

Cheers!

Community Member

Expressway problem with Jabber client

Is there a design or deployment guide available for the Collab Edge feature?  There are a number of references to it on the web site, but no configuration documentation that I can find.

Cisco Employee

Re: Expressway problem with Jabber client

Hi Brandon,

I've been advised this is a good guide:

http://ciscocollab.wordpress.com/2014/01/29/deploying-collaboration-edge/

Marton

Cisco Employee

Re: Expressway problem with Jabber client

Please note that no official guides have been released yet as the Collaboration Edge solution has not yet been officially released and is not yet supported by Cisco. Collaboration Edge will be fully released in the near future.

Additionally, Jabber 9.6 is not a supported collaboration edge client. The first supported collaboration edge client is expected to be 9.7.

Vernon

3512
Views
0
Helpful
12
Replies
CreatePlease to create content