Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How to upgrade the CTS500 firmware from 1.7.4 to 1.8

Dear all,

Our current CUCM sw version is 8.6.2, and we would like to upgrade our CTS endpoint from 1.7.4 to 1.8.

We have uploaded the cmterm-CTS.1-8-1-34R-K9.P1.cop to the CUCM(please refer to attached picture), and we are configure "cmterm-CTS.1-8-1-34R-K9.P1" in the

Device Defaults Configuration of CUCM.

Can anyone provide any suggestion or detail procedure for us?

Best Regards,

Ben

10 REPLIES
Cisco Employee

Re: How to upgrade the CTS500 firmware from 1.7.4 to 1.8

Hi Ben,

In the Load Information field, enter the name of the COP file, removing the cmterm- in front of the file name.

On the following link you have the entire upgrade process very well explained:

Upgrading the CTS Software for Systems That Are Running Cisco TelePresence Software Versions 1.7.4 and Above

http://www.cisco.com/en/US/docs/telepresence/peripherals/cisco_touch/installation/cisco_touch_installation_upgrade.html#wp143851

Best regards.

New Member

Re: How to upgrade the CTS500 firmware from 1.7.4 to 1.8

Dear Antigles,

Thank you for link !

It is very helpful for us, and we have upgraded the CTS-500 to software version 1.8, however, the IP phone is not working after upgrade.

Is it a normal practice?

Many thanks,

Best Regards,

Ben    

Cisco Employee

Re: How to upgrade the CTS500 firmware from 1.7.4 to 1.8

Hi Lai,

The mildets interface on the phone must be upgraded separately. The jar/jad files can be downloaded from cco and the config guide is here: http://www.cisco.com/en/US/docs/telepresence/cts_admin/1_5/admin/guide/cta_1_5_midlets.html

-Paul

Sent from Cisco Technical Support iPhone App

New Member

Re: How to upgrade the CTS500 firmware from 1.7.4 to 1.8

Hi all,

I have upload the 1.8.1 Midlet to the CUCM, and subscribed the service as attached picture.

However, the IP phone shows the software mismatch, and its firmware is previous version.

Anyone has such experience before?

many Thanks.

Ben

Cisco Employee

Re: How to upgrade the CTS500 firmware from 1.7.4 to 1.8

Hi Ben,

Can you post the output of the "show version" command on the codec? and also these two lines taken from the "show hardware all" on your codec too?

Phone midlet status                : active
Phone midlet version               : TSPM-1.8.1-P1-1S

Thanks.

New Member

Re: How to upgrade the CTS500 firmware from 1.7.4 to 1.8

Dear antigles,

Thank for your information.

In the "show hardareall",

Phone midlet status                 : mismatch

Phone midlet version               : TSPM-1.7.4-P1-1S

Please let us know how to fix the software mismatch between CTS and IP Phone.

Best regards,

Ben

Cisco Employee

Re: How to upgrade the CTS500 firmware from 1.7.4 to 1.8

Hi Ben,

As you can see on your output, your phone is still running the old MIDlets.

I guess there are many possible reasons for it to happen, but I would say a frequent one is that people update the existing service instead of creating a new one in CUCM. That is doable but tricky.

I would recommend to create a new service from scratch for 1.8 Midlets, following the instructions on the link provided by Paul above.

I have also observed sometimes better and more consistent results by following this order:

  1. Create new MIDlets service
  2. Unsubscribe phone from old service
  3. Reboot phone
  4. Subscribe to the new service
  5. Reboot phone.

Best regards.

Re: How to upgrade the CTS500 firmware from 1.7.4 to 1.8

Hi Ben,

try to this command :

utils service restart Calling_Services

Sometimes calling service needs to trigger.

Be sure that :

Device > Device Settings > Device default >

Cisco TelePresence 500-37 = CTS.1-8-1-34R-K9.P1.sbn

Also be sure tspm middlett and Phone Service configuration.

Regards,

Baris.

New Member

Re: How to upgrade the CTS500 firmware from 1.7.4 to 1.8

Hi antigles,

Thank you for suggestion, we agreed the IP Phone can't get the 1.8.1 Midlet.

We have tired to delete the old Midlet service and create a new service, however, the problem still exist.

In the CTS endpoint, we found that

2012-05-29 00:55:06: ERROR Download unsuccessful: File CTLFile.tlv not found on host 192.168.30.2
2012-05-29 00:55:06: WARN No CTL found
2012-05-29 00:55:07: INFO Auxilary Camera status is Ready.
2012-05-29 00:55:07: ERROR Download unsuccessful: File cts-ccp-servers.txt not found on host 192.168.30.2
2012-05-29 00:55:07: INFO SEPC471FEE649D4.cnf.xml downloaded (13112 bytes)
2012-05-29 00:55:08: ERROR Download unsuccessful: File TSPM-1.8.1-P1-1S.loads not found on host 192.168.30.2
2012-05-29 00:55:11: INFO Upgrade Primary CTS Image from CTS.1-8-1-34R-K9.P1.sbn to TSPM-1.8.1-P1-1S

Will it be the problem of the call manager?    

Best Regards,

Ben

Cisco Employee

Re: How to upgrade the CTS500 firmware from 1.7.4 to 1.8

Hi Lai,

Your CTS logs indicate that you are conifiguring TSPM-1.8.1-P1-1S as the load name for your codec. This is not correct, (you should leave CTS.1-8-1-34R-K9.P1 in there). This is also suggesting that you might be not following exactly the procedure to subscribe the phone to the midlets service.

Please revisit the procedure and find the point where you decided to configure TSPM-1.8.1-P1-1S as the load name for the codec. Error might be around there.

Being that said, phone logs can provide further details on what the problem might be, whereas codec has noth much to say about midlets.

Following link is specific to midlet configuration and troubleshooting tips.http://www.cisco.com/en/US/docs/telepresence/cucm_cts/cucm_cts_admin_book/guide/cucm_cts_admin_midlets.html#wp1052908

Best regards.

1777
Views
0
Helpful
10
Replies