Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Issue: TMS and TC6.2 behind firewall does not work!

Hello!

If you have TC6.2 (at least TC6.1 seem to be also affected) it seems that you can not add a system behind firewall

anymore. I would expect that others will run to this issue as well if you have systems behind firewall.

If you updated a system from an earlier release you might not directly notice it as the system still shows up

as usual, but if you go for example to the extended settings for that system in TMS and you look at the system status

then its most likely still showing the system version of the pre upgrade release.

Symptoms seem also that the "System Status" might be wring, that changes are not taken and that phonebooks do not work.

Other problems might be present as well.

If you add a new system they show up as "Cisco TelePresence Group Systems" instead of its real type (c40, ex90, ...).

Here you will see that many settings (like all sip settings) do not show up and if ou look at the system stats (under extended settings)

it will say "Could not retrieve System Status".

We filed a SR to Cisco, so lets see. Would be interesting to hear who else ran into this issue and if somebody found a workaround

besides downgrading the endpoints.

Please remember to rate helpful responses and identify helpful or correct answers.

Please remember to rate helpful responses and identify

7 REPLIES
Bronze

Issue: TMS and TC6.2 behind firewall does not work!

Hi Martin,

what version of TMS is that?

what type of Firewall?

what is the topology?

TMS ----- FW1 -----DMZ ----- FW2 ------ Internet ------- Home FW ----- Endpoint1

would it work for this setup?

TMS ---- FW1 ------ DMZ

                                   |

                             Endpoint2

regards, Ahmad

Cisco Employee

Issue: TMS and TC6.2 behind firewall does not work!

Hi Martin,

The problem is easily reproducible with TC 6.1 and later. It is tracked as TC software bug CSCui94908.

I can't see any workarounds, as it looks like the endpoints' /History and /Status documents have changed in a way that TMS cannot parse.

-Kjetil

Re: Issue: TMS and TC6.2 behind firewall does not work!

dont tell me that its easy to reproduce, tell that/train the TAC team ;-)

Do you know how it will be addressed? As updating behind firewall is a pain anyhow and

it might be broken by that issue I would guess TMS should be updated to understand the

endpoint (or at least be able to upgrade them) and the endpoint should be fixed so it works

again with the old TMS versions.

And it would be nice to improve the quality control on new software.

Btw, the bug is still tagged as internal, I only get "Insufficient Permissions to View Bug"

Please remember to rate helpful responses and identify helpful or correct answers.

Please remember to rate helpful responses and identify

Cisco Employee

Re: Issue: TMS and TC6.2 behind firewall does not work!

Hi Martin,

[...]

Do you know how it will be addressed?

Looks like the target for a fix is the next TC 6.3.x release, and that the fix is reverting to TC 6.0 behavior (API wise).

As updating behind firewall is a pain anyhow and it might be broken by that issue I would guess TMS should be updated to understand the endpoint (or at least be able to upgrade them) and the endpoint should be fixed so it works again with the old TMS versions.

I am a bit skeptical of getting a "fix" into TMS when it isn't TMS that broke the integration. Any such TMS "fix" would just introduce additional code complexity that increases the risk of future TMS defects. And I'm not sure if it is even possible to fix it on the TMS side, as it looks like a lot of the information TMS relies upon is just gone from the documents we read from the endpoints.

[...]

Btw, the bug is still tagged as internal, I only get "Insufficient Permissions to View Bug"

I am a bit reluctant to write the publically viewable part of a TC software bug (as it isn't "my" product), but I'll notify my colleagues on the TC software team and ask them to update it.

Regards,

Kjetil

New Member

Re: Issue: TMS and TC6.2 behind firewall does not work!

Is there any date/timeframe when the next version of TC6.3.X will be out? As this is a major drawback for updating the devices to version tc6 from tc5.

br. Tom

Re: Issue: TMS and TC6.2 behind firewall does not work!

Hi Kjetil!

We have an other strange symptom, I am not sure if its related.

We got a new system with TC6.1, it was configured and showed up

as preregistered but not (and not as the group system) added in TMS (behind firewall)

We tried to downgrade it to 5.1.8 and then even 5.1.7 but its still the

same symptom, also a purge system in TMS (13.2.2) + reboot of the endpoint

does not help.

Any clue what we are facing here?

Edit: I opened SR #627775859 for the "preregistered" issue

Please remember to rate helpful responses and identify helpful or correct answers.

Please remember to rate helpful responses and identify

VIP Purple

Re: Issue: TMS and TC6.2 behind firewall does not work!

I second the call for greater quality control. We've noticed a few things (and have had bugs logged for) that worked in TC5 and TC6.0.1, but have been broken in TC6.1 and TC6.2. One's been fixed in a early version of TC6.2.1, but these things shouldn't have broken in the first place.

Sent from Cisco Technical Support iPad App

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.
921
Views
0
Helpful
7
Replies
CreatePlease to create content