Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Layout Problem on Codec C-Series TC6.0

Hi,

We have encountered problem on layout of C60 endpoint running TC6.0 when connecting on MCU.

On the MCU conference layout we use 1 + 3 video layout (pane 1 for content and panes 2,3,4 for participants).

 

The problem is, when the C60 endpoint will do presentation, the presentation is not showing on pane 1.  The presentation is showing on the pane 2 wherein the active presenter is also inserted on the pane. Please refer to picture for illustration.

What is the setting should be on the codec? or on the MCU?

 

Thank you.

Best regards,

 

Acevirgil

  • TelePresence
Everyone's tags (1)
10 REPLIES
VIP Green

To me, that looks like a MCU

To me, that looks like a MCU configuration issue - what's your "Content Mode" set to for the conference on the MCU?

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.

Hi Wayne,We only experience

Hi Wayne,

We only experience this issue when a C-series endpoint will do presentation. If a jabber client will do presentation the layout and applied pane placements are followed.

Here's the configuration of the MCU under conference configuration.

 

 

VIP Green

Have you tried it on the

Have you tried it on the Hybrid, or Pass-through setting, rather than Transcoding?

Also check what the Settings > Conferences > Content Tab > Display content in normal video channel is set to.

It could be a protocol difference too contributing to the issue - is your C60 talking to your MCU via H.323 or SIP?  (The Jabber Client will be SIP).

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.

Hi Wayne,We tried to isolate

Hi Wayne,

We tried to isolate the issue.

We only experience the issue if call is using SIP going to MCU.

H323 is ok with the layout and pane placement set on MCU conference.

Thank you.

 

VIP Green

I suggest you have a good

I suggest you have a good read of the on-line help for the MCU - there's a section on the content channel video support (http://mcu.uk.codian.com/help_content_support.html).

There's also a comment in the Configuring Content Settings section in the on-line help that says:

If there is an active content channel for a conference, it may be that the MCU is unable to open a content channel to a particular endpoint. For instance, that endpoint may have no content capability, or might not support the video format specified by the Outgoing content video codec setting.
In these cases, if this option (Display content in normal video channel) is set to Enabled, the MCU will display the content channel video within a pane of the currently selected conference layout. In these cases, you might also want to enable the Automatically make content channel important option in the Settings > Conferences page which will make the content channel important at the same time.
Note that SIP endpoints receive content from the MCU in the normal video channel (rather than in a separate channel). For this reason, this option must be enabled to allow SIP participants to see content.

 

I have both these set on my MCU(s).

Wayne
--
Please remember to rate responses and to mark your question as answered if appriopriate.

Hi Wayne, Thank you for the

Hi Wayne,

 

Thank you for the recommendations. We already check all settings as suggested but issue still encountered.

We decided to upgrade the firmware of the MCU from 4.4(3.54) to 4.4(3.57) but upgrade is unsuccessful.

Thank you.

Acevirgil

 

VIP Green

If the upgrade didn't work -

If the upgrade didn't work - check that your file downloaded correctly (or grab the latest 4.4_3.67 version) and try it again.

Note: you will need to unzip it first before uploading it and upload the uncompressed file (not the zip file).

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.

Hi Wayne,

Hi Wayne,

Thanks for the response.

We already upgraded the MCU firmware to 4.4(3.67). But upgrading the firmware did not resolves the problem.

We already figured out the issue based on the MCU 4.4 release notes that BFCP is not supported during encrypted SIP calls.

To resolve the problem, we disabled encryption on the codec.

The customer is worried about this since we disabled encryption. How can we mitigate the risk? What specific information will be transmitted without encryption?

Thank you.

Br,

Acevirgil

VIP Green

Good to hear that you've

Good to hear that you've found a work around to your issue and have managed to also get your equipment upgraded.

Obviously, with Encryption disabled on the endpoint, none of the video or audio will be encryped, which could lead to (but pretty unlikely) someone intercepting the communication stream (with a wireshark capture, or similar) and then being able to piece together and re-create/view the audio/video stream.  Is your customer really concerned about what they're transmitting?  What about other forms of communication, do they encrypt them too?  There's lots of ideas you can throw around as arguments for or against encryption on a particular platform.

There are benefits to not having encryption enabled though too - such as the ability to see the what's happening in the conferences through your managment tools (TMS, etc) and see what is going on in your environment - useful to find those users who keep forgetting to disconnect when they've finished their conference (conference has been going for hours, but looking in to the rooms, you can see that they're empty with the lights off - we have one particular customer who is pretty consistently doing this!).

We generally run our environment with Encryption disabled and only enable it when required for special purposes.

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.

208
Views
0
Helpful
10
Replies
This widget could not be displayed.