Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MX300 7.0.1 to 7.0.2 Upgrade fails

I have an MX300 which I'm trying to upgrade from 7.0.1 to 7.0.2 via TMS.  I've upgraded one other MX300 and a number of MX200's using the same image withour any issues.  When I try the upgrade via TMS I get the following error:

 

The event failed to complete. Details: Upgrade Failed: /mnt/base/image1/postinstall.d/rwfs.hook failed to run!

 

I've tried a manual upgrade but this fails also.  Full TMS Activity log is below.  Anyone able to offer assitance to apply the 7.0.2 firmware?

 

Thanks

 

Regards

 

David

 

TimeStatus Description
26/03/2014 14:00:03Event Created
26/03/2014 14:00:07Event executed by SRVETMS01
26/03/2014 14:00:07Endpoint running software: TC7.0.1.264e160
26/03/2014 14:00:09Upgrade assigned SessionID: 2d139b15-ccc0-47f7-aadd-34ba38fe017b
26/03/2014 14:00:09Device provisioned with upgrade information
26/03/2014 14:00:09Upgrade in progress - Phase: DownloadPending, Message: Waiting for start
26/03/2014 14:00:09Upgrade in progress - Phase: Downloading, Message: <none>
26/03/2014 14:00:09Upgrade in progress - Phase: Downloading, Message: <none>
26/03/2014 14:05:07Upgrade in progress - Phase: Installing, Message: <none>
26/03/2014 14:12:51The event failed to complete. Details: Upgrade Failed: /mnt/base/image1/postinstall.d/rwfs.hook failed to run!
Everyone's tags (1)
2 REPLIES
Cisco Employee

Hi David,I can find a couple

Hi David,

I can find a couple of similar upgrade failures in our internal issue tracking system. It seems to be caused by a corrupted configuration database on the endpoint.

The workaround seems to be a) Try the upgrade again (works some of the time), or b) Factory reset the endpoint and then try the upgrade again (works all of the time).

As you use TMS, you could easily take a configuration backup before factory resetting, so b) shouldn't do too much harm.

This issue is not specific to TC 7.0.x by the way, similar upgrade problems could be seen from TC 6.2 and later.

Regards,
Kjetil

New Member

Thanks Kjetil, I had same

Thanks Kjetil,

I had same problem with a new C40 that shipped with TC6.1.1. We could not upgrade beyond what it shipped with despite having all the release keys. Downgrading was OK. I tried all sorts of combinations and nothing worked.

I was finally able to upgrade to TC7.1.1 once we did the factory reset. Backup was made and returned using TMS. For those who dont have TMS remember that from TC6 and upwards you can make a standalone backup.

595
Views
5
Helpful
2
Replies
CreatePlease login to create content