Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

No video with back to back ISDN gateways.

   I just had a very interesting 3 days of troubleshooting videoconferencing calls that losses video or does not connect video when dialling trough an ISDN gateway to another ISDN gateway and connecting to a video systems DID.

Equipment on Client Site (Dialing from)

1. Cisco C20

2. Cisco C60

3. ISDN GW 3241

All codecs register to internal gatekeeper of ISDN GW 3241

Equipment of Site 1 that I dialed to

1. Cisco C20 - Software build TC 4.2.2

2. Cisco C40 - Software build TC 4.0.1

3. ISDN GW 3241 - Software build 2.0(1.51)P

4. VCS Control - Software build 7.1

All codecs and ISDN GW register to VCS Control with an E164/DID and 8 prefix for video dialling out.

Equipment of Site 2 that I dialed to

1. MXE 8510 Media 2 Blade - With Meeting room and ISDN DID - Software Unknown

2. MXE 8321 ISDN GW Blade - Software Unknown

3. VCS Control -Software Unknown

All blades registered with VCS Control

Equipment of Site 3 that I dialed to

1. 3rd party ISDN GW - Unknown

2. Polycom HDX - Software Unknown

3. Cisco EX 90 - Software Unknown

4. Cisco C20 - Software Unknown

All systems register with a gatekeeper and has an DID assigned to them.

Problem description

When placing ISDN calls to any of the above sites DID from -

Equipment on Client Site (Dialing from)

1. Cisco C20 - Software Build TC 5.1

2. Cisco C60 - Software Build TC 5.1

3. ISDN GW 3241 - Software Build 2.1 (1.49)P

The call connects and the audio is stable, but one of the following happens:

* Call connects with two way video and after a couple of minutes the video drops one way or both ways.

* Call connects with only one way video.

* Call connects with no video

Troubleshooting Steps

Step 1: Ruled out network by connecting different codec's directly to ISDN GW - Still experienced the same result

Step 2: Ruled out the ISDN GW by replacing it with the same model and software build - Still experienced the same result

Step 3: Not ruled out yet, but used a different ISDN E1 (PRI) - Still experienced the same result

Step 4: Downgraded the ISDN GW to version 2.0 - Still experienced the same result

Step 5: Downgraded the C-Series Codec's to TC5.0 - Still experienced the same result.

Step 6: Downgraded the C-Series Codec's to TC4.2.2 - Start getting better results

Step 7: Upgrading ISDN GW back to 2.1 - Experienced the same results as other steps.

After downgrading the ISDN GW to version 2.0 and the C-Series Codec's to 4.2.2, the video started staying up.

Questions

1. Is the ISDN GW's backward compatible?

2. Is this a known bug that I am missing in the release notes?

3. When will a new software build or patch be released as the last one was September 2011?

5 REPLIES
Community Member

Re: No video with back to back ISDN gateways.

1. Is the ISDN GW's backward compatible?

Yes the ISDN GW should be backward compatible

2. Is this a known bug that I am missing in the release notes?

None that i know of.

As a matter of interest, have you tried called using different video protocols to see if one of them is giving you your error.

I had an ISDN GW that would always connect on H263, I disabled that protocol on the ISDN GW and the calls then connected at H264 and everything worked from there.

Community Member

Re: No video with back to back ISDN gateways.

Hi Haydn,

I disabled and enabled all video and audio protocols, but nothing.

What i did see is that if you have two sites with ISDN GW both on 2.1 and the codec's on TC 5.1, the calls work 100%, as soon as you dial to a older software build or a 3rd party ISDN GW, the problems starts.

I had a look at the Release notes of the C-Series TC 5.1, under compatibility section they show more than one software version for certain infrastructure but for the ISDN GW 3241 they only show software version 2.1

Also under the open caveats in the document they have one for video not working with the old Tandberg ISDN GW and older Tandberg VC units, so it might be a problem with other systems as well.

Just hoping that a new software build will resolve this.

Community Member

No video with back to back ISDN gateways.

If you would like to test to a 3rd Party site I am available.

I have a I MSE 8321 ISDN GW

I would also be interested to see if connecting the calls from an MCU would have any effect as the MCU can transcode different protocols.

PM me if you would like to test.

Community Member

No video with back to back ISDN gateways.

Hi Burt,

I know since the release of our ISDN GW 2.1 sw version and TC4 and above, we have dramatically improved the interoperability with our C series endpoints.

Unfortunately off the top of my head I cannot pinpoint a specific bug for you to reference, but i had previously experienced problems myself in our lab with back to back ISDN GW calls from C series endpoints and the new sw releases had improved this functionality.

This is why we ALWAYS recommend customers to be on the latest sw releases as there are many additional bugs that are fixed, but unfortunately we cannot fit them all into the software release notes.

I will keep searching our database for you and if i come across the specific bugs i am looking for in reference to this scenario i will post them here for you

Thanks.

Nathan.

Community Member

No video with back to back ISDN gateways.

Hi Nathan,

Thanks for the response,

For now I am keeping the client on the old software as they seem to be more compatible with other ISDN GW's

Do you know when a new software release will be available for the ISDN GW's?

Regards,

434
Views
0
Helpful
5
Replies
CreatePlease to create content