Cisco Support Community

Setup an SX10 using MRA

Hi guys

i seem to be having a slight issue with the above. The error im getting on the VCS-C Expressway is as follows

edgeconfigprovisioning: Level="INFO" Detail="Failed to find username or token in request."
|GET /dW5kc2x2Yy5jb20/get_edge_config/ HTTP/1.1
Via: https/1.1 vcs[C0000203] (ATS), http/1.1 vcs[0AFAFE14] (ATS)
X-Forwarded-For: <MY HOME DSL PUBLIC IP>,
Accept: text/xml
User-Agent: Cisco/TC
Accept-Charset: ISO-8859-1,utf-8
Content-Type: application/x-www-form-urlencoded


Im not using this for Jabber for now i just want to be able to connect a few video devices, particularly the SX10.

Additional Notes

1. The SX10 registers fine internally

2. username and password is the end user credentials that i use daily

3. the domain name is different internally versus externally

4. for testing , i used a W2K8 server to generate the appropriate certificates - looks like this is working

5. SRV records populated based on documentation

6. Not using IM internally and this isnt being tested at this point in any event

7. Software version 8.2.1

8. Not using TLS Verify Mode on to the CUCM at this point and therefore no CA trust uploaded to the CUCM at this point in time



Appreciate any feedback




Im sure someone will be

Im sure someone will be searching around soon..... this document is good..


Good luck

Community Member

Hi,Did you find a fix for


Did you find a fix for this, I'm hitting the same problem you were? Any info you could provide would be appreciated.


Mikee, I did and I have them



I did and I have them registering fine.

im jogging my memory here so if I recall after this post I did the following

1. Loaded the server certificate on the sx10

2.Re-checked and adjusted my firewall rules (this was the biggest issue)

3. Username is ext@(private ip) in the sx10 setup


Send me a pm and I can send u off some info on the current build if you are not getting through still.

note that my system uses the single nic setup on the expressway-e so it was a little tricky when it came to the fw.

here to help and btw it does work good when its up, the sx10 has great quality as well, the effort will pay off :)



Community Member

Thanks for the reply. The

Thanks for the reply. The customer has the same set up, single nic on the expressway-e, they have a third party manage the firewall and its taken over 2 weeks for correct rules to be in place to get the Jabber clients working correctly so this could still be an issue. They also have split domains which have complicated things even more.

I'll try the things you suggested and see if I can get anywhere on Monday and let you know. I have seen hits on the CUCM via the traces but they didn't throw much light on what could be causing it.


I took 3 weeks to get my

I took 3 weeks to get my firewall sorted (im not a firewall guy so I kinda had to learn quickly) using 3rd party as well.

some other things I discovered just as an fyi

1. Get good certs and not windows like I did :)

2. You cant call out unless u have rich media licenses - sounds basic but I didnt know

I also have two domains since the actual domain hosts didnt support srv so I bought another.

again here to help as it was a pain and im still tweaking stuff. 

Fyi tac is actually fairly good imo with collab edge so also try them (u need to call these guys dont wait on emails)

Community Member

Tried everything but still

Tried everything but still the same. Have managed to get a copy of the access lists and config from the ASA and have cornered one of our security guys to see if he can spot anything.

Not sure when it happened but error I'm seeing on the touchpad is "The Cisco UCM service timed out" but the logs still show the same error you were getting.

I've also raised a TAC case and am waiting on the engineer to get in contact.


Shoot me a pm. Ill send you

Shoot me a pm. Ill send you my rule setup as well if you need.



Community Member

hi Mikee, I show that SX10

hi Mikee,


I show that SX10 require 3 parameter:

-Username => ext@(private IP)

-Password => ?????

-Domain => domain that point to External IP.


What is this password ???


Community Member

Username = CUCM Enduser

Username = CUCM Enduser ID

Password = CUCM End User Password

Domain = VCS-E, VCS-C Domain

CreatePlease to create content