Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Strange Tandberg C20 Network Issue

I have three Tandberg C20 codecs at our office.  I have our network vlan'd with separate client, print, voice (Cisco CUCM phones) and AV vlans.  On top of that, I have each of those vlans separated between each floor of our office.  This network and the codecs have been in use for the last 3.5 years with no issue.

A few months ago, all of a sudden none of the codecs were able to make or receive any video calls.  After a reboot of the firewall (ASA 5510) two of the three codecs started working again.  The third still has issues, hence this post.  At this point, the problematic codec is having trouble even getting on the network.  Here's the strangeness:

  • When put on its AV vlan for its floor (vlan 415) it cannot talk on the network with a static IP
  • When moved to another AV vlan from another floor, one that one of the other codecs are on and are working, it cannot talk on the network with a static IP for that vlan
  • When put on a voice subnet used for the phones (using the switchport config "switchport voice vlan xxx") it gets a dhcp address and is accessible.  The interesting thing on that, is that switchport config had both swtichport vlan configs on it like this:

interface GigabitEthernet5/41

switchport access vlan 401

switchport mode access

switchport nonegotiate

switchport voice vlan 410

auto qos voip cisco-phone

qos trust device cisco-phone

spanning-tree portfast

service-policy input AutoQos-VoIP-Input-Cos-Policy

service-policy output AutoQos-VoIP-Output-Policy

end

When the codec went on that switchport with that config, it went on the voice vlan of 410 and got a dhcp address for that vlan instead of going on vlan 401 and getting a dhcp address on that.

  • When put on a client vlan (like vlan 401 from above config) with dhcp configured and no voice vlan configured, it will not get a dhcp address

I just don't get it.  I used two different switchports on the floor's access switch, tried multiple static IP addresses on each of the other vlans.  It seems the ONLY way this codec will talk on the network is putting it on the voice vlan with that switchport config.  I have other devices on that AV vlan that don't have any problem talking on the network.  It's only this codec.  I'm just wondering if there's something in the config of this codec creating this problem, but nothing stood out to me looking through it.

Codec is on version 6.0.1

original switchport config:

interface GigabitEthernet5/41

switchport access vlan 415

switchport mode access

spanning-tree portfast

end

vlan interface config

interface Vlan415

description 19th floor av network

ip address 10.19.15.2 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

no ip mroute-cache

standby 0 ip 10.19.15.1

standby 0 priority 105

standby 0 preempt

standby 0 authentication xxx

end

Any ideas is greatly appreciated.  Let me know if you would like any other details.  Thanks!

3 REPLIES
Cisco Employee

Strange Tandberg C20 Network Issue

Hi Rayan,

What is software version for working and non working codec ,

I suspect this issue is related to bug and which is having fic in TC 6.1.1.

CSCug47392  When an SX20 running TC6 is placed in a VLAN with a static IP address the unit will

not be reachable on the network.

hth

Kind regards,

Dharmmesh

New Member

Strange Tandberg C20 Network Issue

Thanks for the reply.  That is interesting.  This non-working codec and one of the other working codecs are at 6.0.1.  I just upgraded the other working codec from 3.5 to 6.0.1 the other day, and that continues to work, but I guess that doesn't mean it will continue to work.

The broken codec was at 6.0.0 and just today I updated it to 6.0.1.

The only other thing in the config I was just just looking at on the codec was in the general network settings at the bottom, the working codec is set to OFF for Voice Vlan Mode, and the broken one was set to Manual.  Not sure if that would make a difference.

I'll definitely check out that bug, though, and try to update the codec to at least 6.1.1.

Thanks

New Member

Strange Tandberg C20 Network Issue

Got this figured out.  Ended up not being the bug suggested above, as I upgraded to 6.2.0 as suggested.  What it ended up being was the vlan voice mode.  It was set to manual.  Once I set it to off it started working on the normal subnet.  So, my issue is resolved!

However, I'm going to now look into integrating it with our CUCM, so maybe I'll have to end up putting it back on the voice vlan!

Thanks

1001
Views
0
Helpful
3
Replies
CreatePlease to create content