Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

TMS(14.3.1) PhoneBook Issue.

Hi,

While configuring 'Phone Book Server 1' in endpoint, I found a issue.

I set the phone book server in endpoint as TMS URL. So It was like http://xx.xx.xx.xx/tms/public/external/phonebook/phonebookservice.asmx (xxx indicates IP address of TMS)

But I decieded to use DNS server to interwork with TMS. Then TMS server now has the Domain Name allocated from DNS.

Also I set the value of Domain address to 'Phone book server 1 URL' in endpoints and It was like http://abc.efgh.com/tms/public/external/phonebook/phonebookservice.asmx (abc.efgh.com indicated Domain Address of TMS).

Since phone book services are from TMS, I made that change. However, after a while, This phone book server URL was changed to IP address  automatically.

I tried some different way to set the domain address of TMS, but everything was failed. DNS hostname was fully qualifed as well.

I don't still understand why this behavior has happened. It is something like a bug.

Here is my trial:

1. Check If the 'Default configuration template for discovered systems' could affect on it.

     - enable/disable or enable with fillng Domain address in the 'Phonebook Server 1 URL' value. But It doesn't affect on it at all.

2. Check If the 'Enforce Manangement Settings on Systems' could affect on it.

     -Set value as 'No', But It doesn't affect on it at all.

3. Check If the 'Update System Connectivity for Systems' could affect on it.

     -Set value as 'Manual'. But It doesn't affect on it at all.

4. I will attach General Settings in TMS regarding to Phone book configuration.

Is there anybody who has the same problem or workaround for it?? should I open a case..?

Regards,

Paul.

1 ACCEPTED SOLUTION

Accepted Solutions

TMS(14.3.1) PhoneBook Issue.

Would've been good if you could've done the same from the end-point, but I don't believe it is possible to run nslookup from the admin log in using SSH, might be able to do it from root though - never tried, so don't know.

However, if wireshark is showing TMS consistently sending IP address instead of FQDN, then it might be time to open a TAC case.

/jens

Please rate replies and mark question(s) as "answered" if applicable.

Please rate replies and mark question(s) as "answered" if applicable.
13 REPLIES

TMS(14.3.1) PhoneBook Issue.

You need to tell us end-point type and software version they are running.

I'm using FQDN address in both MXPs (F9.3.x) and C-series (TC6.3) and do not see this issue.

Also, has the TMS FQDN address been set in TMS/Administrative Tools/Configuration/Network Settings?

/jens

Please rate replies and mark question(s) as "answered" if applicable.

Please rate replies and mark question(s) as "answered" if applicable.
New Member

TMS(14.3.1) PhoneBook Issue.

Hi Jens,

My endpoint was MX200 that has C-20(TC6.3).

I set all of those thing that you mention there. FQDN set was totally fine when I save the configuration.

I will attach the capture file of it.

Strangely, I couldn't delete TMS Server IPv4 Address above. After making that field blank, It shows the IP address again.

Regards,

Paul.

Cisco Employee

TMS(14.3.1) PhoneBook Issue.

Hi

As Jens is saying you need to have the TMS FQDN typed in the network settings as these are the addresses TMS uses to push the phonebook URL. If you only have IP typed in then TMS will push IP. FQDN will be preffered over IP if this is typed in. DNS Override also need to be set to "No" (default). You need the enforce management settings set to Yes.

/Magnus

New Member

TMS(14.3.1) PhoneBook Issue.

Hi Magnus,

As I said, It was already set as FQDN. You can refer to the image that I attached above.

Cisco Employee

TMS(14.3.1) PhoneBook Issue.

Where is the system located? Is it reachable on LAN or is it on the public internet or behind firewall?

/Magnus

New Member

TMS(14.3.1) PhoneBook Issue.

It is reachable on LAN.

Thanks for caring.

Paul.

Cisco Employee

TMS(14.3.1) PhoneBook Issue.

This is also the status in TMS correct? It might be reachable on LAN but you can change the status in TMS to "public internet" or "behind firewall" even if the system is reachable by TMS on LAN. TMS uses this connectivity status to decide which address it will send.

Connectivity: Reachable on LAN

TMS will use the FQDN typed in this field for systems which has the "Reachable on LAN" status, if it has behind firewall, or Reachable on Public internet it will use the other FQDN field.

If you have more than 1 TMS and the system is added to more than 1 TMS server you can see issues with both TMS´s are pushing their addresses to the system making them change from one to the other.

If you start a wireshark trace on the TMS server and then go to the system in TMS system navigator, click edit settings, then click the button at the bottom: Enforce Management Settings

Now you should find a HTTP packet from TMS to the system which shows what address TMS is sending to the system.

Make sure Override DNS is set to "No" as "Yes" will push IP regardless.

/Magnus

New Member

TMS(14.3.1) PhoneBook Issue.

It would be better if I attach the snapshow of configuration.

Um, what if TMS is sending IP address according to wireshark?

Apparently there is no misconfiguration.

Thanks,

Paul

TMS(14.3.1) PhoneBook Issue.

Did you add the server to the domain and was the hostname set on the server itself, not only within the TMS application?

If you RDP to the server and do a nslookup from there on both IP address and hostname, do both resolve to the correct address?

/jens

Please rate replies and mark question(s) as "answered" if applicable.

Please rate replies and mark question(s) as "answered" if applicable.
New Member

TMS(14.3.1) PhoneBook Issue.

Hi Jens, thanks for the reply.

I added domain to the server, and hostname was correctly wrriten on the server.

I'm attaching the image that has been captured from the server. Each color has the same value.

Regards,

Paul.

TMS(14.3.1) PhoneBook Issue.

Would've been good if you could've done the same from the end-point, but I don't believe it is possible to run nslookup from the admin log in using SSH, might be able to do it from root though - never tried, so don't know.

However, if wireshark is showing TMS consistently sending IP address instead of FQDN, then it might be time to open a TAC case.

/jens

Please rate replies and mark question(s) as "answered" if applicable.

Please rate replies and mark question(s) as "answered" if applicable.
New Member

TMS(14.3.1) PhoneBook Issue.

Thanks for reply, Jens.

But I found something strange, on our customer site, It is working well. But with our lab, It appears the same.

I have concluded this as a problem of configuration of DNS so far.

I will add an update when problem solved.

Have a great day.

TMS(14.3.1) PhoneBook Issue.

Thanks for the feedback, Paul. +5 for that.

Looking forwards to hearing what caused this.

/jens

Please rate replies and mark question(s) as "answered" if applicable.

Please rate replies and mark question(s) as "answered" if applicable.
579
Views
5
Helpful
13
Replies