Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

TMS Provisioning Extension Error - TMSPE Wrapper Error

The TMSPE Installation installed successfully, or so the log says.  However when the TMSPE service is started, this error shows up in the log and the service will not start.

STATUS | wrapper  | 2012/08/01 07:22:03 | --> Wrapper Started as Service

STATUS | wrapper  | 2012/08/01 07:22:03 | Java Service Wrapper Standard Edition 32-bit 3.5.13

STATUS | wrapper  | 2012/08/01 07:22:03 |   Copyright (C) 1999-2011 Tanuki Software, Ltd. All Rights Reserved.

STATUS | wrapper  | 2012/08/01 07:22:03 |     http://wrapper.tanukisoftware.com

STATUS | wrapper  | 2012/08/01 07:22:03 |   Licensed to Cisco Systems, Inc. for Cisco TMS Provisioning Extension

STATUS | wrapper  | 2012/08/01 07:22:03 |

STATUS | wrapper  | 2012/08/01 07:22:04 | Launching a JVM...

INFO   | jvm 1    | 2012/08/01 07:22:04 | Error occurred during initialization of VM

INFO   | jvm 1    | 2012/08/01 07:22:04 | Could not reserve enough space for object heap

INFO   | jvm 1    | 2012/08/01 07:22:04 | Error: Could not create the Java Virtual Machine.

INFO   | jvm 1    | 2012/08/01 07:22:04 | Error: A fatal exception has occurred. Program will exit.

ERROR  | wrapper  | 2012/08/01 07:22:04 | JVM exited while loading the application.

After a little research, I found that Tanuki wrapper uses wrapper.conf to configure, but there is no wrapper.conf.

Does anyone have an idea of how to solve this?

Thank you

Everyone's tags (6)
12 REPLIES

Re: TMS Provisioning Extension Error - TMSPE Wrapper Error

First of all do you have the latest Java upgrades and enough available ram and hd space?

I remember there were some old Java system enviroment settings

(check on control panels > system > advanced > enviroment variables if something else like

listed java args are listed and make a screenshot.

It might be that additional setting with sets less ram which locks it up.

Please remember to rate helpful responses and identify

New Member

TMS Provisioning Extension Error - TMSPE Wrapper Error

I have run TMSPE on multiple TMS servers without a problem.  Each of them have Java version 7 update 5. 

The server that is having the problem is running the same version of Java.

I found the OpenDS args as displayed in your post.  However, OpenDS does not seem to be the error.

I found the wrapper.conf.  It contains a reasonable heap allocation.

# Initial Java Heap Size (in MB)

#wrapper.java.initmemory=3

wrapper.java.initmemory=256

# Maximum Java Heap Size (in MB)

#wrapper.java.maxmemory=64

wrapper.java.maxmemory=1024

I even tried doubling them up.  Initial memory to 512 and maxmemory to 2048.  It resulted in the same error in tmsprovisioningextension-wrapper.log

TMS Provisioning Extension Error - TMSPE Wrapper Error

can you please check on the system enviroment variables.

Please remember to rate helpful responses and identify

New Member

TMS Provisioning Extension Error - TMSPE Wrapper Error

re: can you please check on the system enviroment variables.

New Member

TMS Provisioning Extension Error - TMSPE Wrapper Error

Sorry, I did not answer your 2 other questions

First of all do you have the latest Java upgrades and enough available ram and hd space?

4GB of RAM

26GB available disk space.

TMS Provisioning Extension Error - TMSPE Wrapper Error

Thx. I only remembered that during the EFT something was mentioned regards some old

wrong system variable values which then locked something up.

Do you have other (Java) tools installed on that TMS? Is it a quite "old" installation?

Any other processes running?

How would you describe the size of the deployment (for large installs 8gb ram shall be present).

Did you try to remove the TMSPE, reboot the TMS and reinstall it again?

For now you can also just switch back to the legacy (opends) mode to have a

working enviroment.

If you do not get a better feedback or you can not wait and you have a valid service contract,

use the escalate as a service request function on the right top to send this case to Cisco TAC.

If you fixed the issue, please update us how you did it :-)

Good luck,

Martin

Please remember to rate helpful responses and identify

New Member

TMS Provisioning Extension Error - TMSPE Wrapper Error

Martin,


Thanks. I will update the board, once the problem is resolved.  I like to try these boards first, before using support, as there is always good info here.  This TMS was first installed about 18 months ago.  It has been upgraded from late 12's to the current 13.2.

Nothing else is really running on it.  It is very clean.  I disabled MS Forefront security before installing.

I have uninstalled TMSPE numerous times, trying different scenarios including rebooting the server.

The size is of the deployment is about 60 endpoints and at any one time 30 Jabber accounts.

Yes, I have switched back to legacy and will have to wait until off hours again to work on this.

Thanks for your help.

Cisco Employee

TMS Provisioning Extension Error - TMSPE Wrapper Error

What OS is this? HW or VM? If VM, are these dedicated resources, i.e. in particualar memory? Is it completely up to date with MS hotfixes, etc? Java updated?

And as this appears to be a migration to TMSPE, are you running the migration tool at the end of the install? For example, I'm trying to determine when your seeing the service not being able to start, e.g. when the migration tool is running or after?

And the only time I've seen this is when there hasn't been enough resources available on the system, in particular when running the migration tool since both opends and TMSPE need to be running at the same time so has to do the migration.

New Member

TMS Provisioning Extension Error - TMSPE Wrapper Error

Dale,

Thanks for the feedback. 

OS: Windows Server 2008 Standard 6.0 Build 6002 - It is up to date with hotfixes. Java is up to date as well.  TAC has said we might need to downgrade our java from 7 to 6.

VM: VMWare - I am waiting for the version and resource commitment

When the installation is completed "successfully", I look at the services and the TMS Agent and opends are not running.

TMSPE is not running either.

Looking at the log files, it does not seem to run the migration tool.

Here are the last bits of the install log.

Property(C): SQLPROTOCOL = TcpIp

Property(C): TMSMAJORVERSION = 13

Property(C): TMSMINORVERSION = 2

Property(C): TMSBUILDVERSION = 0

Property(C): LOGPROP = TMSPE (DEBUG): Sql Connection closed successfully

Property(C): ConfigDBExists = YES

Property(C): SqlConnectionStatus = OK

Property(C): LAUNCHMIGRATIONTOOL = 0

Property(C): ConfigDBCompatible = YES

=== Logging stopped: 8/1/2012  9:14:21 ===

MSI (c) (60:08) [09:14:21:309]: Note: 1: 1707

MSI (c) (60:08) [09:14:21:309]: Product: Cisco TMS Provisioning Extension -- Installation completed successfully.

MSI (c) (60:08) [09:14:21:309]: Windows Installer installed the product. Product Name: Cisco TMS Provisioning Extension. Product Version: 1.0.159. Product Language: 1033. Installation success or error status: 0.

MSI (c) (60:08) [09:14:21:324]: Grabbed execution mutex.

MSI (c) (60:08) [09:14:21:324]: Cleaning up uninstalled install packages, if any exist

MSI (c) (60:08) [09:14:21:324]: MainEngineThread is returning 0

=== Verbose logging stopped: 8/1/2012  9:14:21 ===

Cisco Employee

TMS Provisioning Extension Error - TMSPE Wrapper Error

Hi John,

As this is VMWare, it will be interesting to hear whether they've completely dedicated these resources to the TMS or whether they're shared. If they're shared, then you need to have your VM guys dedicate these resources to the TMS server.

As far as downgrading the java, there is a TMS related tech alert out on java 7 update 5 concerning breaking the CCC in TMS (only clients on Windows 7 are affected), but this obviously has nothing to do with TMSPE.

As far as the services goes, and after upgrading and migrating to TMSPE, only the TMSAgentService and TMS Provisioning Extension service should be running.

As far as the migration part, it doesn't appear as though you've run it...meaning did you select it during the installation of TMSPE when asked? Are you following the 'step by steps' when migrating from legacy TMS Agent in the TMSPE deployment guide?

In any case, and because this is VM, my bet is still on lack of resources

New Member

TMS Provisioning Extension Error - TMSPE Wrapper Error

Ok, all is good now.

When I downgraded Java to 6.33 I did not get the resource problem anymore.

When TMSPE installed, it did not automatically run migration, so I ran it manually. It failed as OpenDS was not running.

After starting OpenDS manually, I re-ran migration which ran successfully.

I also ran into a problem when trying to enable TMSPE on the VCS Control.  It did not like the Windows local administrator that was also administrator of TMS. 

I used my active directory account which had administrator privileges.

Thank you for all the help.

New Member

TMS Provisioning Extension Error - TMSPE Wrapper Error

I just had the same issue.  I think a server guy updated Java to Version 7.  I uninstalled version 7 and reinstalld vesion 6 and it worked! The TMSPE install notes says that java has to be 32-bit version 6.

Cheers,

Robert

3003
Views
0
Helpful
12
Replies
CreatePlease login to create content